none
CRM 2011 Workflow Send email Draft Status

    السؤال

  • Have a problem which is causing me major headaches,

    I have several workflows with send emails from a support account to contacts on resolution of a case.  The emails get created, and then imediately enter DRAFT status.  I have already checked the workflow to make sure that the SEND email is being used and not the create.  Running a trace revealed no errors.

     

    Help!

     

    Tony

    24/شوال/1432 11:04 ص

الإجابات

  • The emails go to Draft mode


    I can not think of a scenario where an e-mail generated by workflow, using the "Send E-mail" step, would go to Draft status.  When the Send E-mail step is used, the workflows goes to a Pending Send status and then either failed, cancelled or completed.  If it were me, I would investigate further to try and track down when and how the failed e-mails are generated.  I suspect somewhere there is a workflow that is generating a Create E-mail step or a user that is creating the e-mail and not hitting the Send e-mail button.

    I would also open the E-mail Router Configuration Manager and go to the Load User, Queue, Data tab and ensure that all users are loading as expected and the Test Access is succesful.  Also, have each of the user's create an e-mail from CRM and to a e-mail address outside your network then select Send  E-mail to ensure things are working as expected.


    Regards, Donna

    • تم الاقتراح كإجابة بواسطة Donna EdwardsMVP, Owner 27/شوال/1432 10:51 م
    • تم إلغاء اقتراح كإجابة بواسطة TD-CRM 28/شوال/1432 08:20 ص
    • تم وضع علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:39 م
    27/شوال/1432 10:50 م
    المالك
  • Thanks for confirming what I stated above: 

    "I can not think of a scenario where an e-mail generated by workflow, using the "Send E-mail" step, would go to Draft status"

    I suspect there is a different workflow running or a different step in the existing workflow with a create e-mail rather than send e-mail step,  the e-mails that are in draft status are not generated from the workflow or something different.  Please see my post above for reference.


    Regards, Donna

    • تم وضع علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:40 م
    29/شوال/1432 12:56 م
    المالك

جميع الردود

  • Greetings,

    Can you send emails normally out of the system without problems?

    Does the sender used for the email (The system user) have an email address registered on his form?

    Is the email address approved in CRM (There is a Server setting that only sends out if email is approved)? 


    Halldór Jóhannsson
    24/شوال/1432 11:14 ص
  • Thanks for the quick response

     

    It doesn`t happy everytime, some times it sends with no issues, othertimes it gets stuck

    Email address is both registered and approved

    24/شوال/1432 11:21 ص
  • It will not be able to send if th user does not have the privilege to send emails on behalf of another user. But if you say it works sometimes, it is strange. Is it an automatic or an on-demand workflow?

    Gonzalo | gonzaloruizcrm.blogspot.com

    • تم وضع علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:38 م
    • تم إلغاء علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:40 م
    24/شوال/1432 11:23 ص
    المشرف
  • It happens if I run it as either on demand or automatic

     

    Its really really frustrating me

    24/شوال/1432 11:26 ص
  • Are you sure the email is in draft mode? Or is it in "Pending Send" mode?

    Gonzalo | gonzaloruizcrm.blogspot.com

    24/شوال/1432 11:35 ص
    المشرف
  • Am I correct in assuming you always use the same User as the sender when sending out?

    Is that users in and outgoing settings set to use the email router or outlook?


    Halldór Jóhannsson
    24/شوال/1432 11:37 ص
  • It happens with two user accounts that I have tested so far

     

    Both are using Outgoing as Email router

    24/شوال/1432 11:40 ص
  • I have also noticed that the emails that do send...take up to 6 minutes to send

     

    Tony

    24/شوال/1432 11:41 ص
  • The emails go to Draft mode
    24/شوال/1432 11:54 ص
  • Yes, the email router does take a while to sync, I think default setting is to check every 15 minutes if there is a new email to send, you can configure that in the email router config file (have to edit with notepad or any other text editor, UI does not allow changes to these settings).

    If you open up the email message that is not being sent out do you get any error message there?

     


    Halldór Jóhannsson
    24/شوال/1432 12:43 م
  • NO error messages at all in the acutual email
    24/شوال/1432 01:21 م
  • The emails go to Draft mode


    I can not think of a scenario where an e-mail generated by workflow, using the "Send E-mail" step, would go to Draft status.  When the Send E-mail step is used, the workflows goes to a Pending Send status and then either failed, cancelled or completed.  If it were me, I would investigate further to try and track down when and how the failed e-mails are generated.  I suspect somewhere there is a workflow that is generating a Create E-mail step or a user that is creating the e-mail and not hitting the Send e-mail button.

    I would also open the E-mail Router Configuration Manager and go to the Load User, Queue, Data tab and ensure that all users are loading as expected and the Test Access is succesful.  Also, have each of the user's create an e-mail from CRM and to a e-mail address outside your network then select Send  E-mail to ensure things are working as expected.


    Regards, Donna

    • تم الاقتراح كإجابة بواسطة Donna EdwardsMVP, Owner 27/شوال/1432 10:51 م
    • تم إلغاء اقتراح كإجابة بواسطة TD-CRM 28/شوال/1432 08:20 ص
    • تم وضع علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:39 م
    27/شوال/1432 10:50 م
    المالك
  • Hi Donna,

    I have tried everything you haqve suggested but with no luck.

     

    I am going to keep investigating

     

    Tony

    28/شوال/1432 08:20 ص
  • Hi Tony,

    I would provide information on delay of sending email using Email Router.

    Open the outgoing profile in your email rotuer, click "Advanced" tab, you will see an item called "Polling Period", that's where you can set interval time of routing action for email router.

    Please also check email router service status: running or stopped, when you have much delay.

     

    Leola


    This posting is provided “AS IS” with no warranties, and confers no rights.Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Leola Xu Microsoft Online Community Support
    29/شوال/1432 07:45 ص
  • Hi Tony,

    I have tested a workflow with sending email actions. "Draft" should not be result of the action.

    May you test the workflow by triggering the workflow, then navigate to System>System Jobs, check the "Status Reason" of the workflow. If it's not working as your workflow designs, the status should not be succeeded.

    Leola


    This posting is provided “AS IS” with no warranties, and confers no rights.Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Leola Xu Microsoft Online Community Support
    29/شوال/1432 08:08 ص
  • Thanks for confirming what I stated above: 

    "I can not think of a scenario where an e-mail generated by workflow, using the "Send E-mail" step, would go to Draft status"

    I suspect there is a different workflow running or a different step in the existing workflow with a create e-mail rather than send e-mail step,  the e-mails that are in draft status are not generated from the workflow or something different.  Please see my post above for reference.


    Regards, Donna

    • تم وضع علامة كإجابة بواسطة TD-CRM 01/ذو الحجة/1432 03:40 م
    29/شوال/1432 12:56 م
    المالك
  • Hi

    Was there ever a resolution to this? I am using the email router to send out an email generated using workflow and the email is created in Draft status and is never sent.  The workflow is using Send Email - in fact there isn't Create Email - CRM 2011 Online - but the email remains in draft.   I am sending the email to a Facilities/Equipment that has an email address.   The sender email address is approved and is set to send via email router. 

    Any help would be greatly appreciated.   Thanks Caroline

    05/ذو القعدة/1432 08:41 ص
  • I've the same problem... any hints?
    14/ذو القعدة/1432 02:50 م
  • I still have the problem also - No idea :(
    14/ذو القعدة/1432 02:52 م
  • I have finaly found the solution - Somebody had created a workflow that was designed to set an email to Draft.  It should of been "on Demand" Only, however it was also selected for all created emails.  This is why emails would fail on the first send, but would re-send imediately.

     

    Will give FULL credit to posters that said Workflow - Completly overlooked this and feel silly for it now.

     

     

    01/ذو الحجة/1432 03:38 م