locked
SignTool reported an error - The signer's certificate is not valid for signing

    Question

  • I'm having a problem publishing an application written in VB.NET in VS2005 using ClickOnce.

    I get the error:

    Code Snippet

    Error    2    SignTool reported an error 'Failed to sign bin\MyApp.publish\\setup.exe. SignTool Error: ISignedCode::Sign returned error: 0x80880253

        The signer's certificate is not valid for signing.

    SignTool Error: An error occurred while attempting to sign: bin\MyApp.publish\\setup.exe

    '.    MyApp



    I have just installed visual studio 2008 - could this be causing the problem? Any idea how to get round it?
    Thursday, 14 February, 2008 4:05 PM

Answers

  • I sorted it. I went to the project properties, clicked Signing, then Create Test Certificate. It warned me about it being signed differently when I published it but it worked and my app updated succesfully when I ran it.


    EDIT

    The above didn't work. I needed to renew my certificate using the renewcert thing you can find here:
    http://support.microsoft.com/kb/925521
    Thursday, 14 February, 2008 4:12 PM

All replies

  • I sorted it. I went to the project properties, clicked Signing, then Create Test Certificate. It warned me about it being signed differently when I published it but it worked and my app updated succesfully when I ran it.


    EDIT

    The above didn't work. I needed to renew my certificate using the renewcert thing you can find here:
    http://support.microsoft.com/kb/925521
    Thursday, 14 February, 2008 4:12 PM
  • Yes, you can create a new certificate, but if this is a problem for your users see the topic under the topic Words of Warning in the below link:

    http://www.infoq.com/articles/ClickOnce-Versioning

    which has a link to the instruction on how to extend the expiration date of a certificate.

    http://support.microsoft.com/Default.aspx?kbid=925521

    Thursday, 25 September, 2008 2:54 PM
  • Thanks, this worked for me too.

    My problem symptom was getting a 404 error when trying to download the setup.exe from the web server.
    Joseph Nielsen
    Thursday, 23 July, 2009 2:20 PM
  • Thanks J. Mitchell. I was having a same issue and i fixed it with your help.

    Regards,

    Tuesday, 3 August, 2010 6:14 AM