none
CRM 2011 installation Microsoft.Crm.Setup.Server.GrantAspNetServiceAccountAccessAction failed.

    Question

  • I Start to installation, when its starts to create organization web service error appear. All other roles installed correctly.

    Can you please help.

    Here the log :

     Error| System.Exception: Action Microsoft.Crm.Setup.Server.GrantAspNetServiceAccountAccessAction failed. ---> System.ArgumentException: The parameter is incorrect.

       at System.DirectoryServices.Interop.UnsafeNativeMethods.IAds.PutEx(Int32 lnControlCode, String bstrName, Object vProp)
       at System.DirectoryServices.PropertyValueCollection.set_Value(Object value)
       at Microsoft.Crm.Setup.Server.Utility.ADUtility.GrantAccess(DirectoryEntry groupEntry, String accountName)
       at Microsoft.Crm.Setup.Server.GrantAccessToServiceAcountAction.Do(IDictionary parameters)
       at Microsoft.Crm.Setup.Common.CrmAction.ExecuteAction(CrmAction action, IDictionary parameters, Boolean undo)
       --- End of inner exception stack trace ---, Error, RetryCancel, Option1

    Friday, October 05, 2012 11:39 AM

All replies

  • Are you logged in as Administrator when you create the organisation?

    Roar Jørstad aka sveroa
    Senior Consultant, EVRY as
    Blog: Notebook, trick & tips
    Please mark as answer or helpful if my post is useful

    Friday, October 05, 2012 1:00 PM
  • Yes I Logged in as Domain Administrator for installation.

    Setup didn't create organization. Its give error when its installing to services.

    Application service created web site created but organization service giving that error.

    Friday, October 05, 2012 7:36 PM
  • Hi

    I encoured the same issue installing MS CRM DYNAMICS 2011.

    We have an application server and SQL server on two different box.

    The account used to install is Admin of the two box.

    Info| Executing Install action: Microsoft.Crm.Setup.Server.GrantAspNetServiceAccountAccessAction

    |  Error| System.Exception: Action Microsoft.Crm.Setup.Server.GrantAspNetServiceAccountAccessAction failed. ---> System.UnauthorizedAccessException: Access is denied.

       at System.DirectoryServices.Interop.UnsafeNativeMethods.IAds.SetInfo()

       at System.DirectoryServices.DirectoryEntry.CommitChanges()

       at Microsoft.Crm.Setup.Server.Utility.ADUtility.GrantAccess(DirectoryEntry groupEntry, String accountName)

       at Microsoft.Crm.Setup.Server.GrantAccessToServiceAcountAction.Do(IDictionary parameters)

       at Microsoft.Crm.Setup.Common.CrmAction.ExecuteAction(CrmAction action, IDictionary parameters, Boolean undo)

       --- End of inner exception stack trace ---, Error, RetryCancel, Option1

    Does any one found a solution ?

    Tuesday, November 13, 2012 10:28 AM
  • Im also getting this error.

    Has anyone found any solution to this?

    Wednesday, March 20, 2013 1:27 PM
  • Please try removing all current installed components of CRM 2011 => Reboot machine => Delete Folder from Program files =>

    On SQL Server in 'SQL Server configuration manager' go to SQL Server network configuration => Protocols for SQL Instance and change status to Enable for Named Pipes.

    Hope you are doing installation with user who is Domain Admin in AD.

    Try re installation now.

    Thanks!

    Thursday, March 21, 2013 6:31 AM
  • I tried this, but no change.

    Any other suggestions? 

    Friday, March 22, 2013 12:50 PM
  • I have tried installing a new SQL on the same server as CRM, no change.

    I have tried reinstalling the CRM server, no change.

    The only thing "unusual" in our domain that I know of is we have 2012 AD controllers and domain is promoted to 2012.

    Would appreciate any suggestions, or facts that others might know about this problem.

    Tuesday, April 02, 2013 1:39 PM
  • Did you ever figure this out?

    Thanks, Paul Nath

    Friday, June 28, 2013 7:20 PM
  • So I spent hours on this one. Turns out due to a previous install of an earlier version of Dynamics (might not have been cleanly removed) I had some "Account Unknown" entries on the Dynamics OU. If you right-click the OU, select security and remove (I had to turn off inherit) these "Account Unknown" entries. Once I did this the install completed and this error went away. Good luck.

    Saturday, February 22, 2014 1:52 PM