locked
Contact Numbers not appearing in communicator.

    Question

  • Hi,

     

    I have recently deployed Office Communicator as a pilot and am having an issue with the contact numbers not appearing in communicator.  The pilot is only deployed internally to the business.

     

    When you open communicator you are able to have all the normal functionality message, add, remove contacts, view presence, find people.  However when you right click, under call, no numbers (Work, Home, Mobile etc) or the Line URI: number appear. 

     

    - In active directory all numbers are present and configured including the OCS tab with line URI:

    - PBX integration works, you can dial numbers out from your phone PC, click to call, pop ups work etc.

     

    - GalContacts.db is populated

    - When in communicator under call forwarding, all numbers appear for the local user

    - When a user has been enabled but has not logged before, their Tel:URI number appears in under their details when looked up eg. Work 9837

    - I have tried putting everyone under personal (Maximum) level of access, no success there.

    - I enabled publish this phone number is selected under the phones tab

    - When I add an 'other' number through communicator and click publish this phone number under the phones tab other people are able to see this if they are under my personal contacts.

     

    I have tried dabbling with normalization to see if that was the problem, both at the address book and at the front-end server.  I am baffled that the GalContacts.db are populated locally yet they do not appear under contacts.

     

    Could there be some AD group policies that would force the hiding of details?

     

    Any suggestions to trouble shoot would be much appreciated?

    Tuesday, January 15, 2008 10:38 PM

Answers

  • Hey Mike,

     

    just got it, for some bizzare reason the absconfig.exe had Include the phone number value that is currently present in the AD and not to normalize.  We have had a previous installation of LCS 2005 so perhaps some settings were carried over?

     

    The numbers are now comming through once I changed the setting on ABSconfig.exe to take numbers and normalize rather than straight out of AD.

    Wednesday, January 16, 2008 3:33 AM

All replies

  • Andrew,

     

    This is typically caused by the numbers not being normalized.  Can you look in your ABS folder to see if you have an invalid_ad_phone_numbers.txt file?

    Tuesday, January 15, 2008 11:01 PM
    Moderator
  • Hey Mike,

     

    just got it, for some bizzare reason the absconfig.exe had Include the phone number value that is currently present in the AD and not to normalize.  We have had a previous installation of LCS 2005 so perhaps some settings were carried over?

     

    The numbers are now comming through once I changed the setting on ABSconfig.exe to take numbers and normalize rather than straight out of AD.

    Wednesday, January 16, 2008 3:33 AM
  • Can you please provide an example of your company_phone_number_normalization_rules.txt?  I am having the same problem where the phone numbers are not getting displayed.  Thanks.

    Thursday, January 17, 2008 8:46 PM
  • ##
    ## This is a read-only file that contains an example of company specific
    ## phone normalization rules used by Microsoft Corporation.  You should
    ## make a copy this file in the same folder, with the name
    ## Company_Phone_Normalization_Rules.txt and make it writable.  You can
    ## then edit the file to adapt it to your needs.  The file will not be
    ## uninstalled when you uninstall the Address Book Service,
    ##

    ##
    ## Microsoft specific rules
    ##
    #
    # Extenstions
    #
    #
    (\d\d\d\d)
    +$1

    #
    #
    # Other numbers
    #
    #
    #
    ^(0\d*)$
    +1$1
    #
    #
    #
    #
    #
    #

     

    Please note: the advice in #'s listed above in microsoft document doesn't seem to work, it says name it Company_Phone_Normalization_Rules.txt, Ive found when I just removed the word Sample from the txt file it worked eg.

     

    Company_Phone_Number_Normalization_Rules.txt

    rather than,

    Company_Phone_Normalization_Rules.txt

     

    Also just remember to run

    abserver -regenUR

    abserver -syncnow

     

    and delete your galcontacts.db

     

     

    Thursday, January 17, 2008 10:19 PM
  • Thank you for the quick response.  Weird thing is I tried what you mentioned, but when I run the command abserver.exe -dumprules, only the built-in generic rules appear.  It looks like the file Company_Phone_Number_Normalization_Rules.txt

     is not being read.  I even run abserver -regenUR.  When I execute abserver.exe -syncnow, I still get the numbers sent tot Invalid_AD_Phone_Numbers.txt.  Am I doing something wrong?  Of course the numbers are still not appearing in Office Communicator.  Thanks for taking the time to review this.

    Friday, January 18, 2008 4:19 PM
  • If you are getting numbers sent to invalid_Ad_phone_numbers.txt then normalization is occuring.

     

    To give it a test just go into dos and use the abserver -testphonenorm (number)

     

    check that you have removed the word sample, infront of the sample_company_phone......txt

     

     

    Thursday, January 24, 2008 2:16 AM
  • you have to copy the "Company_Phone_..." file to the share/location where the ABFiles are stored, that is the same location where you will find the "Invalid_AD_Phone_Numbers.txt" file. After that run regenUR and syncnow again ..

     

    Using abserver -dumpRules should show your company normalization rule just before the generic rule.

     

    The text within the Sample file refering to "You should make a copy this file in the same folder" is wrong.

     

    Andreas

     

    Tuesday, January 29, 2008 5:33 PM
  • I had actually figured it out before your response, but thank you very much for your feedback.  I just wished Microsoft had explained in detail that kind of information in their documents.  Once again, thank you very much.

     

    Thursday, January 31, 2008 2:29 PM