none
Customer Portal Uninstall

    Question

  • My client recently installed Customer Portal on our production site and we began having issues accessing our form customizations. We tried to uninstall the solution however we are receiving dependency issues. When I uninstalled from our test site the install had no issues. I have went through and deactivated processes and removed any fields from the forms I can access, my list of dependencies has decreased but I cannot resolve any more of them. Is there a way to do a clean install and where do I start? My client did not take a backup first so I have quite the headache.
    Tuesday, December 27, 2011 10:06 PM

Answers

  • Just wanted to update this form so that others can maybe learn from this. What happened was that customizations were not properly published when the solution was installed, instead of backing up from a month ago, I created a test database of my current system and found the SystemFormBase showed 2 different Form XML for account. Once I changed the form xml to be the same in the table I was able to access my customizations for the account form, remove the dependencies and uninstall the solution.

     

    Thanks!

    Wednesday, December 28, 2011 10:51 PM

All replies

  • Hi,

    1) I would have tried to remove all the dependencies from the list one by one if there are few left. Let us know if you need information on any message you are trying to follow. 

    2) You can also do this, Get a fresh CRM Organization, export the default customization by going to the Settings -> Customization -> Customize the System -> Do Export Solution -> import this solution into your CRM Organization that is having issues right now (aka. your Production site) & Publish it. Make sure the CRM Version on both the Organization is the same to avoid any further complications.

    Thanks,

    RBaliga

    Tuesday, December 27, 2011 10:26 PM
  • I cannot remove the rest of the dependencies from the list as they are involving my account entity which I cannot access in Customizations. This whole issue started there. After installing Customer Portal, when you would select the main account form to customize there was an error, therefore I cannot go in and remove any of these fields from the form.

     

    I have lots of customizations and I do not want to wipe them out by using a new org and I do not think that will resolve it as it seems to not have installed correctly in the first place.

     

    Any other suggestions?

    Tuesday, December 27, 2011 10:33 PM
  • Looks like you will need permissions to the account entity form to remove the further dependencies.

    Apparently, people have seen these issues for the forms of out of the box entities.

    thanks!

    Tuesday, December 27, 2011 11:25 PM
  • I have full permissions to the system, I am the system admin. I have proper permissions to access the account form but I cannot after having this Customer Portal installed. Installing Customer Portal either messed up during the install or during the customization of it. Any other ideas?
    Wednesday, December 28, 2011 12:50 AM
  • Just wanted to update this form so that others can maybe learn from this. What happened was that customizations were not properly published when the solution was installed, instead of backing up from a month ago, I created a test database of my current system and found the SystemFormBase showed 2 different Form XML for account. Once I changed the form xml to be the same in the table I was able to access my customizations for the account form, remove the dependencies and uninstall the solution.

     

    Thanks!

    Wednesday, December 28, 2011 10:51 PM
  • Thanks for sharing!
    Monday, January 09, 2012 12:00 AM
  • Hi Kim, I have same problem for a while but I use CRM 2011 online. I am wondering if your approach would work. It seems the issue is with CRM not able to remove the solutions.  
    Thursday, February 02, 2012 4:21 PM
  • Try publishing all customizations before attempting to remove the managed solution.

    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com

    Wednesday, February 15, 2012 12:19 AM
    Moderator
  • Hi,

    I can't uninstall MicrosoftXrmCustomerPortal verion 1.0.0015 from CRM 2013. I was waiting 1 hour with no luck.

    I published all customization several times and still i can't uninstall the solution.

    Is there any other way to remove the solution? and How can i trace the errors of Uninstalling the Solution?

    Thursday, January 02, 2014 2:50 PM
  • Try publishing all customizations before attempting to remove the managed solution.

    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com

    Didn't work for me.
    Thursday, January 02, 2014 2:52 PM
  • There are only two primary reasons for not being able to uninstall managed solutions. The first reason is that there are dependencies in your unmanaged layers on a component that is in the managed solution. CRM requires that you remove this prior to it letting you uninstall the managed solution. CRM will tell you about these dependencies and you can manually remove them until there are none left. The other reason I have seen for not being able to remove an unmanaged solution is that the solution file is very large and your CRM SQL timeouts are set too low, not giving CRM enough time to successfully remove the solution before it aborts the attempt. For CRM Online, the only way to get this fixed is to call into CRM Online support and request that they increase the SQL timeouts so that you can remove a managed solution file that is taking too long.

    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com

    Thursday, January 02, 2014 5:20 PM
    Moderator