locked
XP Service Pack 3 - Remote Access Via RDP BROKEN

    Question

  • Hi all,
    I have seen this problem consistant on multiple machines so I thought i would post up about it.
    Essentially after installing Service Pack 3 on xp machines i cannont get RDP connected through internet explorer.  Internet explorer prompts to add my homeserver web site address to the "Trusted Sites" security of IE but after adding the server address it does not resolve the problem. 

    Any ideas?
    Thursday, May 15, 2008 1:32 PM

Answers

  • Curveo,

    Hi,

    Yes, there have been a few mentions of this problem. It's the 'upgraded' security model which comes with SP3.

    The reason for this is that the Terminal Services ActiveX control is disabled by default in XPSP3 as a security measure. You need to explicitly enable the Terminal Services ActiveX control in IE in order to use the ActiveX control. To do this you will need to do the following: 

     

    Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control. If you are unable to see/enable the Terminal Services ActiveX control in IE7 on XPSP3 as a workaround can you try deleting the following registry keys: 

     

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)

    Once you delete these keys, the activeX control should be enabled in IE7.

     

    HTH,

     

    Colin

     

    Thursday, May 15, 2008 5:11 PM

All replies

  • Curveo,

    Hi,

    Yes, there have been a few mentions of this problem. It's the 'upgraded' security model which comes with SP3.

    The reason for this is that the Terminal Services ActiveX control is disabled by default in XPSP3 as a security measure. You need to explicitly enable the Terminal Services ActiveX control in IE in order to use the ActiveX control. To do this you will need to do the following: 

     

    Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control. If you are unable to see/enable the Terminal Services ActiveX control in IE7 on XPSP3 as a workaround can you try deleting the following registry keys: 

     

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)

    Once you delete these keys, the activeX control should be enabled in IE7.

     

    HTH,

     

    Colin

     

    Thursday, May 15, 2008 5:11 PM
  • Thank you for fully understading the issue!! 
    Have a good day.


    Curveo
    Friday, May 16, 2008 1:47 AM