none
BT Home Hub - non uPnP router?

    Question

  • This device claims to be uPnP but WHS thinks not; any other users find otherwise?

     

    It does appear in the network neighborhood of my XP MCE machine, but the Vista box doesn't seem to discover it either.

    Monday, May 07, 2007 1:28 PM

All replies

  • Just a FYI for any other BT Home Hub users, I ran the MS Internet Connectivity Evaluation Tool against the Home Hub and these were the issues:

    1 - Network Address Translator Type

     

    The NAT is a symmetric one:

     "Microsoft has determined that symmetric NATs can block the traffic of programs that use IPv6 tunneling over IPv4  (see Teredo Overview for details of how this works). Failure to connect using IPv6 may cause these programs to not run or to have a degraded experience. "

     

    2 - UPnP Support Test

     

    It seems that the router is uPnP as advertised, but maybe restricts access to the ports for security reasons, which I guess is why WHS regards it as non-uPnP:

     

    The firewall is enabled

    Exceptions are allowed by the firewall

    UPnP is enabled by the firewall

    UPnP services are running

    UPnP Discovery is enabled

    Detecting Internet Gateway Devices on the network

    1 IGD(s) found

    IGD Device Information:

    Manufacturer Name : THOMSON

    Model Name : SpeedTouch

    Model Number : BTHH
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    get_StaticPortMappingCollection() returned NULL IStaticPortMappingCollection
    Failed to get port mapping from the IGD

    Thursday, May 24, 2007 10:32 PM
  • I am running a different router (WRT54G) but on mine I had to turn on uPnP support in the router config for things to work then it showed up as a uPnP device.

     

    Rex Geissinger

    Friday, May 25, 2007 5:35 PM
  • I had the same problem with the Home Hub.  I had to manually create the application to get it to work using the ports posted in the FAQs.

     

    I used this excellent step by step guide.

     

    Have fun

    Yogimax

     

    http://www.frequencycast.co.uk/homehub.html

     

    Friday, May 25, 2007 5:45 PM
  • Thanks, Rex. This router is set to uPnP by default, as I recall - it's certainly enabled.

     

    (The slightly curious thing is that it turns up in the network neighborhood on my MCE machine, but not on Vista, but maybe that uses a similar test to the online check.)

    Friday, May 25, 2007 7:00 PM
  • Thanks Yogimax - yes, did that already but may be useful for someone else. It's an informative site, thanks for the pointer.

     

    Everything works fine except the Remote Desktop feature Sad

    Friday, May 25, 2007 7:04 PM