locked
Cannot do 3 party "conference" IM's 2 party works fine.

    Question

  • 2 party IM works fine.. if you add a 3rd person that 3rd person never sees any of the messages or even gets an initial box pop up.

    If you start a new IM conversation with 3 people and type a message you get an error after a minute or so

    "This message was not delivered to <unknown> due to an error: More details (ID:3098)

    and neither party receives the message.
    Wednesday, July 18, 2007 1:37 PM

All replies

  • Do you get any errors in your server's event logs?

    Monday, July 23, 2007 9:17 PM
  • Yes.. constant 1022 errors.. event id 61030 source is OCS MCU Infrastructure

    The process RtcHost(2984) did not receive a certificate from the client.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I've checked my certificate and it appears to be fine.. so not sure why that happens. 

    Also discovered that Web Conferencing does not work as well.. you can schedule a meeting in Outlook and invite people but when anyone clicks on the link to join the conference it fails to connect.

    edit

    There is another one that occurs after you attempt a 3 party IM conference and it times out.. missed it the first time

    Event ID 32052, Category 1006 Source OCS User Services.


    A C3P request sent to an Mcu timed-out. Conferencing requests for this Mcu type will be retried but if this error continues to occur conferencing functionality will be affected.

    Mcu Url: https://balatss.agrp.com:444/LiveServer/MCUFactory/
    Resolution:
    Ensure that the Mcu is provisioned and functioning correctly. If any network related errors are reported by the Mcu ensure that they are resolved.
    Tuesday, July 31, 2007 4:05 PM
  • The client trusts the certificate presented by OCS? I would first try to resolve the certificate issue and then move from there.

    Monday, August 13, 2007 6:32 PM
  • Not sure how to check or ensure the client does trust the certificate on the OCS.. that certificate looks fine to me when I check it on the OCS server.
    Tuesday, August 14, 2007 5:23 PM
  • Hi Alexis,

     

    Did you manage to resolve this problem ? I am also having the same issue, and cant find or figure out a fix. I did see another post on this forum under MCU's, but the only resolution they had was to reinstall OCS from scratch, which I really do not want to do at this stage.

     

    Thanks,

    Marcus

     

    Tuesday, September 11, 2007 3:41 AM
  • Same problem here with both the web and fat client.  Would greatly appreciate any solutions/ideas/fixes.

     

     

     

    Wednesday, October 10, 2007 10:07 PM
  •  

    Same problem here .. getting that ID:3098 as well.

     

     

    Tuesday, October 23, 2007 6:50 PM
  • Has anyone resolved this issue?  I too am having this problem Sad

    Wednesday, November 14, 2007 8:02 PM
  • Let me bump this to the top of the list by saying that I too am having this issue.  One-on-one chat works like a champ!

    Consolodated setup on one virtual machine.  SQL instance is installed on a different machine.  We are using an external cert that is already in the trusted root (Thawte).

    If anyone else has the issue, please pipe up.

    Dan
    Tuesday, November 27, 2007 10:51 PM
  •  

    I've not had any luck,  We are using a Cert from godaddy that uses a intermediate.  If the clients couldnt read the cert it wouldnt make sense why it works with 1 on 1 im's

     

     

    Someone help!!!

    Wednesday, November 28, 2007 2:09 AM
  •  

    I havent seen anyone post this so I will... If you enable event logging in the communicator, after you get the error 3098 in your message window,this gets written to application event logs:

     

    A SIP request made by Communicator failed in an unexpected manner (status code 80ef025b). More information is contained in the following technical data:
     
     RequestUri:   sip:jharrell@mydomain.com;gruu;opaque=app:conf:chat:id:175E1EF40399054FBB4D3E1C87F42657
    From:         sip:jharrell@mydomain.com;tag=f7991d6b02
    To:           sip:jharrell@mydomain.com;gruu;opaque=app:conf:chat:id:175E1EF40399054FBB4D3E1C87F42657;tag=E03C98C05A62475EBE9B86C73645D014
    Call-ID:      c1d02d99292c470a858ae77314cb86ad
    Content-type: application/sdp;call-type=im

    v=0
    o=- 0 0 IN IP4 172.29.48.31
    s=session
    c=IN IP4 172.29.48.31
    t=0 0
    m=message 5060 sip null
    a=accept-types:text/rtf application/x-ms-ink image/gif multipart/alternative application/ms-imdn+xml


    Response Data:

    603  Decline
    ms-diagnostics:  3098;reason="No MCU Factory Available";source="VENUS.mydomain.com"

     
     Resolution:
     If this error continues to occur, please contact your network administrator. The network administrator can use a tool like winerror.exe from the Windows Resource Kit or lcserror.exe from the Office Communications Server Resource Kit in order to interpret any error codes listed above.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Wednesday, November 28, 2007 5:01 PM
  • I managed to sort out IM conferencing on my setup, but unfortunately I had to do a reinstall to fix it. I was using OCS Standard Edition trial version, but reinstall Enterprise Edition from the MSDN CD, so I dont know if its a Standard Edition bug or a bug that in the trial version that was fixed (or both) or if it was my configuration.

     

    Not much help really I know, but the reinstall doesnt take very long at all once you have done it once, as all DNS, AD etc is already set up.

     

    Wednesday, November 28, 2007 10:40 PM
  •  

    So, Did you reformat and start from scratch or just uninstall without deactivation and reinstall after.  Did you have to restore a DB or anything?  What were your steps?

     

     

    I ran across KB article 944686 today and waited all day to receive the file from M$ to find out that it didnt fix my problem Sad

    Wednesday, November 28, 2007 11:58 PM
  • Hi jharrell,

     

    I didnt restore from bare metal, I just uninstalled all the OCS components from the OCS SE server - being SE, everything was on the one machine. Once they were uninstalled, I just ran the setup.exe again from the CD. I did have to create a new certificate ( I used godaddy), as I installed Enterprise Edition this time, and had to have a certificate that matches the pool name. With the SE install, I didnt have a pool, just the single server. I also had to make a slight mod to the DNS, but again that was to accomodate the pool name, instead of the individual server name. Once I'd reinstalled, and I had the certificate issues sorted, the conferencing just worked.

     

    On reinstall, I always selected the option to recreate the existing DB, as there was nothing that I needed to keep from the old install.

     

    Thursday, November 29, 2007 12:35 AM
  •  

    well ours is in full production... I may make a call to MS and get them to help me fix it.  The good news is this is a virtual machine so If i do break something I can have it back online in minutes.

     

    Thanks for the help, If i do call MS and get a "real" fix i'll post here for others

     

    Thanks again everyone.

    Thursday, November 29, 2007 2:15 PM
  •  Alexis Muhly wrote:
    Yes.. constant 1022 errors.. event id 61030 source is OCS MCU Infrastructure

    The process RtcHost(2984) did not receive a certificate from the client.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I've checked my certificate and it appears to be fine.. so not sure why that happens. 

    Also discovered that Web Conferencing does not work as well.. you can schedule a meeting in Outlook and invite people but when anyone clicks on the link to join the conference it fails to connect.

    edit

    There is another one that occurs after you attempt a 3 party IM conference and it times out.. missed it the first time

    Event ID 32052, Category 1006 Source OCS User Services.


    A C3P request sent to an Mcu timed-out. Conferencing requests for this Mcu type will be retried but if this error continues to occur conferencing functionality will be affected.

    Mcu Url: https://balatss.agrp.com:444/LiveServer/MCUFactory/
    Resolution:
    Ensure that the Mcu is provisioned and functioning correctly. If any network related errors are reported by the Mcu ensure that they are resolved.

     

    This error is due to too many trusted root certificates on the server. see http://support.microsoft.com/kb/937296/en-us

    Thursday, November 29, 2007 2:57 PM
  •  

    FIXED!!!!

     

    Called Microsoft so I thought I'd share.

     

    Go to your certificate, I used IIS and right clicked my website and hit properties, went to "Directory Security" select View cert:  You need to go to "details" tab and select "edit properties" Enable all purposes for this cert needs to be ticked.

    This setting needs to be on all intermedia certs and parent certs, So after you verify your purchased cert has enabled all purposes go to the "certification path" tab and work your way up the tree selecting "view cert" and checking the details on each...

     

    We have godaddy so there are 4 including the one we've purchased and all intermediate, The very top of our tree was the problem, so in our case I selected the Certification path tab, highlighted the top most cert "calicert class 2 policy validation authority" and selected "view certificate" went to details tab, and hit "edit properties" checked the radio button "enable all purposes for this certificate"

     

    Hope this saves someone!!!

    -Jeff

    Thursday, November 29, 2007 6:37 PM
  • Worked for me as well.  We get our cert from Thawte and I had to do it at the root of the certification path.

    Jeff, you need to setup a PayPal so we can share the cost of the call (or at least pay for a beverage of your choice)!

    Thanks for the legwork and saving me a $250 pay-per-incident call.

    Dan
    Thursday, November 29, 2007 7:39 PM
  •  

    Hey, i'm easy to please....  Bud Light!

     

    LOL

     

    Glad I could help

    Thursday, November 29, 2007 7:55 PM
  •  

    jharrel1, just wanted to say THANK YOU! Out of ~7000 posts related to this issue and countless red herrings, your post was the only one that solved my problem.

     

    Thanks a ton for posting this information online. I'd still be pulling my hair out now if it weren't for you.

     

    -Andy

    Tuesday, March 25, 2008 8:14 PM
  •  

    No problem bud.  I'm glad to help!

     

     

    Tuesday, March 25, 2008 10:31 PM
  • This also COMPLETELY SOLVED my problem. Just wanted to say thank you. This was driving me up the wall for two days and I ended up deploying Communicator to all our users before the IM conferencing was working. I am so glad that now we have all the features working!! Thank you!!
    Tuesday, May 27, 2008 4:17 PM
  • Thank you Jeff,

    Just want to add to this that this will fix all https://server.domain.com:444/liveserver/Factory issues. Also DNS records have to be modified as described in OCS_EdgeServerDeploy.doc. Thank you fro saving us lot of time and money. GoDaddy Support was cluless about it.

     

    Bill, MyQuickPC.com

    Tuesday, June 17, 2008 3:40 PM
  • Thanks for posting that fix, Jeff!

    Thursday, August 07, 2008 9:38 PM
  •  

    Thanks!

    Yeah it saved me  a lot...

    Friday, August 08, 2008 7:24 PM
  •  

    No problem guys... Glad the info could help others.
    Friday, August 08, 2008 7:27 PM
  • Thats wierd this is exactly my error that I'm getting but when I check on the OCS server and IIS both the default website and the OCS web access site under the certificates both have this setting already checked am I missing something?

     

    Ok this worked for me too, didn't realize you had to go into the certificates MMC and was trying from IIS, but when I went into the cetificates MMC and under "Trusted root Certification Authorities--> Certificates"  then changed the entries for Thawte as mentioned above to "enable all purposes for this certificate" the error went away.

    Friday, October 31, 2008 4:55 PM
  • Hi jharrell1

    I'm using OCS 2007 R2 and have this problem. I don't know why your solution works for everyone but me. I'm using an internal CA and when i checked your recommendations, everything was right! and still have problem.
    please help me how to get out of this.

    Thanks everybody
    Hossein Tavakkoli
    Sunday, July 19, 2009 4:39 AM
  • I experienced this error in both of the below environments:

    OCS 2007, CCM 7, CUPS v7.0.1
    OCS 2007 R2, CCM 7, and CUPS 7.0.2

    In my particular situation, the problem ended up being a catch all SIP route, i.e., *@*, in the Front End properties under routing; by removing this route, the 3-party conferencing worked fine.

    Just thought I'd share, as all of my certificates, Authentication, etc checked out.
    Thanks! -Josh
    Wednesday, July 29, 2009 5:26 PM
  • Hi Hossein,

    having same issue and solves only after deactivating and activating IMMCU (IM Conferencing) module with LCSCmd.exe tool... just type these two commands and start IM Conferencing service...

    LCSCmd.exe /MCU /Action:deactivate /Role:IMMCU

    after got successful message type this at cmd

    LCSCmd.exe /MCU /Action:Activate /Role:IMMCU /Poolname:<pool> /Username:<username> /Password:<password>

    remember use same username/password who has service start right of 'IM Conferencing'.

    -Salman
    Thursday, October 08, 2009 4:48 PM
  • Does this work for Windows 2008?  The Edit Properties is grayed out for me.

    FIXED!!!!

     

    Called Microsoft so I thought I'd share.

     

    Go to your certificate, I used IIS and right clicked my website and hit properties, went to "Directory Security" select View cert:  You need to go to "details" tab and select "edit properties" Enable all purposes for this cert needs to be ticked.

    This setting needs to be on all intermedia certs and parent certs, So after you verify your purchased cert has enabled all purposes go to the "certification path" tab and work your way up the tree selecting "view cert" and checking the details on each...

     

    We have godaddy so there are 4 including the one we've purchased and all intermediate, The very top of our tree was the problem, so in our case I selected the Certification path tab, highlighted the top most cert "calicert class 2 policy validation authority" and selected "view certificate" went to details tab, and hit "edit properties" checked the radio button "enable all purposes for this certificate"

     

    Hope this saves someone!!!

    -Jeff

    Thursday, October 08, 2009 9:24 PM
  • Just saved my bacon here.  Thanks for posting!

    Bill Auclair
    Wednesday, October 28, 2009 9:39 PM