locked
Remote Connection to the computer timed out

    Question

  • When I remotely access my WHS RC (from work), and trying to remote to my Windows XPP computer I almost immediately get an error telling me that the "Remote Connection to the computer timed out. Please connect again." I don´t get this if clicking the "Connect to your Home Server." I can browse my shares just fine. I´ve tried this from a friends Windows XPP remote over the Internet and get the same fault. I´ve forwarded the three ports in my router. Does anyone have any suggestions?
    Wednesday, July 04, 2007 7:47 AM

All replies

  • Hi,

    The pc that you need to remote access to, should have remote access enable:

    Start | Right click on "My Computer" and to the remote tab, then remote desktop.

    I am right now on Vista, but I think you need to chose if I recall the option in Remote desktop - "Allow connection from computer running any version of remote ..", something like that.

    My best.
    Wednesday, July 04, 2007 8:09 AM
  • abobader, i´ve done that.
    Wednesday, July 04, 2007 8:17 AM
  • Did you open the RDP port in the XP firewall too?


    (BTW: TCP 3389)
    Wednesday, July 04, 2007 8:27 AM
  •  egaf56 wrote:
    abobader, i´ve done that.


    Hi,

    Just to be sure that the remote desktop for the pc you want to remote access to, if that done.

    Can you check in that pc firewall setting in "Exception" that "remote desktop" is enable (box is mark)?

    My best.
    Wednesday, July 04, 2007 8:30 AM
  • Also for firewall within the whs ports, look to this topic:

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1775042&SiteID=50

    If the pc xp do not have the firewall port rule, SME post above the port that need to be enable.

    My best.
    Wednesday, July 04, 2007 8:42 AM
  • Ok, tnx abobader. I´ll check this during my lunchbreak. I´m at work now.
    Wednesday, July 04, 2007 9:06 AM
  • I have changed two items. I cancelled my F/W (Zone Alarm) and enabled the XP F/W. I also checked that "Remote assistance" and "Remote Desktop" was enabled in exceptions. 

    But still I can´t remote control my home PC from work.

    I don´t know what this means but before I cancelled ZoneAlarm, I checked the log. At the time I tested this morning, the log showed that my WHS had sent a request to port 3389 on my PC, and ZA had acceped this.

    Wednesday, July 04, 2007 11:24 AM
  •  egaf56 wrote:

    I have changed two items. I cancelled my F/W (Zone Alarm) and enabled the XP F/W. I also checked that "Remote assistance" and "Remote Desktop" was enabled in exceptions.

    But still I can´t remote control my home PC from work.

    I don´t know what this means but before I cancelled ZoneAlarm, I checked the log. At the time I tested this morning, the log showed that my WHS had sent a request to port 3389 on my PC, and ZA had acceped this.



    Can you see the rules within zonealarm for WHS as trusted or ports remote access rules in it? (As add WHS local ip as trust zone).

    Sometimes if nothing seem to work, you have to make rule to forward that port within your router.

    To customize these issue here:

    1 - WHS firewall should have RD enable (same as the link I post about what ports in WHS should be active.

    2 - Your client/s pc should have RD ports enable.

    3 - Your router if need should have RD port forward as well (for some setup, not for everyone).

    If this not working, simply disable firewall on the client, and see if it ok, if not, I need to post here the clients firewall ports as well.

    My best.

    Wednesday, July 04, 2007 5:02 PM
  • Also after you done above, we should apply this as well:

    The pc that you need to remote access to, should have remote access enable:

    Start | Right click on "My Computer" and to the remote tab, then remote desktop.

    I am right now on Vista, but I think you need to chose if I recall the option in Remote desktop - "Allow connection from computer running any version of remote ..", something like that.


    Otherwise, you will still get time out.

    My best.
    Wednesday, July 04, 2007 5:21 PM
  • abobader, i´ll answer your Q´s below:

     

    Can you see the rules within zonealarm for WHS as trusted or ports remote access rules in it? (As add WHS local ip as trust zone).

     

    Answer: I cancelled ZA, so I skipped this.



    Sometimes if nothing seem to work, you have to make rule to forward that port within your router.

    To customize these issue here:

    1 - WHS firewall should have RD enable (same as the link I post about what ports in WHS should be active.

     

    Answer: I enabled RD in the settings on WHS. I also checked the F/W on the WHS and RD was checked in the exceptions.

    2 - Your client/s pc should have RD ports enable.

     

    Answer: I´ve enabled RD in the way you described, My Computer, Settings and so on... I have also checked the F/W (Microsoft) settings and RD was checked in the exceptions.

    3 - Your router if need should have RD port forward as well (for some setup, not for everyone).

     

    Answer: The Router forwards port 80, 443 and 4125 to my WHS. I also have port 3389 forwarded to my WXPP PC.

    If this not working, simply disable firewall on the client, and see if it ok, if not, I need to post here the clients firewall ports as well.

    My best.

    Thursday, July 05, 2007 7:26 AM
  • Hi,

    I just setup a laptop that did not have remote desktop enable, so I can work that with you, OS on it is XP pro.

    BTW, did you reboot the xp after you done all the setting before?

    Here what in my laptop firewall setting:

    - File and print sharing:
    TCP: 139 | 445
    UDP: 137 -> 138

    - Network Diagnostics for Windows Xp
    path: C:\windows\Network Diagnostic\xpnetdiag.exe

    - Remote Assistance
    path: c:\windows\system32\sessmgr.exe

    - Remote Desktop
    TCP: 3389

    - Windows Home Server Connector
    path: c:\program files\windows home server\discovery.exe

    Also, need to notice regarding the "Scope" within the Remote Desktop rules, should be:
    "Any computer".

    Well, that about all, reboot and recheck.

    My best.
    Thursday, July 05, 2007 10:36 AM
  • If the above a no go, let try to find what the problem:

    1 - Check if the Terminal Services is running on the desktop PC by:

    Start | Run | services.msc

    See if Terminal Services = started

    2 - Verify the PC is listening on TCP Port 3389 by:

    Start | Run | cmd then in the command prompt type:

    netstat -a

    And see if it listening on TCP Port 3389.

    hmm, that all I can think of at the moment tho, hope that help.

    My best.
    Thursday, July 05, 2007 11:30 AM
  • abobader, I´ve checked the above:
    1- Terminal Services Status: Started, Manual, Local system
    2- Protocoll: TCP, Local adr: AndersNya:3389, Extern adr: AndersNya:0, Status: Listening
    Regards Anders
    Friday, July 06, 2007 4:53 AM
  • abobader, I can´t find the below settings, where did you find them?

    I just setup a laptop that did not have remote desktop enable, so I can work that with you, OS on it is XP pro.

    BTW, did you reboot the xp after you done all the setting before?

    Here what in my laptop firewall setting:

    - File and print sharing:
    TCP: 139 | 445
    UDP: 137 -> 138

    - Network Diagnostics for Windows Xp
    path: C:\windows\Network Diagnostic\xpnetdiag.exe

    - Remote Assistance
    path: c:\windows\system32\sessmgr.exe

    - Remote Desktop
    TCP: 3389

    - Windows Home Server Connector
    path: c:\program files\windows home server\discovery.exe

    Also, need to notice regarding the "Scope" within the Remote Desktop rules, should be:
    "Any computer".

    Regards Anders
    Friday, July 06, 2007 5:02 AM
  •  egaf56 wrote:
    abobader, I can´t find the below settings, where did you find them?


    Hi Anders.

    Regarding these ports settings? Here

    Start | Control Panel | Windows Firewall | Exceptions

    If a program or ports not there, just add program or ports or edit.

    Regarding "Scope", within any items there, just click "edit" then "change scope".

    And in case, for remote setting:

    Start | right click "my computer" | properties | Remote | Remote Desktop.

    And See if your site that you try to connect from is in IE as "Trusted site", almost forgot about that:

    IE | Tools | Internet Options | Security tab | select zone -> Trusted sites -> Sites -> add yours there.

    My best.
    Friday, July 06, 2007 5:13 AM
  • Hello abobader, here is what I found:

     

    Here what in my laptop firewall setting:

    - File and print sharing:
    TCP: 139 | 445
    UDP: 137 -> 138

     

    Anders: Yes, the same



    - Network Diagnostics for Windows Xp
    path: C:\windows\Network Diagnostic\xpnetdiag.exe

     

    Anders: Yes the path was there, but the name was different, I changed it.

    - Remote Assistance
    path: c:\windows\system32\sessmgr.exe

     

    Anders: Yes, This was ok.

    - Remote Desktop
    TCP: 3389

     

    Anders: Yes the same.

    - Windows Home Server Connector
    path: c:\program files\windows home server\discovery.exe

     

    Anders: This was also ok.

    Also, need to notice regarding the "Scope" within the Remote Desktop rules, should be:
    "Any computer".

     

    Anders: Yes it has the same scope.

     

    Sorry, but this it a bit tricky.  Smile

     

    Regards Anders

    Friday, July 06, 2007 6:57 AM
  • Hi,

    heh, I almost run of idea here Smile

    well, let go back to basic on this:

    1 - Use any util to clean the registry from that zone alarm one, use something like CCleaner, then reboot.

    2 - Try to update the xp from windows update site.

    My best.
    Friday, July 06, 2007 7:17 AM
  • abobader, thank you so much for your help!

    I think there must be something wrong in my WinXPP PC.

    I tried Remote Desktop Connection from my work, and that didn´t work either.

    I guess there is something in the Registry that is faulty.

    Regards Anders

    Friday, July 06, 2007 9:29 AM
  • Hi

    Maybe we did not come to this, but i need to ask:

    1 - the user account that you login to your whs with, that user have administrator right in that local account of the xp?

    If not, add that user to the "remote desktop users groups" in xp (local users and groups).

    Start | Control Panel | Administrative Tools | Computer Management:
    System Tools - Local users and group - Groups - double click on "remote desktop users" - Add.

    My best.
    Friday, July 06, 2007 9:52 AM
  • abobader, I checked this also, and it was ok.
    I log in with he same name on XPP and on the WHS.
    Regards Anders
    Thursday, July 12, 2007 5:38 AM
  • Try setting up a forward port on your router, not only the standard remote port but port 80 and especially port 4125.

    This helped me getting connected through the internet to my Home Server and even throught that to my other computers..

    It wasn't only my windows firewall that caused problems, but the routing of port 4125.

    Good luck. Hope it helpes..

     

    Sunday, December 16, 2007 4:49 PM
  • Hi,

     

    Please check if your workplace network infrastructure is running ISA. If that's the case, you may have to install ISA Client on the work computer form which you're trying to RDP to your server or home PCs.

     

    Thanks,

    Eugene

     

    Tuesday, December 18, 2007 4:35 PM
  • FWIW, I get a connection time out almost immediately when I first try to connect.  However, doing nothing but trying the connection a second time yields a connection.  Seems really odd, but that's what happens with me.

     

    Tuesday, December 18, 2007 6:32 PM
  • Hi Sail,

     

    We'd be very interested to look at your logs.

    Could you please:

    - Download toolkit from http://go.microsoft.com/fwlink/?LinkID=98601

    - Install it on the client

    - copy %ProgramFiles%\Windows Home Server\Toolkit\Toolkit.msi to the \\server\software\add-ins

    - Open admin console and install toolkit add-in

    - In admin console go to ettings page, Toolkit, Support

    - click on error report

    - submit CAB number to this thread

     

    This will send all your logs to MS and will help us to investigate your problem.

     

    Thank you!

     

    Tuesday, December 18, 2007 7:21 PM
  • Cab # 423786446

     

    Note that the timeout happens most of the time on the first attempt, but not all times.  However, in all cases, a second attempt immediately after a timeout succeeds.

     

    While you're in there, I'd apprecaite guidance on the ftdisk warnings-- posted as a separate question but got no response.

    Tuesday, December 18, 2007 9:30 PM
  •  

    I have the same problem in that I cannot remote to any of my home network machines from within the network or from the outside.  All my clients are running Windows Vista and do not require NLA.  I can use MSTSC to connect directly but the proxy through the server does not work.  I am running the latest updates on all machines.

     

    My cab number is as follows: 427297202.

     

     

    Wednesday, December 26, 2007 11:19 PM
  • So it's not the same in that trying a second time doesn't work for you?

     

    So what happens when you try to connect? No one will be able to help unless we have more details.

    Wednesday, December 26, 2007 11:31 PM
  • I experienced the same problem but then discovered that the user account I used was not allowed to log onto terminal services. To allow this user that access I went to "Admin Tools", then "Local Security Policy". From here I selected "User Rights Assignment" then added the user account to the "Allow log on through Terminal Services". Once I did this, I never received the "Remote Connection to computer timed out" message. hope that helps.

    Tuesday, February 19, 2008 6:31 AM
  • Oddly enough, my Nvidia drivers were the cause of my RDP woes.  The newer drivers would cause RDP to fail with NO errors!  Nothing in the event logs, nothing!  I had to revert back to older drivers, version 175.24 if memory serves.  This article may also provide a fix, though I have not tried it:

    http://computingondemand.com/?p=1141
    Saturday, January 09, 2010 2:57 AM