none
Outlook Clients won't connect after upgrade. Error "Cannot find any organizations on the server. Try entering the URL again...."

    Question

  • I recently upgraded from 4.0 to 2011.  The CRM server is new, but it's a separate SQL2008R2 server which contained the 4.0 DB.  I went through the upgrade process during the install and things seemed to go fine.  We can connect via the web interface, but the Outlook clients won't connect.  I've looked through all the existing cases on the forum, but none of the solutions seem to match what we're seeing and we've still got the problem.

    Wednesday, July 10, 2013 8:00 PM

All replies

  • You can check the crm50clientconfig.log to see what is the error in it. By default, the location of the configuration log files (including crm50clientconfig.log), where User is the account of the user who ran Configuration Wizard, is as follows:

    Windows XP: SystemDrive:\Documents and Settings\<User>\Local Settings\Application Data\Microsoft\MSCRM\Logs\
    Windows Vista: SystemDrive:\Users\<User>\AppData\Local\Microsoft\MSCRM\Logs
    Windows 7: SystemDrive:\Users\<User>\AppData\Roaming\Microsoft\MSCRM\Logs\ 
    You can also use this wizard to do the troubleshooting: http://rc.crm.dynamics.com/rc/2011/en-us/online/5.1_CTP/outlook-troubleshooting.aspx

    Jackie Chen, Microsoft Online Community Support. Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, July 12, 2013 2:04 AM
  • Did you also install the CRM 2011 Outlook client on the client machine or are you still using the CRM 4.0 client. Please try to install CRM 2011 client and check.

    HTH

    Sam


    Dynamics CRM MVP | Inogic | http://inogic.blogspot.com| news at inogic dot com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, July 12, 2013 3:39 AM
  • Thanks.  Here's a copy of the log.

    12:39:52|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging started: 7/10/2013 12:39:52 PM ===
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Initialize
    12:39:52|   Info| Client Configuration Wizard Version      : 5.0.9690.3448
    12:39:52|   Info| Client Configuration Wizard LanguageID   : 1033
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:39:52|   Info| Query all rows in profile table
    12:39:52|   Info| Outlook is  initialized
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:39:52|   Info| Client Configuration Wizard Running Mode : Normal
    12:39:52|   Info| Configuration file Type : OnPremise.
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetAllCRMOrgsInOutlookProfile
    12:39:52|   Info| Logon mapi store
    12:39:52|   Info| Logon admin service
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:39:52|   Info| Query all rows in msg service table
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:39:52|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:39:52|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:39:55|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:39:55|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:39:58|  Error| Exception : Cannot find any organizations on the server. Try entering the URL again. If the problem persists, contact your system administrator.    at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
       at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadOrganizationsCompleted(Boolean enableOrgSelection)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    12:48:01|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:48:01|   Info| Exit code: Default
    12:48:01|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:48:01|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging stopped: 7/10/2013 12:48:01 PM ===
    12:48:05|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging started: 7/10/2013 12:48:05 PM ===
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Initialize
    12:48:05|   Info| Client Configuration Wizard Version      : 5.0.9690.3448
    12:48:05|   Info| Client Configuration Wizard LanguageID   : 1033
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:48:05|   Info| Query all rows in profile table
    12:48:05|   Info| Outlook is  initialized
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:48:05|   Info| Client Configuration Wizard Running Mode : Normal
    12:48:05|   Info| Configuration file Type : OnPremise.
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetAllCRMOrgsInOutlookProfile
    12:48:05|   Info| Logon mapi store
    12:48:05|   Info| Logon admin service
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:48:05|   Info| Query all rows in msg service table
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:48:05|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:48:05|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:48:08|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:48:08|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:48:11|  Error| Exception : Cannot find any organizations on the server. Try entering the URL again. If the problem persists, contact your system administrator.    at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
       at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadOrganizationsCompleted(Boolean enableOrgSelection)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    12:48:40|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:48:40|   Info| Exit code: Default
    12:48:40|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:48:40|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging stopped: 7/10/2013 12:48:40 PM ===
    12:53:37|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging started: 7/10/2013 12:53:37 PM ===
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Initialize
    12:53:37|   Info| Client Configuration Wizard Version      : 5.0.9690.3448
    12:53:37|   Info| Client Configuration Wizard LanguageID   : 1033
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:53:37|   Info| Query all rows in profile table
    12:53:37|   Info| Outlook is  initialized
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.Validator.IsOutlookInitialized
    12:53:37|   Info| Client Configuration Wizard Running Mode : Normal
    12:53:37|   Info| Configuration file Type : OnPremise.
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetAllCRMOrgsInOutlookProfile
    12:53:37|   Info| Logon mapi store
    12:53:37|   Info| Logon admin service
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:53:37|   Info| Query all rows in msg service table
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.GetServiceIds
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.CleanUpDatastoreIfNeeded
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    12:53:37|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    12:53:37|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    12:53:39|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:53:39|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    12:53:42|  Error| Exception : Cannot find any organizations on the server. Try entering the URL again. If the problem persists, contact your system administrator.    at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
       at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadOrganizationsCompleted(Boolean enableOrgSelection)
       at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    12:55:56|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:55:56|   Info| Exit code: Default
    12:55:56|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    12:55:56|   Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging stopped: 7/10/2013 12:55:56 PM ===

    Friday, July 12, 2013 4:34 PM
  • We have some machines which still had the 4.0 client, we also tried upgrading to 5.0.  I also installed the 5.0 client on a brand new machine.  All have the same behavior.
    Friday, July 12, 2013 4:36 PM
  • I had the same problem. it may vary from machine to machine, but to asure anything you must macth your outlook crm version with you crm server. 4.0 and 2011 is too much difference. even a rollup difference could cause this issue. check the rollup notes for the versions that have major upgrades
    Saturday, July 13, 2013 4:38 AM
  • Hello :)

    Maybe it is problem with certificate of your organization.

    Try upload on your machine a cert of organization, and then try connecting by Conf Wizard.

    Monday, July 15, 2013 1:11 PM
  • 1. Please check the date/time/time zone is correct on the client machine.

    2. Disabled and re-enabled the user in the CRM organization 
    3. The issue might happen if the imported Organization did not get initialized correctly. You might need to restore the ORG DB and re-import it again.

    Jackie Chen, Microsoft Online Community Support. Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, July 16, 2013 1:32 AM
  • Hi Jackie,

    Thanks.

    I have the latest rollup 13 on the server and I also downloaded the latest client.

    I have checked to make sure the date/time is synched up.

    Disabling/enabling user(s) doesn't seem to have an effect.

    One thing I found during troubleshooting was that in the manager, when I'm viewing the organization, the status shows "Failed".  Everything appeared to be working after the migration so I didn't initially notice this.  I assume this is getting to your point of it not initializing correctly.  If something was wrong, I would have assumed the web interface wouldn't have worked! Anyhow, the only option I have is to Delete. 

    I don't have a lot of experience with this app, so I'm not sure what I can and can't do without detriment to the system.  Could this be the problem and if so, what's the steps to fix it?

    Wednesday, July 17, 2013 5:50 PM
  • The org status is failed which should be the cause of your issue. you can re-import the org again. If you don't want to impact the current system, you can do it like this.

    1. Restore the ORG DB to the SQL with another name, like ORG1_MSCRM.
    2. Import the Org to CRM in the CRM deployment manager, with another org name.
    3. Make sure it's working on the web and outlook.
    4. Then you can disable the old org in deployment manager.

    Jackie Chen, Microsoft Online Community Support. Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, July 18, 2013 7:10 AM
  • If I schedule some downtime, I can safely 'delete' the Org and then re-import it via the deployment manager and see if that brings the status to Online or whatever it should be?

    Thursday, July 18, 2013 11:34 PM