none
How to Deploy Customer portal with CRM 2011 Onpremise?

    Question

  • Hi,

    I have been asked to deploy customer portal with CRM 2011 on premise which is very new to me. I have been following Customer Portal Deployment Guide_OnPremises_V2.0 guide which is given here http://dynamics.pinpoint.microsoft.com/en-US/applications/customer-portal-for-microsoft-dynamics-crm-2011-12884910826 The document provided is not similar and its confusing  which is very hard to continue while configuring the steps.Guess the live.azure.com site has been modified. Has anybody had faced this kinda issue earlier? DO anyone successfully deployed this?

    Some of my doubts am listing here

    1. What are the things i require?

    2. Is one Windows live id enough?

    3. What should i enter into the redirect URL text field?

    4.Whether the  Domain should be a public one?

    5. What is cloud app URL?

    6. Do i need to verify the domain?

    7.Do i need to enter the client ID and client secret key in the WEb config file

    8. And much more....

    Do any one have proper set up documents with the screen shots. Please post it here or else refer me any link.It would be really helpful. Comments are welcome and would be highly appreciated.


    • Edited by Selvaa4u Tuesday, April 03, 2012 11:34 AM
    Wednesday, March 28, 2012 9:30 AM

All replies

  • Hi

    when i deploy customer portal I stuck in the windows live ID authentication set up. At that time I just want to set it up quickly, play around and see what features are there. So that I configured it to use ASP.NET Membership provider (SqlMembershipProvider).

    Change the web.config to the following

    <authentication mode="Forms">
        <forms loginUrl="/login" timeout="525600"/>
    </authentication>
    <membership defaultProvider="SqlMembershipProvider">
        <providers>
            <add name="SqlMembershipProvider" connectionStringName="MyLocalSQLServer" applicationName="MyAppName" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
        </providers>
    </membership>

    Change login.aspx to

    <%@ Page Language="C#" MasterPageFile="~/MasterPages/Default.master" AutoEventWireup="True" CodeBehind="Login.aspx.cs" Inherits="Site.Pages.Login" %>
    
    <asp:Content ContentPlaceHolderID="ContentBottom" runat="server">
        <asp:Login ID="Login1" runat="server" />
    </asp:Content>
    

    That will get it up and running, at the same time you can figure out how to set it up to use live id authentication properly.

    Hope this will help


    Zhongchen Zhou

    Thursday, April 05, 2012 2:17 AM
  • Dear Selva , 

    We also faced problem in customer portal with help of using windows live id , finally we followed the below link for the customer portal with switching authentication from liveid to forms 

    http://a33ik.blogspot.in/2013/01/customer-portal-switching.html


    Thanks & Regards Dhamodharan R

    Monday, March 18, 2013 6:11 AM