locked
Publishing problem - HTML brackets stripped from post?

    Question

  • This just started happening yesterday, I haven't changed anything on my blog and it was working fine with the same version/configuration of Live Writer two days ago.
    The problem is when I publish a post, it shows up with the HTML brackets stripped out.  For example if I write and publish this in Live Writer:

    This is a test.

    Paragraph two test test test.

    It will show up on my blog like this:

    pThis is a test./p pParagraph two test test test./p

    In Live Writer I've tried refreshing my blog theme and creating a completely new blog account for my blog, neither has worked.  It shows up correctly in the Preview tab in Live Writer, but when I publish something is going wrong.

    Sunday, September 28, 2008 3:57 PM

All replies

  • delutz said:

    This just started happening yesterday, I haven't changed anything on my blog and it was working fine with the same version/configuration of Live Writer two days ago.
    The problem is when I publish a post, it shows up with the HTML brackets stripped out.  For example if I write and publish this in Live Writer:

    This is a test.

    Paragraph two test test test.

    It will show up on my blog like this:

    pThis is a test./p pParagraph two test test test./p

    In Live Writer I've tried refreshing my blog theme and creating a completely new blog account for my blog, neither has worked.  It shows up correctly in the Preview tab in Live Writer, but when I publish something is going wrong.


    Welcome to the group. I have this problem since two weeks ago. I have tried almost everything. Look here: http://www.uprm.info/test . Any help would be appreciated. I want to be able to write my posts with WLW.
    Sunday, September 28, 2008 5:21 PM
  • delutz said:

    This just started happening yesterday, I haven't changed anything on my blog and it was working fine with the same version/configuration of Live Writer two days ago.
    The problem is when I publish a post, it shows up with the HTML brackets stripped out.  For example if I write and publish this in Live Writer:

    This is a test.

    Paragraph two test test test.

    It will show up on my blog like this:

    pThis is a test./p pParagraph two test test test./p

    In Live Writer I've tried refreshing my blog theme and creating a completely new blog account for my blog, neither has worked.  It shows up correctly in the Preview tab in Live Writer, but when I publish something is going wrong.



    we got the same problem here

    we have the host tring to resolve the problem

    tried other blog writer software and same problem has happened

    the host has reinstalled apache still no good

    we use wordpress the latest version even tried older version

    we setup our blog on several other test servers and had no problems

    but we would like to use are main server
    Wednesday, October 01, 2008 6:22 PM
  • Is everyone that has this problem using a self hosted version of Wordpress?
    -Brandon Turner [MSFT]
    Wednesday, October 01, 2008 11:00 PM
  • And what web hosting company are you all using?
    Wednesday, October 01, 2008 11:14 PM
  • My host is Fused Network, I guess I'll ask them if they changed something recently.
    Thursday, October 02, 2008 8:55 PM
  • i am using the lastest version downloaded directly from wordpress

    today i tried useing scriptfire from firefox and also had the problem though not as bad was getting /br for carraige returs

    ive tried all the settings no luck

    we have another ticket in at host hopefully they can solve the problem

    when they do i will report back
    Thursday, October 02, 2008 9:00 PM
  • Here's one suggestion I've found to fix this issue, I haven't tested it myself but I'm going to ask my host if they can give it a try.
    On my Fedora 9 I had to downgrade to libxml2-2.6.32-1.fc9 and xml-common-0.6.3-23.fc9.

    I initially started with a downgrade of PHP (I thought it may have been php's processing of xmlrpc.php) but still had the issue so I then downgraded libxml and xml-common and the problem was resolved.

    I then re installed the latest php from the update repo. I had to set up yum to exclude libxml* and xml-common* so the nightly yum update didn't put the libxml files back in place.

    Saturday, October 04, 2008 5:05 PM
  • Delutz, that's very interesting--do you remember where you saw that?
    Sunday, October 05, 2008 3:39 AM
  • Here:
    http://wordpress.org/support/topic/205213

    Also there's this bug report for libxml2 which might be the problem:
    http://bugzilla.gnome.org/show_bug.cgi?id=554124

    I should point out that my host downgraded and it didn't seem to fix the issue for me, so I don't know if any of this info is accurate.  And I was able to publish to a blog on a different host without this issue.
    • Edited by delutz Sunday, October 05, 2008 3:57 AM
    Sunday, October 05, 2008 3:49 AM
  • Hi

    I have the same problem with Joomla 1.5.7 and spanish language.

    WLW reconizes auto my joomla movable type api configuration. WLW upload images ok to my ftp server.
    The problem is with encoding and losing characters "<" ">"

    You can see the problem here:
    http://nova.alc.upv.es/joomla/index.php/general/434-test-wlw-artiacuteculo
    http://nova.alc.upv.es/joomla/index.php/general/454-artiacuteculo-de-prueba

    My joomla and database is configured UTF-8 enconding.

    How I can do to solve it?
    Thanks a lot in advance, and best regards from spain.
    Alex

    Alex
    Saturday, October 11, 2008 7:09 PM
  • I'm also having this problem with my own hosted Wordpress install. It worked on the previous beta, but not the newest beta version.
    I can post fine in the dashboard of my blog however, just not using WLW.
    Friday, October 17, 2008 7:40 AM
  • I am also facing this issue for both wordpress and b2e. Earlier versions of WLW worked very well with no issue. Any quick solution please?
    Wednesday, October 29, 2008 11:02 AM
  • It's definitely a bug with PHP and one of the XML libraries. I think there are multiple bugs open on PHP around this.

    Wednesday, October 29, 2008 5:21 PM
  • Hi guys, Nice to meet you..I got the same problem here..

    Btw, Im using WLW Version 14.0.393xxx, and wordpress 2.6.3

    Any Solution?
    Monday, November 03, 2008 2:04 PM
  • I'm having the same problem, started yesterday! Any solution?

    Tuesday, November 11, 2008 6:08 AM
  • I had the same issue and it's now fixed. I am using WP 2.6.5 and the latest WLW
    My web host fixed this issue in about 15 mins...see below should this be of use to anyone. Most users will probably need to get their webhost to fix it. Here's info from my host.


    For reference, the fix for cPanel servers is to create a file called all_php5 under /var/cpanel/easy/apache/rawopts/ and add the following two lines then recompile Apache:

    -with-expat=builtin
    -with-libexpat-dir=/usr/lib

    For those who are not using cPanel but instead manually compile PHP, the fix is to add the following line after the other ./configuration options then build as usual:

    --with-expat=builtin --with-libexpat-dir=/usr/lib

    • Proposed as answer by NickyJ Wednesday, December 03, 2008 3:34 AM
    Wednesday, December 03, 2008 3:33 AM
  • is this the only way  ? 
    Sunday, December 21, 2008 4:02 PM