none
Xbox 360 not seeing all files in shared videos

    Question

  • Ok my Xbox through the video/server option in dashboard and can see some of my folders in my shared video folder of my WHS but not all. There doesnt seem to be any reason why, some of the folder it cant see have AVI and the ones it does also have avi. I have rebooted a few times and no change. I have also turned off the video media sharing and back on but no change. Is there a bug in WHS/xbox.. Thanks for the help..

    Mike
    Sunday, November 22, 2009 6:44 AM

Answers

  • Thanks for the tip, i'll check it out.. 

    I figured out the problem, i was copying and making new folders to d:\shares\videos, now i started copying them to \\server\videos and they show up.. Not sure why that mattered but it works now :).. I recopied all the folders and now everything shows up.. thanks for all the tips

    Mike
    • Marked as answer by itsmike2k Wednesday, November 25, 2009 5:09 PM
    Wednesday, November 25, 2009 3:54 AM

All replies

  • Sounds like a permission issue.  On the WHS do you have the Guest account turned on, and did you give your Guest account access to that Shared folder on the WHS?
    Sunday, November 22, 2009 2:13 PM
  • media sharing is enabled so i dont think a guest account needs to be set up. That still wouldnt explain why i can see 42 sub folders but not the other 60. 
    Sunday, November 22, 2009 5:44 PM
  • I see what you are saying, I get the same thing when I set it up like what you have described.  I'll play with it and see if I can come up with something.

    Sunday, November 22, 2009 7:59 PM
  • I have a theory that I am playing with, though not very scientific in my testing:

    I think the Xbox recognizes the file formats and only lets you see what it can actually play natively.  I noticed that if I move a file that it will play to another folder, that previously you could not see (that folder), you can then see that folder available with that file in it from the Xbox.  I've tried several formats, and the only ones that become visible are those that it can actually play natively.  Like an .m2ts (AVCHD file) it cannot see, yet a .WMV or .MP4 it will.  Whether this is a "bug" or a "feature", its your call!  Hope this helps.

    Sunday, November 22, 2009 8:54 PM
  • Ok my Xbox through the video/server option in dashboard and can see some of my folders in my shared video folder of my WHS but not all. There doesnt seem to be any reason why, some of the folder it cant see have AVI and the ones it does also have avi. I have rebooted a few times and no change. I have also turned off the video media sharing and back on but no change. Is there a bug in WHS/xbox.. Thanks for the help..

    Mike
    kansascybercop is correct.  The XBox 360 will only display playable file types.  However, avi files should be playable as long as you go online and install the update from XBox Live.
    Monday, November 23, 2009 6:03 AM
  • Remember that .avi is a container, and the enclosed media may have been encoded with a codec that the Xbox doesn't have the ability to decode, or that the streaming server in Windows Home Server doesn't have the ability to serve. In those cases, I believe the Xbox won't show the media.
    I'm not on the WHS team, I just post a lot. :)
    Monday, November 23, 2009 3:22 PM
  • Ok here is what it seems to be, not that i have a fix yet. Ok i had a trial version of WHS and set it up,  now that i did a reinstall of a OEM it seems that the xbox only sees the original folders and movies. Anything new that i add doesn't show up even if its a copy of an existing movie that shows up in one of the original (trial) folders. I can delete folders and that shows up in the XBOX, but not add anything. any thoughts?
    Tuesday, November 24, 2009 4:49 AM
  • I don't know how much this will help, but I had a problem with my xbox recently where it wouldn't see any mp4 files, where it had been doing so perfectly fine for ages. It all seemed to happen when I installed Orb on the home server, but I don't know if the two were directly related (uninstalling Orb didn't help).

    Anyway, I upgraded the home server to Windows Media Player 11 following the instructions at http://www.mediasmartserver.net/wiki/index.php/Installing_Windows_Media_Player_11 and this fixed my problem. It's not exactly the same problem I know, but if you're lucky it might fix it ;)

    After upgrading I also started to get little thumbnail previews of videos that I never had before, so even if you don't have a problem I think it's worth the upgrade :)
    Tuesday, November 24, 2009 10:47 PM
  • Thanks for the tip, i'll check it out.. 

    I figured out the problem, i was copying and making new folders to d:\shares\videos, now i started copying them to \\server\videos and they show up.. Not sure why that mattered but it works now :).. I recopied all the folders and now everything shows up.. thanks for all the tips

    Mike
    • Marked as answer by itsmike2k Wednesday, November 25, 2009 5:09 PM
    Wednesday, November 25, 2009 3:54 AM
  • I had the same exact problem... Half of my videos showed up on the 360 but a bunch would not. I found that many of them had a file extension like: Filename.xvid, they were .avi or mp4 so I just deleted the ".xvid" and the 360 recognized and played them fine... I'm not a computer guy so if this sounds stupid you don't need to pick on me. I'm just telling you all what worked for me. Immediately the 10 or so that the 360 wouldn't read were showing up and playing fine.
    Tuesday, February 22, 2011 7:53 AM
  • Are you trying to play movies directly from the WHS on the XBOX?  if yes - this is not supported.   Tour X-box needs to connect to a computer (Windows XP, VISTAm Windows 7) thats  runnung Windows media Center and that PC connects to WHS
    WHS_retail version
    Wednesday, February 23, 2011 5:10 PM
  • Are you trying to play movies directly from the WHS on the XBOX?  if yes - this is not supported.   Tour X-box needs to connect to a computer (Windows XP, VISTAm Windows 7) thats  runnung Windows media Center and that PC connects to WHS
    WHS_retail version
    How is this not supported if WHS is a DLNA server?
    Saturday, December 29, 2012 4:32 AM