none
"Can't play audio file" error msg using Remote Desktop Connection to control WMP 10 on WHS and direct audio over home speakers?

    Question

  •  

    Before I installed Windows Home Servier I had XP Pro configured so I could initiate a remote desktop connection to my server from my laptop, launch WMP, and play music over my distributed speaker system controlled by a Crestron system.

     

    Now when I try to play audio files via RDP to WHS using Media Player 10 I get the following error message:

    "Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly."

     

    I recall having to configure something so that the audio stream was routed through my server and not through the client, but I cannot remember what I did and I cannot find any relevant help topics on the web.

     

    Does this problem sound familiar?  Any idea what I need to configure to make it work?

     

    Jeff


    Jeff Thiel
    Sunday, December 21, 2008 8:50 PM

Answers

  • Sound through Remote Desktop is a special situation. There are a couple of things you can try to see if you can get it to work. First, you can try changing a setting in your remote desktop connection to your server. Before you log in:
    • Start your remote desktop client.
    • Click the 'Options >>' button.
    • Select the Local Resources tab.
    • Under Remote computer sound, make sure that you choose Leave at remote computer.
    If that doesn't do it, you can try connecting to your server's console session, instead of a normal Remote Desktop session (the same settings as above apply to a console session connection):
    • Start your remote desktop client. Use a command line switch; depending on whether you have XP SP3 or Vista SP1 or Windows Server 2008, or you have a prior version, use the switch /admin or /console (respectively).
    • connect to your server.
    However, kariya21 is correct that remote desktop is not a supported access method for your server. it will work, but using it the way you propose is a violation of the EULA (not that I think Microsoft will hunt you down for it :) ) and is potentially dangerous, as there are tools available in a remote desktop session that could cause severe problems on your server.

    I'm not on the WHS team, I just post a lot. :)
    Monday, December 22, 2008 5:46 PM
    Moderator

All replies

  • jeff_r_thiel said:

     

    Before I installed Windows Home Servier I had XP Pro configured so I could initiate a remote desktop connection to my server from my laptop, launch WMP, and play music over my distributed speaker system controlled by a Crestron system.

     

    Now when I try to play audio files via RDP to WHS using Media Player 10 I get the following error message:

    "Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly."

     

    I recall having to configure something so that the audio stream was routed through my server and not through the client, but I cannot remember what I did and I cannot find any relevant help topics on the web.

     

    Does this problem sound familiar?  Any idea what I need to configure to make it work?

     

    Jeff


    Jeff Thiel



    You should not be using WHS as a desktop operating system (as a matter of fact, logging into the server desktop for any reason is unsupported).  You should be using a client PC and playing your music from the server by accessing the network shares stored on the server.

    Having said that, it sounds like you don't have a sound driver installed.
    Monday, December 22, 2008 5:16 AM
    Moderator
  • Sound through Remote Desktop is a special situation. There are a couple of things you can try to see if you can get it to work. First, you can try changing a setting in your remote desktop connection to your server. Before you log in:
    • Start your remote desktop client.
    • Click the 'Options >>' button.
    • Select the Local Resources tab.
    • Under Remote computer sound, make sure that you choose Leave at remote computer.
    If that doesn't do it, you can try connecting to your server's console session, instead of a normal Remote Desktop session (the same settings as above apply to a console session connection):
    • Start your remote desktop client. Use a command line switch; depending on whether you have XP SP3 or Vista SP1 or Windows Server 2008, or you have a prior version, use the switch /admin or /console (respectively).
    • connect to your server.
    However, kariya21 is correct that remote desktop is not a supported access method for your server. it will work, but using it the way you propose is a violation of the EULA (not that I think Microsoft will hunt you down for it :) ) and is potentially dangerous, as there are tools available in a remote desktop session that could cause severe problems on your server.

    I'm not on the WHS team, I just post a lot. :)
    Monday, December 22, 2008 5:46 PM
    Moderator