locked
Cannot find SITE object with identifier "Default Web Site/Etc/Place/Null" when installing

    Question

  • Hi there,

    tried it 5 times, no success ....happens at the very last step of Deploy Server...Thanks for any help in advance

    appcmd.exe set config "Default Web Site/Etc/Place/Null" -section:system.webServer/security/requestfiltering -allowDoubleEscaping:true

    --------------------------------------------------------------------------------------------

    ERROR ( message:Cannot find SITE object with identifier "Default Web Site/Etc/Place/Null". )

    here is a little excert of the log file it happens at the end

    07/03/200906:12:39

    Cmd.exe /D /C ASPNet_RegIIS.exe -s W3SVC/1/ROOT/RequestHandler/

    --------------------------------------------------------------------------------------------

    Start registering ASP.NET scriptmap (2.0.50727) at W3SVC/1/ROOT/RequestHandler/.

    Finished registering ASP.NET scriptmap (2.0.50727) at W3SVC/1/ROOT/RequestHandler/.

     

    --------------------------------------------------------------------------------------------

    07/03/200906:12:40

    Cmd.exe /D /C ASPNet_RegIIS.exe -s W3SVC/1/ROOT/RequestHandlerExt

    --------------------------------------------------------------------------------------------

    Start registering ASP.NET scriptmap (2.0.50727) at W3SVC/1/ROOT/RequestHandlerExt.

    Finished registering ASP.NET scriptmap (2.0.50727) at W3SVC/1/ROOT/RequestHandlerExt.

     

    --------------------------------------------------------------------------------------------

    07/03/200906:12:41

    CScript.exe //Nologo C:\inetpub\AdminScripts\adsutil.vbs SET W3SVC/1/ROOT/RequestHandlerExt/AuthPersistence 64

    --------------------------------------------------------------------------------------------

    AuthPersistence                 : (INTEGER) 64

     

    --------------------------------------------------------------------------------------------

    07/03/200906:12:41

    appcmd.exe set config "Default Web Site/Etc/Place/Null" -section:system.webServer/security/requestfiltering -allowDoubleEscaping:true

    --------------------------------------------------------------------------------------------

    ERROR ( message:Cannot find SITE object with identifier "Default Web Site/Etc/Place/Null". )

     


    Andy - ComputerHelpSOS
    Friday, July 03, 2009 10:41 AM

All replies

  • I had this same issue.  I have a bunch of web sites on my IIS machine, so I renamed the sites after their url.  This included changing the name of the web site from "Default Web Site" to "mysite.xyz.com". 

    It would appear that the web site where OCS 2007 R2 Web components are installed should be called, "Default Web Site".  Renaming the web site back to "Default Web Site" fixed the issue and OCS installs.

    Please pass on a forehead slap to the developer(s) who thought this would be a good idea.
    Saturday, September 05, 2009 3:23 PM
  • Try to remove and reinstall the IIS, to make sure which you installed the correct pre-requisites, use the following script to install IIS.

    Servermanagercmd -i web-server
    Servermanagercmd -i web-webserver
    Servermanagercmd -i web-common-http
    Servermanagercmd -i web-static-content
    Servermanagercmd -i web-dir-browsing
    Servermanagercmd -i web-http-errors
    Servermanagercmd -i web-http-redirect
    Servermanagercmd -i web-health
    Servermanagercmd -i web-http-logging
    Servermanagercmd -i web-request-monitor
    Servermanagercmd -i web-security
    Servermanagercmd -i web-basic-auth
    Servermanagercmd -i web-windows-auth
    Servermanagercmd -i web-digest-auth
    Servermanagercmd -i web-filtering
    Servermanagercmd -i web-performance
    Servermanagercmd -i web-stat-compression
    Servermanagercmd -i web-mgmt-tools
    Servermanagercmd -i web-mgmt-console
    Servermanagercmd -i web-mgmt-compat
    Servermanagercmd -i web-metabase
    Servermanagercmd -i web-wmi
    Servermanagercmd -i web-lgcy-scripting
    Servermanagercmd -i web-lgcy-mgmt-console
    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist | http://brunoestrozi.spaces.live.com
    Saturday, September 05, 2009 6:20 PM