none
Unable to create disk snapshot try running chkdsk /f/r

    Question

  • I know there are other threads on this but I can't find a solution that helps.  I get the error listed above.  Only one volume is being backed up, OS is Windows XP.  Chkdsk does not show any errors.  I have tried brubbers fix but it does not help
    Friday, January 30, 2009 7:00 PM

Answers

  • Hi,

    had you at any time Symantec Ghost installed on the client? In this case look into this thread.

    On the client run regedit, search for the CLSID {e4eb5095-f587-4159-a1d8-2710692fd243} and check, what is behind it. If this are remains from Ghost, search for the remains of it in the registry and delete these keys or values. If you are unsure, export the registry keys before deleting them.

    Best greetings from Germany
    Olaf

    Monday, February 02, 2009 2:42 PM

All replies

  • The following errors were in the event log of client computer:

    Backup set 17 on HOMESERVER failed: Microsoft.HomeServer.Backup.VSS.ShadowVolumeException: Exception from HRESULT: 0x8004230F ---> System.Runtime.InteropServices.COMException (0x8004230F): Exception from HRESULT: 0x8004230F
       at Microsoft.HomeServer.Backup.VSS.IVssBackupComponents.IsVolumeSupported(Guid ProviderId, String pwszVolumeName)
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes)
       --- End of inner exception stack trace ---
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet.CreateShadowVolume(VolumeInfo[] volumes)
       at Microsoft.HomeServer.Backup.VSS.ShadowVolumeSet..ctor(VolumeInfo[] volumes)
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.RunWithoutCatch()
       at Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.Run()

    and 

    Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {e4eb5095-f587-4159-a1d8-2710692fd243} [0x80040154].

    Maybe this helps troubleshoot?

    Monday, February 02, 2009 2:10 PM
  • Hi,

    had you at any time Symantec Ghost installed on the client? In this case look into this thread.

    On the client run regedit, search for the CLSID {e4eb5095-f587-4159-a1d8-2710692fd243} and check, what is behind it. If this are remains from Ghost, search for the remains of it in the registry and delete these keys or values. If you are unsure, export the registry keys before deleting them.

    Best greetings from Germany
    Olaf

    Monday, February 02, 2009 2:42 PM
  • Olaf,

    The CLSID is from StorageCraft.  I did have Shadow Protect trial installed at one time.  So you think if I delete this key and search for any other keys or values from StorageCraft and delete it will help?  Thank you for the help.
    Monday, February 02, 2009 8:52 PM
  • Chaz11 said:

    The CLSID is from StorageCraft.  I did have Shadow Protect trial installed at one time.  So you think if I delete this key and search for any other keys or values from StorageCraft and delete it will help?  Thank you for the help.



    I think yes, this could help. Although if you are not carefully and delete too much in the registry, your system may become unusable. So you should do this only, if you have a good level of IT knowledge and know, what you do ;-)

    Best greetings from Germany
    Olaf
    Tuesday, February 03, 2009 7:55 AM
  • Chaz11 said:

    Olaf,


    The CLSID is from StorageCraft.  I did have Shadow Protect trial installed at one time.  So you think if I delete this key and search for any other keys or values from StorageCraft and delete it will help?  Thank you for the help.



    Deleting all Storagecraft related keys will probably fix it. I would also advise you to backup the registry before you start deleting keys, and copy every key you delete to a notepad or other text file so you know what you have deleted.
    Personally I would start by deleting all except the MS Software Shadow Copy Provider from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers.

    If this doesn't fix it (after reboot) please open a command shell and run the following commands:

    vssadmin list providers
    vssadmin list writers

    If you have original XP CD you can also try and reinstall ntbackup.msi from \Valueadd\msft\ntbackup.
    Tuesday, February 03, 2009 9:52 AM
  • Deleting the key associated with CLSID {e4eb5095-4159-a1d8-2710692fd243} fixed it!!  Thank you so much!

    Do you think I still need to delete the other keys with storagecraft in them?  I will make backups first.

    Also I love WHS but would still like to use another backup program just in case.  Any suggestions?  I have tried Ghost, Acronis and Storage Craft but it seems there are potential problems with using any of them and WHS together.
    Tuesday, February 03, 2009 2:26 PM
  • Hi,
    depends what and where to you wish to backup.
    If it is mainly data, Microsoft SyncToy could be an option.
    Best greetings from Germany
    Olaf
    Tuesday, February 03, 2009 4:14 PM