none
There is a problem with this website's security certificate.

    Question

  • When remotely logging on to WHS I get the following:

     

    There is a problem with this website's security certificate.

     

    Under this warning I get:

     

    The security certificate presented by this website was issued for a different website's address.
     
    And then I have the following options:
     
    Click here to close this web page.
    Continue to this website (Not Recommended)
     
    If I click on continue I connect. How do I get rid of this?
     


    Wednesday, March 28, 2007 5:35 PM

Answers

  • The easiest way would be to view and install the certificate localy on the broswer in which you are using to connect to the webpage.  Then also add the website to the trusted sites in the security settings of the browser.

     

    The hard way would be to get a real SSL cert that matched the website name that your connecting to.  So if you were connecting to http://server.home.com then you would need to get a SSL cert with that name.

     

     

    Wednesday, March 28, 2007 5:45 PM

All replies

  • The easiest way would be to view and install the certificate localy on the broswer in which you are using to connect to the webpage.  Then also add the website to the trusted sites in the security settings of the browser.

     

    The hard way would be to get a real SSL cert that matched the website name that your connecting to.  So if you were connecting to http://server.home.com then you would need to get a SSL cert with that name.

     

     

    Wednesday, March 28, 2007 5:45 PM
  • Pugsly,

     

    Thank you. I took the easiest way.

    Wednesday, March 28, 2007 6:42 PM
  • Several bugs are reported on this in Connect (search for 'certificate').

     

    I found the following one that had lots of votes and validations listed against it: 

     

    https://connect.microsoft.com/WindowsHomeServer/feedback/ViewFeedback.aspx?FeedbackID=254482

     

    This particular defect is marked Closed (Fixed) and the comment from Microsoft is:

    We will address this issue before release. It is known and scheduled work item.
    Posted by Microsoft on 2/5/2007 at 9:36 AM

     

     

    Wednesday, March 28, 2007 7:26 PM
  •  Zalatimo wrote:

     

    Dear Pugsly,

     

    I am sorry, but both easy and hard way didnt work...please provide me with the solution ASAP as i am facing this problem when opening my hotmail inbox, and now msn.com and hotmail.com is not working

     

    Thanks a lot in advance

     

     

    This has nothing to do with hotmail/msn.com.  It's strictly to fix the certificate error when logging into your WHS at home from a remote location.

    Thursday, August 23, 2007 4:45 PM
    Moderator
  • To avoid getting this error, the user must add the website to the trusted sites in the security settings of the browser (or)

     

    Click on Tools-> Go to Internet options-> Content-> Under Certificates Click on Clear SSL sate button. Click ok and close the browser. Close all IE windows and relaunch.

     

    It worked for me.

     

    Regards,

    Santosh.

    Wednesday, December 19, 2007 12:20 PM
  •  I have added the website to the trusted web sites and am still getting this message.

     

    Got another other suggestions?

     

    Bob

     

    Wednesday, December 19, 2007 11:35 PM
  • This update to WHS might be relevant...

    http://support.microsoft.com/?kbid=941914
    Thursday, December 20, 2007 12:05 AM
  • Your hour and date in your clock its wrong, update your date and time.

     

    • Proposed as answer by joe123cal Monday, March 14, 2011 7:01 PM
    Tuesday, January 08, 2008 7:34 AM
  •  

    I setup my WHS on the 3rd of January, but I entered the date as 03-01-07 instead of 03-01-08

     

    caused all sorts of problems.  I even had to activate it straight away after setting the date correctly.  and all sorts of security issues preventing me from accessing it remotely.

    Tuesday, January 08, 2008 8:17 AM
  • ISSUE: " There is a problem with this website's security certificate". The security certificate presented by this website was not issued by a trusted certificate authority".

     

    The issue resolution as follows :

     

    1. In Windows Internet Explorer 7, click Continue to this website (not recommended). 80% the issue would be resolved once you follow this step.
    If not, you will see a red Address Bar and a certificate warning appear, keep clicking on next & cu will get a PHISHLING FILTER. Click on "YES", close ie and re- open.

    2. Another cause for this issue is that the computer's time/ date could be wrong, because in that case, the certificates may show up as expired. Change the computers time to a different date and month and revert back to the old one (Believe me, it works !!!)

    4. In rare scenarios, resetting modem & for Windows Vista users, right clicking on Internet Explorer icon, "Select Run as Administrator." has worked.

     

    In Internet explorer 6, none gets the error "There is a problem with this website's security certificate"...

     

    In Internet Explorer 6, the user will only receive a message that resembles the following:

     

    "Information you exchange with this site cannot be viewed or changed by others. However there is a problem with the site's security certificate."

    The security certificate was issued by a company you have not chosen to trust. View the certificate to determine whether you want to trust the certifying authority.

     

    The error "There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority." is dedicated for ie 7.

     

    This is infact caused due to Phishing Filter in IE 7 for enhanced security.

    more info on Phishling Filter : https://phishingfilter.microsoft.com/faq.aspx

     

    APPLIES TO:

    • Windows Internet Explorer 7 in Windows Vista

    • Windows Internet Explorer 7 for Windows Server 2003

    • Windows Internet Explorer 7 for Windows XP

     

    Reference websites:

    support.microsoft.com/kb/931850/en-us

                               msmvps.com/blogs/donna/archive/2007/02/09/ie-there-is-a-problem-with-this-website-s-security-certificate.aspx

    http://www.ie-vista.com/secure.html#cert%20problems

    Regard's,

     

    RATISH SEKHARAN NAIR

     

     

    Monday, January 28, 2008 12:49 AM
  •  RATISH SEKHAR wrote:

    ISSUE: " There is a problem with this website's security certificate". The security certificate presented by this website was not issued by a trusted certificate authority".

     

    The issue resolution as follows :

     

    1. In Windows Internet Explorer 7, click Continue to this website (not recommended). 80% the issue would be resolved once you follow this step.
    If not, you will see a red Address Bar and a certificate warning appear, keep clicking on next & cu will get a PHISHLING FILTER. Click on "YES", close ie and re- open.

    2. Another cause for this issue is that the computer's time/ date could be wrong, because in that case, the certificates may show up as expired. Change the computers time to a different date and month and revert back to the old one (Believe me, it works !!!)

    4. In rare scenarios, resetting modem & for Windows Vista users, right clicking on Internet Explorer icon, "Select Run as Administrator." has worked.

     

    In Internet explorer 6, none gets the error "There is a problem with this website's security certificate"...

     

    In Internet Explorer 6, the user will only receive a message that resembles the following:

     

    "Information you exchange with this site cannot be viewed or changed by others. However there is a problem with the site's security certificate."

    The security certificate was issued by a company you have not chosen to trust. View the certificate to determine whether you want to trust the certifying authority.

     

    The error "There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority." is dedicated for ie 7.

     

    This is infact caused due to Phishing Filter in IE 7 for enhanced security.

    more info on Phishling Filter : https://phishingfilter.microsoft.com/faq.aspx

     

    APPLIES TO:

    • Windows Internet Explorer 7 in Windows Vista

    • Windows Internet Explorer 7 for Windows Server 2003

    • Windows Internet Explorer 7 for Windows XP

     

    Reference websites:

    support.microsoft.com/kb/931850/en-us

                               msmvps.com/blogs/donna/archive/2007/02/09/ie-there-is-a-problem-with-this-website-s-security-certificate.aspx

    http://www.ie-vista.com/secure.html#cert%20problems

    Regard's,

     

    RATISH SEKHARAN NAIR

     

     

    You should not be seeing this error any more.  MS released a patch in November that installs a certificate from GoDaddy that should get rid of this issue.

    Monday, January 28, 2008 3:35 AM
    Moderator
  • I use an HP Mediasmart and a Domain name from TZO

     

    Within my network----I never see the Security Certificate's warning when accessing my home page...

     

    Outside my home network---I ALWAYS see the warning.

     

    Is there a way to export the certificate to a file so I can then move it and load it on my laptop and my work machins so I no longer get that stupid warning????

     

    At least from those two machines----which I normally use to access my homepage while away from home....

     

    Thanks for any help....

     

    I have tried to use GoDaddy to 'build a certificate"  for my TZO domain Name-----but their help and tech support was totally useless----basically wasted phonecalls.....

     

    They took my $30 and ran.........

    Tuesday, January 29, 2008 4:17 PM
  • John, the GoDaddy certificate is issued for the homeserver.com domain. I'm sorry, but you can't "move" it to another domain. I haven't actually obtained a commercial certificate for my WHS (the GoDaddy cert is fine for what I'm doing) so I'm going to see if I can get someone who I know has obtained and installed a certificate to write up a "how to."
    Tuesday, January 29, 2008 4:32 PM
    Moderator
  • Perfect Ken----that would be great.

     

    I'm sure there are a ton of HP MediaSmart owners who run into the same thing constantly.

     

    It's an irritation that I know there just has to be a way to fix.

     

    I was showing my 82 year old mother in law my brand new homepage from her computer-----of course the security warning popped up.  Thought she was going to have a heart attack----kept asking me what I'd done to her computer----had I put a "Virus" on it....

     

    My wife was going to kill me!!!

     

    A how-to writeup to fix this would be excellent.

     

    John

    Tuesday, January 29, 2008 7:26 PM
  • Hmm. Something occurs to me. You will need to be the owner of the domain for which you are requesting a certificate. That means that you won't be able to request one for a TZO, DynDNS, or other dynamic DNS provider-supplied name, unless you're paying for a custom name (see information for TZO and DynDNS).

    I could, for example, obtain a cert for any of the domains that I personally own, but not for my vanity URL at homeserver.com. I'm not aware of any vendors that don't have this requirement.
    Tuesday, January 29, 2008 8:42 PM
    Moderator
  • You are correct Ken, TZO and all other DDNS providers that I know of will not allow you to get a cert for one of the subdomains they offer. This also goes with the HP Domains available via TZO within the MediaSmart server - at least until HP has a solution for this issue - which Im sure will happen eventually

    If you do purchase an HP custom domain name powered by TZO in the MediaSmart, I can help you generate the CSR and get you up and running.  We can document the process and I can plop a tutorial on MyHomeServer.com that will help guide others through this process.

    Feel free to give me a shout by sending me a message to - editor - at myhomeserver.com


    Tuesday, January 29, 2008 9:33 PM
  •  MyHomeServer.com wrote:

    If you do purchase an HP custom domain name powered by TZO in the MediaSmart, I can help you generate the CSR and get you up and running. 

     

    Thank you so much----that would be VERY helpful.....

     

    But one thing I do not understand----do I have to purchase something else from TZO???

     

    I am using the HP/TZO one year free Domain Name----then will pay any following year after that.

     

    Am I supposed to pay for additional stuff???

     

    Is this what you mean by "Vanity Name"?

     

    I haven't actually purchased a domain????  I'm just using a name that will link to a TZO domain??

     

    Am I understanding this correctly???

     

    And if I have to purchase something else----how much money are we talking about as an estimate???

     

    Sorry to sound stupid but I'm new to networking, domains and stuff like security certificates.

     

    Thanks again----John

    Wednesday, January 30, 2008 7:35 PM
  • John, there are different classes of service available from the various dynamic DNS providers. Some of them include a fully custom domain name, such as say http://www.johnrrc.com. That sort of name is the only one you will be able to purchase an SSL certificate for. Microsoft can issue them for the homeserver.com domain because they own that whole domain. I provided links to two dynamic DNS providers' pages describing this process.

    So if you want a custom URL (what I referred to as a vanity URL) with an SSL certificate, you will need to spend even more money than you already have. Or you can use the free certificate that you get with the homeserver.com domain; it's a great value. But then you're stuck with johnrr6.homeserver.com, or whatever.
    Wednesday, January 30, 2008 8:33 PM
    Moderator
  • Hi John,

    In order to get your OWN domain name, you first need to register a domain - via TZO or anywhere else
    Being a MediaSmart customer, you can go through the Remote Access section in the MediaSmart and select the HP CUSTOM DOMAIN and select your domain name  - such as LuckyJohn.com or ServerJohn.com, etc

    Right now you are using a free domain that is owned by HP and run by TZO. This costs nothing the first year, and then $9.99 per year after it expires.  At this time, HP and TZO are not offering Certs on these domains, but like Ken says, you can move to a Homeserver.com domain and get a free cert, OR you can upgrade to a Custom domain within the MediaSmart and then purchase a cert to apply to this domain.  Microsoft does NOT offer a custom domain option, so it's their free homeserver.com domain and thats it - but you do get a free cert with this.  It costs nothing but I've had some issues with the DNS reliability using the homeserver.com, and have seen a number of "unkonwn errors" when setting up a homeserver.com - sometimes it works and sometimes it doesnt.  If you search through here you'll also find plenty of other folks that have reported DNS and signup issues with the homeserver.com domain - not sure if they fixed these issues, but in testing a homeserver.com domain yesterday, I got the "unknown error" when trying to choose a homeserver.com domain...It's all up to what you prefer and what works best for you....



    Here is the breakdown of costs you are looking at - keep in mind this is for HP MediaSmart customers only, they get a price break:

    TZO Premiere Service (DNS service for your own custom domain) - $24.95 per year
    (Does not include registration, see below)

    TZO Domain Registration - $14.95 per year (If you already have a domain registered, you can just point the DNS to TZO and this will do the trick - you do not have to register the domain if you have one already)

    Cost of the Certificate - depending on what level of cert you get - at this time TZO does not sell certs, but you can buy one from GoDaddy or anywhere else.  This is where you have to GENERATE THE CSR -

    So, to get this working, it's $39.90 payable to TZO if you don't have a private domain name already regsitered.  Only $24.95 if you do already have a domain - you just need to point the domain name at the TZO DNS servers for it to work.

    Hope this helps, give me a shout if you have more questions

    Wednesday, January 30, 2008 9:16 PM
  • Thank you----I think I get it----and I may be much better off than I thought----especially money wise.

     

    Years ago----I purchased a Domain Name from www.mydomain.com

     

    Basically bought my family name.com for 10 years and the rate was incredibly cheap.

     

    So I think all I have to do is "Transfer" that domain name to TZO and it will cost me $24.95.

     

    I have already paid GoDaddy----for a Certificate which has never been generated (there telephone help was not very good and I was probably no help to the poor guy----bottom line he finally said "call HP" and gave up)

     

    So I go back to GoDaddy----this time armed with better information......

     

    Get the certificate (Do I have to Load this Certificate somehow??----or does it magically just work once you get it.

     

    Then I have to reconfigure WHS with the new domain stuff.

     

    Viola!!

     

    Have I got the gist of it???

    Thursday, January 31, 2008 2:01 AM
  • John, you will need to pay TZO as you said. Then you will need to generate a certificate signing request (CSR) from your server, which you will provide to GoDaddy. They'll generate a signed certificate for you, which you will install. I think editor (hey, "editor," how about a name? Smile ) might have a step-by-step walkthrough on his site.

    Thursday, January 31, 2008 1:12 PM
    Moderator
  • Friday, February 01, 2008 12:41 AM
  • This all sounds right, I'm looking at doing the certificate "add" through TZO sometime in the next few days and hope to have this posted early next week.  For the short term fix, you can "accept the certificate permanently" and that will make it go away. I don't use IE unless required, so Im not sure of the steps to do this on IE, but its simple to make this go away after the first time in firefox by just clicking "accept the certificate permanently"

    With my CERT tutorial, I'll focus on choosing a custom domain name in the HP MediaSmart and registering the domain with TZO.  I'll then focus on generating the CSR and getting a 128 Bit "Domain Only" cert installed for "myCustomName.com"

    This should help most of those folks that are having questions, and this should help in the short term while we wait to see if there is a cert solution for using domains than homeserver.com from MSLive.

    -Eric (editor -at- myhomeserver.com)



    Friday, February 01, 2008 1:24 PM
  • John, as described that walkthrough should cover what people will need to know:
    • purchase a fully custom domain
    • generate a CSR
    • get the certificate signed
    • install the signed certificate
    It won't matter who the dynamic dns provider is, as long as the domain is owned by the individual requesting the certificate. As for a soution other than homeserver.com, there won't be one from Microsoft. And I don't think HP has much interest in providing them, either, except maybe to EX47x purchasers. Smile
    Friday, February 01, 2008 5:52 PM
    Moderator
  • Did it!!!

     

    Kinda proud of myself......

     

    An old lunkhead like me actually got this done....

     

    1. I went into WHS settings and unconfigured my current web page setup.

    2. Reconfigured under "Custom Domain Name" under TZO and select "Transfer"

    3. Purchased the "Premier" service with a transferred name from TZO ($24.95 a year)

    4. Went to mydomain .com (the ownere of my domain name----and pointed the DNS servers to ns.tzo.com, ns2.tzo.com, ns3.tzo.com, ns4.tzo.com and  ns5.tzo.com----took about 3 hours for the domain nameservers to update

    5. Went to goDaddy.com and purchased a Standard SSL Security Certificate ($29.95)

    6.  Part of the process is to generate a CSR (certificate signing request) from your server----the godaddy site has excellent directions that walk you through----use Microsoft IIS 6.0 for the walk-through.

    7. Took the copied text of the CSR that I just generated from the server and pasted it into GoDaddy's certificate building process.

    8. Published the Certificate

    9. Used the goDaddy instruction accompanying the published certificate to intall the new certificate on the WHS server.

    10. Tested and Viola!!  I now have my WHS site using my custom name without any security problems with the SSL portion!!

     

    Phew!!

     

    One tip----make sure you do this all on "Default Web Site----not the Web site entitled "WHS"

     

    It was a long process----a good step by step will really help folks!!!

     

    But this can be done....

     

    John

     

    Monday, February 04, 2008 9:07 PM
  • Hi All

    We've been working on these tutorials for a while now and finally have released them on our site at http://www.MyHomeServer.com

    We step you through the process of exporting and removing a cert (for those of you that have a homeserver.com domain) and we then show you how to register your own domain name with TZO, generate a CSR, signup for a cert and then install that cert in your server.  I Hope this helps everyone that has been asking for this type of info!

    Any issues let us know by emailing editor@myhomeserver.com - I hope these help everyone that's been having these issues and want a resolution




    Wednesday, February 13, 2008 7:35 PM
  • Thank you for this tutorial!!!!  This worked perfectly and we now have our own domain name with no more security warnings!
    YAYYYY!!!!

    My wife and I set this server up to do 2 things, backups our PC's at home and share our family pictures with the rest of the family.  our hp mediasmart has been great, but we received many emails from our friends/family that they came uup with an error when they went to our website (the hp picture webshare) - at least half of people on our small mailing list were scared to go to our pictures! all is O.K. now though after we did this and my wife was happy that we get to test out the certificate first before we buy it

    thanks much for this forum,

    Scott


    Saturday, February 16, 2008 12:23 PM
  •   Oh my gosh... I checked and checked ran AV spyware safemode and even tried system restore  who would have thought? And I was so confused why in the restore it said June  2028. Thank you Thank you Than YOU

    Tuesday, June 03, 2008 3:27 AM
  • i have this exact problem except for that i don't have the option to continue with the website, which is a pain in the arse because the website its doing it to is hotmail so my mum and my boyfriend are unable to read emails as theyre both on hotmail.com, but i can see my emails as im on msn.com... can someone please help me??

     

    Monday, June 23, 2008 9:17 PM
  •  

    Thanks!...this worked for me..phew!
    Tuesday, June 24, 2008 9:22 AM
  • Ok  well i have followed everything on this  site  and nothing seems to help  i have imported new certs  i have check , changed, and reset time  nothing
    phising   checked all that    nothing
    security settings  checked all that  adn well still nothing still haveing the problem   but only with  one computer 
    the other 10 comps that i have here  all  same service pack  all up to date  all same hardware and software on them   but only one computer is having this issue   any other suggestion?????
    Thursday, December 04, 2008 9:02 PM
  • texas aggie82 said:

    Could you please post your question as a new thread? Threads already marked as answered don't receive the same level of attention as unanswered questions, and your problem sounds like it's unrelated to the original issue.

    And please provide a bit more detail. You're having some sort of problem with a certificate, but where you're seeing the issue, what error messages, etc. will be vital to finding an answer.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, December 04, 2008 9:51 PM
    Moderator
  • thank you ZENZ,
    the hour and the date in my clock were wrong... updating this values, the problem was fixed ! thanks a lot !!
    Wednesday, May 06, 2009 5:09 PM
  • CHECK THAT THE DATE AND TIME ON THE COMPUTER IS CORRECT, INCLUDING THE YEAR

    Most common reason for such security certificate error is that the certificates are valid for a certain period of time, and if your computer’s date is set to other than the current date or correct date, there are high chances that you will get this warning. So the first thing to check when you receive such error is to check your computer’s
    date and time settings.


    Read more: http://www.troublefixers.com/security-certificate-error-while-opening-web-sites/#ixzz0RQ1zbaVd
    Friday, September 18, 2009 1:51 AM
  • i have a big problem, i need someone to help me asap Ahmed
    Sunday, November 01, 2009 2:03 PM
  • i have a big problem, i need someone to help me asap Ahmed
    You need to post more (some) info (and preferably start your own thread).
    Sunday, November 01, 2009 11:44 PM
    Moderator
  • that fixed it for me.   Thank you.

    Sunday, February 28, 2010 8:13 AM
  • I tried your secon option because my date was wrong and I worked for me. (Believe me it works!).

    Wednesday, April 21, 2010 6:09 AM
  • I tried to get a certificate. I went to tools, internet options, Security and then certificates. When I tried to get a certificate, it gave me the window to choose the application and then browse to find the file. I couldn't find a file to choose. I am getting the error message when I try to go to my Gmail. This hasn't happened before so I am puzzled. 

     

    Sunday, April 25, 2010 1:35 PM
  • I had a user with this issue and keep banging my head trying to figure out what was wrong until I had the user access the site in firefox and got the same problem (just different wording because it was firefox).  Just so nobody over looks the really simple and stupid solution here.  In my users case she was trying to access a website but was not putting www in front of it.  so she would type in sitename.com and press enter.  It would go to the site fine but when she clicked the login link on the page she got the error about the certificate.  However after launching it in firefox and getting a bit more discriptive error message I tried www. then the sitename.com and voila no issues.  Tried it in IE and same thing took care of the issues.  The reason is the certificate is specifically issues for www. whatever the site was.  it wasn't issued for just the sitename.com even though it was the same site and would work.  So just in case pay very close attention to exactly what sitename the certificate is registered to because if what you are typing in for the url doesn't match exactly it will cause this issue. 

    Wednesday, August 04, 2010 8:49 PM
  • Many things, I tried everything and your suggestion worked!! thanks again, it was so frustrated before.
    Thursday, August 19, 2010 1:32 AM
  • When remotely logging on to WHS I get the following:

     

    There is a problem with this website's security certificate.

     

    Under this warning I get:

     

    The security certificate presented by this website was issued for a different website's address.
     
    And then I have the following options:
     
    Click here to close this web page.
    Continue to this website (Not Recommended)
     
    If I click on continue I connect. How do I get rid of this?
     

     


    • Proposed as answer by maila123 Wednesday, September 08, 2010 9:37 PM
    • Unproposed as answer by Ken WarrenModerator Wednesday, September 08, 2010 11:18 PM
    • Proposed as answer by maila123 Thursday, September 09, 2010 1:22 AM
    • Unproposed as answer by kariya21Moderator Thursday, September 09, 2010 4:22 AM
    Wednesday, September 08, 2010 9:31 PM
  • Changing the date and time is definitely working so far.

    I'm not sure why the date and time changed in the first place.

     

    Thank you.

    Saturday, January 22, 2011 1:01 AM