none
Reoccurring Error--Event ID: 25, Source: VolSnap

    Question

  • Almost nightly, I have noticed a message similar to the following in the Event Viewer:

    "The shadow copies of volume C:\fs\17 were deleted because the shadow copy storage could not grow in time.  Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied."

    This generally happens between midnight and 4:30am.  Looking over the logs, I see that this error is also generally happening during or immediately following one of the following conditions:

    1.  Backup sets of another home PC (Event IDs 258, 260. or 261)
    2.  Cleanup of the backup database (Event ID 276)

    While WHS seems to recover okay and the backups do seem to complete just fine, I've found that other services are seemingly being impacted by these events, such as my USB connected, Hauppauge HD-PVR stopping whatever it was in the middle of recording and then not being able to record anything else until I power cycle the device.

    Most of the searching I've done on the error points to solutions for Windows Server 2003, not WHS.  Those that I did find for WHS didn't seem to apply to me.

    Any ideas?
    • Edited by brubberModerator Tuesday, February 03, 2009 2:56 AM edited to make post readable
    Sunday, February 01, 2009 8:11 PM

Answers

  • Skirge01 said:

    I didn't turn on volume shadow copies myself.  I suppose it's possible that some piece of software turned it on.  I could try turning the service off and see if anything breaks.

    The tuner isn't built-in, but connected via USB.  If no tuners are supported, then it doesn't really matter, though, does it?

    I am recording directly to the storage pool.



    Shadow copies are made for storage volumes automatically every 24h in default WHS install (OEM disk kit WITHOUT Powerpack1). Shadow copies on + frequency is set by a single registry key. Please note there are some issues with shadow copies on WHS, so you can not simply rely on them. More reading: How to regain access to previous version of files in WHS shares and Previous Versions for files on Windows Home Server Shared Folders may not function correctly

    You can change the location where shadow copies are stored and the maximum size; logon to the WHD desktop, open explorer window, expand my computer, right click C or D partition, Shadow Copies Tab, Settings. Please note shadow copies will show disabled for all volumes, please don't change this. WHS will only create shadow copies for storage volumes (D and C:\fs\*). If you also want shadow copies for other volumes you should set them enabled manually.

    Since shadow copies are not supported on WHS anyway you can also choose to disable them completely;  
    1. Log on to your WHS using  Remote Desktop (RDP)
    2. Do Start, Run, type regedit and Hit Enter
    3. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes\
    4. Select the Volume which represents the D partition (select volume key, value for mountpoint should be D)
    5. DELETE the REG_DWORD key SnapPeriod.
    6. Reboot to make effective.
    7. Check after 24h if snapshots are no longer created (RDP into WHS, in explorer window right click drive letter, select shadow copies) 
    Tuesday, February 03, 2009 3:18 AM

All replies

  • Hi,
    volume shadow copies on WHS are not supported. If the disk is nearly full, it is to expect that they do not find enough place to take a snapshot of larger changes.
    Also not supported are builtin TV cards and recording directly to the server.
    To which target are you recording? This should be either a network share on the server (not through the file system) or to a dedicated disk, which is not part of the storage pool.
    Best greetings from Germany
    Olaf
    Sunday, February 01, 2009 11:05 PM
  • I didn't turn on volume shadow copies myself.  I suppose it's possible that some piece of software turned it on.  I could try turning the service off and see if anything breaks.

    The tuner isn't built-in, but connected via USB.  If no tuners are supported, then it doesn't really matter, though, does it?

    I am recording directly to the storage pool.
    Monday, February 02, 2009 7:18 PM
  • Hi,
    you can disable Volume Shadow copies.
    Some details you can also find in the Technical Brief for Drive Extender.
    Best greetings from Germany
    Olaf
    Monday, February 02, 2009 11:29 PM
  • Skirge01 said:

    I didn't turn on volume shadow copies myself.  I suppose it's possible that some piece of software turned it on.  I could try turning the service off and see if anything breaks.

    The tuner isn't built-in, but connected via USB.  If no tuners are supported, then it doesn't really matter, though, does it?

    I am recording directly to the storage pool.



    Shadow copies are made for storage volumes automatically every 24h in default WHS install (OEM disk kit WITHOUT Powerpack1). Shadow copies on + frequency is set by a single registry key. Please note there are some issues with shadow copies on WHS, so you can not simply rely on them. More reading: How to regain access to previous version of files in WHS shares and Previous Versions for files on Windows Home Server Shared Folders may not function correctly

    You can change the location where shadow copies are stored and the maximum size; logon to the WHD desktop, open explorer window, expand my computer, right click C or D partition, Shadow Copies Tab, Settings. Please note shadow copies will show disabled for all volumes, please don't change this. WHS will only create shadow copies for storage volumes (D and C:\fs\*). If you also want shadow copies for other volumes you should set them enabled manually.

    Since shadow copies are not supported on WHS anyway you can also choose to disable them completely;  
    1. Log on to your WHS using  Remote Desktop (RDP)
    2. Do Start, Run, type regedit and Hit Enter
    3. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes\
    4. Select the Volume which represents the D partition (select volume key, value for mountpoint should be D)
    5. DELETE the REG_DWORD key SnapPeriod.
    6. Reboot to make effective.
    7. Check after 24h if snapshots are no longer created (RDP into WHS, in explorer window right click drive letter, select shadow copies) 
    Tuesday, February 03, 2009 3:18 AM
  • Thanks for editing my original post.  The forum was acting very strange when I initially posted and there wasn't supposed to be anything after the "Any ideas?" piece.

    Anyway, I'll try disabling Shadow Copies entirely and see how it works.  I really have no need for them.  I'll report back regardless of the outcome.

    Thanks!
    Tuesday, February 03, 2009 6:03 AM
  • I was about to make the change suggested to turn off Shadow Copies and decided to look at the D: drive's Shadow Copies tab beforehand, so I'd know what was different after the change.  I noticed that the "Next Run Time" says "Disabled" for D:.  Is this normal BEFORE I've made the registry change?  I just want to ensure things are as expected before I make the change.
    Friday, February 06, 2009 5:49 AM
  • Skirge01 said:

    I was about to make the change suggested to turn off Shadow Copies and decided to look at the D: drive's Shadow Copies tab beforehand, so I'd know what was different after the change.  I noticed that the "Next Run Time" says "Disabled" for D:.  Is this normal BEFORE I've made the registry change?  I just want to ensure things are as expected before I make the change.


    Yes, that is normal.  The reason it's like that is because it's not Server 2003 that is running the Shadow Copies, it's WHS.
    Friday, February 06, 2009 6:23 AM
  • Just wanted to pop back in and say thanks.  Turning off the shadow copies did indeed fix the issue with no side effects.
    Thursday, March 05, 2009 3:50 AM