none
.NET 4.0

    Question

  • My WPF code won't run on my XP machine, saying there is no .NET 4.0.
    I try to download .NET 4.0 and it won't load, saying there is already .NET 1.0 installed.
    But there isn't. I uninstalled it for this purpose days ago

    Ray Reeves
    • Moved by Linda Liu Friday, March 19, 2010 9:42 AM (From:Windows Presentation Foundation (WPF))
    Monday, March 15, 2010 3:46 PM

All replies

  • 1. Download the Visual Studio 2010 release candidate from the Microsoft site
    http://msdn.microsoft.com/en-us/vstudio/dd582936.aspx (Scroll down to the section Release Candidate downloads).

    2. It will automatically install .NET 4.0 and also enable you to use WPF4.

    Please revert if you had any problems after that. Hope this helps.

    -Mamta
    Wednesday, March 17, 2010 5:17 AM
  • Thanks Manta. That gets me NET4 alright but it seems a ____ of a way to get it.
    It downloads 4 large files and then extracts an iso file. I don't know how to get the VS2010 out of that.
    When I click it SONIC appears, which is useless.

    ray reeves
    Wednesday, March 17, 2010 7:10 PM
  • Ray,
    ISO files are image files. You can burn it (with Sonic) or mount it with other tools (Daemon Tools / Clone Drive/ etc). When mounted they act as a burned CD/DVD.

    Then you can access the files inside.

    Hope this helps.
    noorbakhsh حميد نوربخش
    • Proposed as answer by noorbakhsh Wednesday, June 09, 2010 3:49 PM
    Wednesday, March 17, 2010 7:22 PM
  • Thanks. I successfully burnt a CD and used it to install VS2010. Successfully, I think.
    Sunday, March 21, 2010 4:16 PM