locked
The security token could not be authenticated or authorized :O

    Question

  • Hi,

     

    i've  sucessfully deployed my wes adapter to the sandbox. I am able to manualy invoke the methods from the sandbox portal, but i am unable to create a session using http://csfsession.networkmashups.com/Session30/SessionManagerAdmin.ashx although i am using my provisioned username and password (the same as for login into the sandbox). The error i am getting is:  The security token could not be authenticated or authorized ... so what could be the problem ? Where can i check if my credentials are allowed to create a session using the sandbox's SessionManager or get some information what kind of credentials i have to provide to sucessfully create a session Smile

     

    I have a windows forms ui registered as an endpoint, from which i am trying to create a session. If i provide my username and password (token) i get The security token could not be authenticated or authorized, but if i provide nothing then i get: Request message doesn't validate against any of the configured assertion, which sounds reasonable.

     

    I hope somebody would be able to help me out, cause i am running out of ideas. Just for the information everything works OK in my dev enviroment with both the csf lite and the normal version.

     

    Cheers, Simon

     

     

    Wednesday, May 30, 2007 4:04 PM

Answers

  • Hi Matei,

     

    i found the problem Smile You have to use your username in the username@networkmashups.com format. It wasn't written anywere in the documentation or at least i didn't find it, but it works. The password stays the same as for loging into the portal.

    I hope that will resolve also you problem, as it did mine.

     

    Cheers, S

     

    Sunday, June 03, 2007 1:44 PM

All replies

  • Hi,

     

    I am having the same problem. The security token could not be authenticated or authorized. I am also using the same credentials I use for logging into the sanbox. Have you found a solution to this problem?

     

    Much appreciated!

    Matei Dorobantu

    Thursday, May 31, 2007 2:47 AM
  • Hi,

    No sadly not yet,  i posted the question just yesterday.

    But i am refreshing this page every hour cause I need an answer or some kind of direction what to do - who to ask asap Smile

    If you come to a solution before we get any feedback on this forum, please post it and relief my suffering Smile

     

    Cheers, S

     

     

    Thursday, May 31, 2007 11:04 AM
  • Will do! There are a couple of posts related to this but they didn't help much. I created a new acount but I have the same problem. I suspect it has something to do with the account creation, for some reason the page just sits there and does nothing. I get the email to verify the password bu the account creation page just kinda times out eventualy (after about 10 minutes or so)

     

    Cheers,

    Matei

    Thursday, May 31, 2007 1:30 PM
  • Hi Matei,

     

    i found the problem Smile You have to use your username in the username@networkmashups.com format. It wasn't written anywere in the documentation or at least i didn't find it, but it works. The password stays the same as for loging into the portal.

    I hope that will resolve also you problem, as it did mine.

     

    Cheers, S

     

    Sunday, June 03, 2007 1:44 PM
  •  

    are you sure about this solution type resolve the problem. i'm getting same error. i did same example which is in codeproject web page. but i'm getting this error. i did your solution but it didn't. how can i resolve this problem.

    please help..

    Wednesday, October 22, 2008 10:54 AM