none
namespace "IdentityModel" does not exist in the namespace "Microsoft.Xrm.Portal"

    Question

  • Hi,

    I got following errors in Visual Studio 2010 when trying to compile the CustomerPortal project  included in the CustomerPortal.zip.cab. I am confused why the IdentityModel  is under Microsoft.Xrm.Portal. I have installed Microsoft Identity Framework and it is listed as "Microsoft.IdentityModel" in project references. Can anybody help? Thanks.

    C:\CustomerPortal\Web\Global.asax.cs(4,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Pages\ConfirmInvite.aspx.cs(6,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Pages\ConfirmInvite.aspx.cs(7,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Pages\Error.aspx.cs(2,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\MasterPages\Default.master.cs(5,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Controls\AzureACS.ascx.cs(4,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Controls\AzureACS.ascx.cs(5,28): error CS0234: The type or namespace name 'IdentityModel' does not exist in the namespace 'Microsoft.Xrm.Portal' (are you missing an assembly reference?)
    C:\CustomerPortal\Web\Pages\ConfirmInvite.aspx.cs(14,13): error CS0246: The type or namespace name 'IUserRegistrationSettings' could not be found (are you missing a using directive or an assembly reference?)

    Compile complete -- 8 errors, 0 warnings

     


    lulu2005

    Thursday, March 29, 2012 6:47 PM

All replies