none
Outlook client pop-up blocker error

    Question

  • Hi,

    Users in my company are using CRM Outlook Client 4.0. Some of them, when they try to open an account, they get the following error: " A Microsoft Dynamics CRM windows was unable to open, and may have been blocked by a pop-up blocker. Please add this Microsoft Dynamics CRM server to the list of sites your pop-up blocker allows to open new windows: <server name>."

    The fact is i already added the server name to the list of sites. So might there be any other reason for that?

    Thanks in advance

     

     

    Monday, January 12, 2009 7:12 AM

Answers

  • Depending on the error message - if it includes messages that the error is thrown when it attempts to "prepareEnablePresence" Check to see if all your contacts have last names  (field is required, but sometimes is omitted if some contacts were imported without lastnames) - The error is likely coming from the Presence Indicator's effort to check to see if that person is online (using messenger)- if it doesn't have a last name, it fails for some people. -

    http://dmcrm.blogspot.com/2008/10/hide-annoying-script-error-popups.html

    A Microsoft or an experienced partner can help out by updating the OrganizationBase Table to change the 'ispresenceenabled' setting to off and avoid the issue altogether.

    There is a Microsoft KB article on how to turn off the Presence Controls throughout the system, check the KB article ID 947545 (you will need a PartnerSource log in to view the KB article).
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Tuesday, March 31, 2009 9:18 PM
  • Hi,

    We had the same issue (only CRM within Outook Client generated "Window blocked" alert and we solved it in the following way:
    1. Disable all the pop-up blockers in IE, together with Google Toolbar and other third paty tools
    2. For the trusted sites allow for scripting and running activex controls, also unsigned
    3. Kill all IE processes or resart te computer.

    The main poblem was caused by the Google Toolbar that blocked only (sic!) Pricelist modal window in CRM Outlook client.

    Kind regards,
    Kuba
    -- Kuba Skałbania, Netwise
    Tuesday, March 31, 2009 9:39 PM
  • I fixed this by running a command prompt (Start Menu > Run... > cmd) and typing: taskkill /f /im iexplore.exe This killed all instances of Internet Explorer that were running in the background. Once I did this, the pop-up message stopped right away.
    Wednesday, December 08, 2010 10:59 PM
  • What does support say; have you opened a ticket?
    CRM Site Manager
    Thursday, March 12, 2009 8:13 PM

All replies

  • Hi Sabine

     

    Have you cleaned up your browser cache and restarted Outlook after those steps?

     

    Vonzie

     

    Monday, January 12, 2009 7:22 AM
  • Hi,

    I am trying to add the server name to the pop-up allowed sites but i am getting an error so i am unable to add it.

    But even when i turn the pop-up blocker off, i still get the error when opening the accounts.

    Note: The Accounts are opened with no problem from the web client so it's only an outlook error. How to solve it?

    Any more idea?

    Monday, January 12, 2009 9:00 AM
  • Add the crm url to IE trusted sites. run the crm diagnostic tool which may fix your error (start > program files > microsoft dynamics crm 4.0 > diagnostics)

     

    Monday, January 12, 2009 8:41 PM
  • Hi

    Thanks for your help.

    Actually the crm url is added to the IE trusted sites. Also, i ran the diagnostic tool but it didn't fix the problem. The user has no google, yahoo... toolbars. So is there any other idea?

     

     

    Tuesday, January 13, 2009 8:52 AM
  • After all those steps my guess is to re-configure the Outlook-client. Do you have the same address from intranet and internet? Check you can browse into both of them via IE?

     

    Tuesday, January 13, 2009 9:06 AM
  • Hi,

    I just reconfigured Outlook. It didn't work. But from the webclient everything is normal. What's the reason for this error?

     

    Tuesday, January 13, 2009 3:23 PM
  • hi sabina,
    I am facing the problem with one of user. He has Office 2007 client and does not have any tollbar. Have you managed to solve the issue, if yes, could you please let me know how you have managed to resolve it. Your quick response will be highly appreciated.

    Thanks

    Mou
    CRM Analyst
    Tuesday, March 10, 2009 8:52 PM
  • Hi,
    Actually nothing seems to be working.
    Haven't managed to solve the issue yet.
    Keep me posted and i'll do the same :)
    Wednesday, March 11, 2009 7:28 AM
  • What does support say; have you opened a ticket?
    CRM Site Manager
    Thursday, March 12, 2009 8:13 PM
  • bump as I am having the same problems and have tried all the proposed ideas from here and google group.
    Wednesday, March 18, 2009 3:54 PM
  • John did you find any solution?
    Thursday, March 19, 2009 10:39 AM
  • Yes and No.  Today, I installed the release of IE8 over my beta version.  The CRM forms now pop-up as expected, but I still get the error dialog.  The good news is that the error dialog is "behind" the popped up form.  So everything "works", but after closing the CRM pop-up form I have to hit Ok to close the error message dialog.
    Friday, March 20, 2009 9:09 PM
  • Has anyone asked Microsoft whether this is an issue and that perhaps the meesga eneeds to be changed to something that makes sense?

    I have this problem when I open an update an Accounts record, then attempt to re-open the same record without first saving the updated one. This issue occurs with any entity.
    Tuesday, March 24, 2009 2:10 AM
  • Depending on the error message - if it includes messages that the error is thrown when it attempts to "prepareEnablePresence" Check to see if all your contacts have last names  (field is required, but sometimes is omitted if some contacts were imported without lastnames) - The error is likely coming from the Presence Indicator's effort to check to see if that person is online (using messenger)- if it doesn't have a last name, it fails for some people. -

    http://dmcrm.blogspot.com/2008/10/hide-annoying-script-error-popups.html

    A Microsoft or an experienced partner can help out by updating the OrganizationBase Table to change the 'ispresenceenabled' setting to off and avoid the issue altogether.

    There is a Microsoft KB article on how to turn off the Presence Controls throughout the system, check the KB article ID 947545 (you will need a PartnerSource log in to view the KB article).
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Tuesday, March 31, 2009 9:18 PM
  • Last I have seen this issue with one of user they had some client application on their system which was stoping all pop-ups from outlook client. You need to check, if they have any client program installed.

    CRM Analyst
    Tuesday, March 31, 2009 9:21 PM
  • Hi,

    We had the same issue (only CRM within Outook Client generated "Window blocked" alert and we solved it in the following way:
    1. Disable all the pop-up blockers in IE, together with Google Toolbar and other third paty tools
    2. For the trusted sites allow for scripting and running activex controls, also unsigned
    3. Kill all IE processes or resart te computer.

    The main poblem was caused by the Google Toolbar that blocked only (sic!) Pricelist modal window in CRM Outlook client.

    Kind regards,
    Kuba
    -- Kuba Skałbania, Netwise
    Tuesday, March 31, 2009 9:39 PM
  • within IE go to Tools - Internet Options - Security and then uncheck the field that says "Enable Protected Mode"
    Friday, September 04, 2009 10:02 AM
  • within IE go to Tools - Internet Options - Security and then uncheck the field that says "Enable Protected Mode"

    But if you do this you have no protection on your IE. That cant be right.

    By the way, we got the same problem and cant seem to find a solution to it.
    Anybody who has solved this? 
    Monday, December 07, 2009 1:51 PM
  • within IE go to Tools - Internet Options - Security and then uncheck the field that says "Enable Protected Mode"

    But if you do this you have no protection on your IE. That cant be right.

    By the way, we got the same problem and cant seem to find a solution to it.
    Anybody who has solved this? 
    I agree with your statement however we have to begin at a starting point to methodically determine a solution. Therefore the statement by CasperS.... is correct -disabling the IE feature remedies the problem, the question is why?  If the site is 'Trusted' and all prompts are disabled it still has no effect with the security feature enabled. Conclusion: With the security feature enabled -problem persists and with the security feature disable the problem is remedied but presents a strong security risk which is unacceptable therefore is not a recommended solution.

    So we continue onward...Any updates would be greatly appreciated.


    Saturday, December 19, 2009 8:36 PM

  • Running CRM Diagnostics is very worthwhile. Here is what I have found.

    You should have the CRM URL in IE pop-up blocker allowed sites and in IE Trusted Sites. If you have Protected-mode enabled for Trusted Sites you will be prompted for your CRM username and password when each window opens (see below for a workaround). If you have Protected-Mode off you will see the pop-up blocked (even though the window will open).

    The workaround for the credentials is to open a CRM window from Outlook (can be anything), enter your credentials and minimize the window (don't close it). As soon as all IE windows are closed you will have to authenticate again when you open the next CRM window. You can also do this by navigating to your CRM URL directly in IE, signing in and then minimize that.

    It's interesting to note that after you sign in to CRM you can close the CRM IE window(s) as long as one IE window stays open. I've not tested this extensively but it seems to work.


    Madrona
    • Proposed as answer by Grant Thompson Monday, December 28, 2009 8:28 PM
    Monday, December 28, 2009 8:28 PM
  • I also am having this problem using the Outlook Client and IE8 and can confirm the above information.

    1: With the site in Trusted Sites, popups disabled and protected mode off; Outlook display a 'popup blocked' message but the application continues to open the correct windows and function as expected.

    2: Turning Protected Mode ON prevents the message being displayed with the unfortunate side effect of failing to maintain the login state (prompting every time) UNLESS an IE window is kept open.

    Neither of these options are desirable and are unfortunately embody the advice that I so often have to deliver to clients :- 'That's just Microsoft being flakey, you can ignore that.'

    I suspect that this bug could be solved from either side (Outlook or IE) can anyone confirm that it is being worked on?

    Regards
     -- Peter, AmigoIT

    Monday, January 11, 2010 10:08 PM
  • The solution can be found in the following knowledgebase article.  Method 2 worked like a champ.

    http://support.microsoft.com/kb/970632

    -- Scott

    Thursday, June 10, 2010 11:26 PM
  • We have an user who was having this problem and nothging worked to fix it.

    Incase if someone is still experiencing this problem, I tried everything suggested in this thread as well as steps from the link below

    http://www.eggheadcafe.com/software/aspnet/32275628/pop-up-blocker-error.aspx

    Finally i tried system restore to the point CRM was working correctly. This did the trick and fixed the issue.

    It looks like something was installed which user did not noticed, otherwise we have already unistalled all recenlty installed programs.

     

    Monday, November 08, 2010 5:13 PM
  • I fixed this by running a command prompt (Start Menu > Run... > cmd) and typing: taskkill /f /im iexplore.exe This killed all instances of Internet Explorer that were running in the background. Once I did this, the pop-up message stopped right away.
    Wednesday, December 08, 2010 10:59 PM
  • I had a prompting for credential case and solved it, did everything imaginable, they were getting the pop up blocker message all of a sudden as well, what i found out was they uninstalled crm through add/remove programs and left traces of the old instances behind, so i gave them steps to fully uninstall crm, delete folders, registry keys and reinstall, no issue of prompting for credentials or pop up.  IE configuring is so annoying for crm.
    Wednesday, June 22, 2011 12:25 AM