none
SQL connection with security for reports - data not returned properly

    Question

  •  

    Hi,

     

    We're having some issues with reports securtiy.

    For example, a manager role is seeing data that he shouldn't.

     

    I'm wondering if didn't set up the connection string corrrectly.

    This is what i have currently.

    THanks for taking the time to have a look.

    Name:
    Description:
    Connection type:
    Connection string:
    Connection type:
    Connection string:
    Connect using:
    Display the following text to prompt user for a user name and password:
    User name:
    Password:

    Tuesday, September 18, 2007 2:15 PM

Answers

  • You should have the 'Windows integrated security' option set to ensure the reports are run under the correct context.

     

    (The 'Credentials stored securely in the report server' option is used when scheduling reports)

    Tuesday, September 18, 2007 3:41 PM
    Moderator

All replies

  • You should have the 'Windows integrated security' option set to ensure the reports are run under the correct context.

     

    (The 'Credentials stored securely in the report server' option is used when scheduling reports)

    Tuesday, September 18, 2007 3:41 PM
    Moderator
  • Thanks David.

     

    I initially thought that was how the connection should be done but one of the other developers changed it.

     

    The problem though now when it is set to integrated security, it gives a SQL connection error.

    I'm away from the office and don't know the exact error message they are getting.

    Maybe the users are not set up with report permissions?

     

    Thanks again.

    Tuesday, September 18, 2007 5:24 PM