none
SRS Data Connector, PrivReportingGroup permissions error on install

    Question

  • I am trying to install SRS Data Connector on a SRS server which is seperate to both the CRM server and the SQL Server (a 3 tier architecture CRM - SRS - SQL). I am getting the following error:

     

    10:28:35|  Error| Check PrivReportingGroupActiveDirectoryRightsValidator : Failure: The current user does not have required permissions (read/write) for the following Active Directory group: PrivReportingGroup

    (this is taken from the command line install log file)

     

    However, the user that is installing srsdc has 'full permission' to the privreportinggroup. I've even tested it in adsiedit, and manually modified the group, and it worked.

     

    Does anyone know why I'm getting this error, or what permissions exactly is the PrivReportingGroupActiveDirectoryRightsValidator looking for?

     

    Thank you

    Paul

    Friday, February 01, 2008 10:36 AM

Answers

  • Sorted now. The Implementation guide is not very clear on the exact format of the config.xml. I found a better example on a ms KB article:

     

    <crmsetup>
      <srsdataconnector>
        <configdbserver></configdbserver>
        <autoupdateconfigdb>1</autoupdateconfigdb>
        <reportserverurl>http://servername/Reportserver$Titan</reportserverurl>
        <autogroupmanagementoff>1</autogroupmanagementoff>
        <instancename>Titan</instancename>
        <configsku>OnPremise</configsku>
        <!-- Set enabled = true for DB webstore integration.  Set configdb="true" for config db webstore integration-->
        <webstore enabled="false" configdb="false" />
        <monitoring>
    <!-- Monitoring service account name and password. It can not be local system or network service account -->
          <serviceaccountname></serviceaccountname>
          <serviceaccountpassword></serviceaccountpassword>
        </monitoring>

        <Groups autogroupmanagementoff="true">
                        <PrivUserGroup>.....</PrivUserGroup>
                        <SQLAccessGroup>....</SQLAccessGroup>
                        <UserGroup>....</UserGroup>
                        <ReportingGroup>....</ReportingGroup>
                        <PrivReportingGroup>....</PrivReportingGroup>
        </Groups>

      </srsdataconnector>
    </crmsetup>

    NOTE - You need to specify <autogroupmanagementoff> as a seperate node, and not as an attribute of the Groups node

    Friday, February 01, 2008 2:58 PM

All replies

  • Further info....

     

    In the xml config file I've got <Groups autogroupmanagementoff="true">, so the install shouldn't even be trying to modify the group???

     

    Friday, February 01, 2008 10:45 AM
  • Sorted now. The Implementation guide is not very clear on the exact format of the config.xml. I found a better example on a ms KB article:

     

    <crmsetup>
      <srsdataconnector>
        <configdbserver></configdbserver>
        <autoupdateconfigdb>1</autoupdateconfigdb>
        <reportserverurl>http://servername/Reportserver$Titan</reportserverurl>
        <autogroupmanagementoff>1</autogroupmanagementoff>
        <instancename>Titan</instancename>
        <configsku>OnPremise</configsku>
        <!-- Set enabled = true for DB webstore integration.  Set configdb="true" for config db webstore integration-->
        <webstore enabled="false" configdb="false" />
        <monitoring>
    <!-- Monitoring service account name and password. It can not be local system or network service account -->
          <serviceaccountname></serviceaccountname>
          <serviceaccountpassword></serviceaccountpassword>
        </monitoring>

        <Groups autogroupmanagementoff="true">
                        <PrivUserGroup>.....</PrivUserGroup>
                        <SQLAccessGroup>....</SQLAccessGroup>
                        <UserGroup>....</UserGroup>
                        <ReportingGroup>....</ReportingGroup>
                        <PrivReportingGroup>....</PrivReportingGroup>
        </Groups>

      </srsdataconnector>
    </crmsetup>

    NOTE - You need to specify <autogroupmanagementoff> as a seperate node, and not as an attribute of the Groups node

    Friday, February 01, 2008 2:58 PM
  • The solution for this problem is to have the full permission on this object instead of only read/write permissions to privReportingGroup AD Group.


    Note: When i tried only read/write permission it didn't work.
    Monday, December 28, 2009 9:35 PM
  • Mostafa, this does not work. Do you have any other ideas?
    Thursday, May 27, 2010 11:45 AM
  • Tried to give the admin full access on the PrivUserGroup, but afterwards the installationwizard is giving the same problem.


    it's all very nice when it works
    Thursday, July 01, 2010 1:29 PM