none
Robocopy - ERROR : You do not have the Manage Auditing user right.

    שאלה

  • I'm trying to copy files between servers in different domains, while retaining ntfs permissions.  The souce and destination are in different domains, but there is a trust in place.  Source is WinXP based NAS device.  Destination is windows 2008 server.  I'm executing the command on the win2k8 box.  I'm an domain admin on both machines.

    I keep getting this error:

    ERROR : You do not have the Manage Auditing user right.

    How do I give myself this "Manage Auditing" user right?

     

     

    U:\>robocopy \\dellnas1\users\fumstead \\lanpa\mad\home\fumstead /e /copyall

    -------------------------------------------------------------------------------
       ROBOCOPY     ::     Robust File Copy for Windows

    -------------------------------------------------------------------------------

      Started : Thu Jan 29 12:54:43 2009

       Source : \\dellnas1\users\fumstead\
         Dest : \\lanpa\mad\home\fumstead\

        Files : *.*

      Options : *.* /S /E /COPYALL /R:1000000 /W:30

    ------------------------------------------------------------------------------

    ERROR : You do not have the Manage Auditing user right.
    *****  You need this to copy auditing information (/COPY:U or /COPYALL).

           Simple Usage :: ROBOCOPY source destination /MIR

                 source :: Source Directory (drive:\path or \\server\share\path).
            destination :: Destination Dir  (drive:\path or \\server\share\path).
                   /MIR :: Mirror a complete directory tree.

        For more usage information run ROBOCOPY /?


    ****  /MIR can DELETE files as well as copy them !

    If I exclude the auditing I get this error:

    2009/01/29 11:33:05 ERROR 1307 (0x0000051B) Copying NTFS Security to Destination
     File \\dellnas1\users\fumstead\WINDOWS\Msflxgrd.ocx
    This security ID may not be assigned as the owner of this object.

    What's it mean?

     

     

     

    יום חמישי 29 ינואר 2009 18:08

תשובות

  • You need to have the command prompt to be run as administrator. right click run as admin
    • סומן כתשובה על-ידי David Shen יום חמישי 26 מרץ 2009 03:35
    יום שלישי 24 מרץ 2009 17:57
  • Hi Rich,


    It seems that the user doesn't have full control on ntfs and share permission on the target share. Would you please verify that the logon domain admin has full control permission on the target share to test? if you still cannot copy the data in this case, i'd suggest you use NTBackup on the Windows to backup and migrate the data to the new box.

    Thanks and regards,
    Scorprio


    MCTS/MCITP: Enterprise Admin
    • סומן כתשובה על-ידי David Shen יום רביעי 04 פברואר 2009 03:16
    יום שני 02 פברואר 2009 11:12

כל התגובות

  • Hi Rich,


    It seems that the user doesn't have full control on ntfs and share permission on the target share. Would you please verify that the logon domain admin has full control permission on the target share to test? if you still cannot copy the data in this case, i'd suggest you use NTBackup on the Windows to backup and migrate the data to the new box.

    Thanks and regards,
    Scorprio


    MCTS/MCITP: Enterprise Admin
    • סומן כתשובה על-ידי David Shen יום רביעי 04 פברואר 2009 03:16
    יום שני 02 פברואר 2009 11:12
  • You need to have the command prompt to be run as administrator. right click run as admin
    • סומן כתשובה על-ידי David Shen יום חמישי 26 מרץ 2009 03:35
    יום שלישי 24 מרץ 2009 17:57
  • Yes, right clicking on command prompt and selecting run as administrator will work.

    However, if you run robocopies like i do through schedule tasks then it is a bit different.  Once you setup the schedule task, right click on the task and under the general tab select run whether user is logged on or not and select run with highest privileges.  Then click ok and run the task.  This of course is how to do it in windows 2008.  I haven't tried it in windows 2003.
    יום שישי 19 יוני 2009 21:59
  • I have the same problem. I logon as domain admin and tried "run as administrator". Still got that error message:-(
    יום שלישי 23 יוני 2009 16:10
  • make sure you are using the command prompt and not PowerShell.
    Member-X, MCSE 2003 and all around great guy :-)
    יום שני 26 אוקטובר 2009 18:54
  • Remove /copyall option and check
    יום שישי 25 ינואר 2013 13:01
  • This also didn't work for me.
    יום חמישי 05 דצמבר 2013 15:04
  • Hello! 

    I was having the same trouble. I am using a Synology NAS with all windows ACL stuff setup. In my case, my boss wanted me to make folder templates with user permissions already setup for each and every new project! Some of these files had many persmissions etc.. pain. 

    So back to your problem. You want to use Robocopy with /Copy:DATSO not /Copy:DATSOU as the U stands for aUditing. We have no use for auditing so it wasnt necessary to copy.

    Also when running the cmd prompt as administrator check if you are still logged into the server with the net use command. Running cmd as administrator gave me login errors!

    Hope this helps! It fixed my problem! 

    • הוצע כתשובה על-ידי PianoBench יום שלישי 19 אוגוסט 2014 06:54
    יום שלישי 19 אוגוסט 2014 06:53