none
missing mfc100.dll

    Kérdés

  • i have installed Microsoft streets and trips and restarted my PC twice, when i try to start it, i get an error that mfc100.dll is missing and to try to reinstall it

    any ideas?

    thanks in advance

    2012. július 10. 21:46

Az összes válasz

  • there must have been something wrong with the streets and trips 2013 dvd

    i downloaded it from the streets and trips site and it installed fine

    2012. július 11. 17:03
  • I got the same error when I downloaded the trial from the Streets & Trips site and from the disk ordered from Microsoft. I downloaded C++ as instructed - no change. Turned off all anti-virus and firewall software - no change. Activated Internet Explorer so it would already be up - no change. Also, the install doesn't display the frame that asks for the product key or registration info.
    • Szerkesztette: Montray 2012. július 12. 1:57
    2012. július 12. 1:50
  • @Montray

    I just opened and installed the CD for Streets & Trips and I get the same error "mfc100.dll missing".

    I've uninstalled and re-intalled twice. No joy. So, we're all having the same problem with no fix so far. Frustrating!!!

    2012. július 12. 5:07
  • OK - I got it to work. I persisted to muttle through in complete ignorance of what I was doing (I hate it when I do that).

    I uninstalled the MS Streets and Trips 2013. I found a copy of mfc100.dll under c:\Program Files (x86)\Garmin\Lifetime Updater (my gps software directory) and copied it to c:\Program Files (x86) AND to c:\Program Files. I then reinstalled MS S/T from the CD. This time during installation I got a message that said a Hotfix (KB2643882) was needed. I clicked OK and apparently the hotfix was installed. Then the installation asked for the product key which I inserted. The installation continued to the 'activation' step and failed to activate online. I received an internal error has occured (error code: 0x80072F78), and was offered the option to try again or activate by phone. I clicked on 'try again to activate over the internet. This time it worked. The MS S/T finally loaded at which point I 'registered' the product online. What a PIA.

    After too many years of this type of exercise I've lost all my tolerance levels for this. I hope this helps someone to reduce their level of frustration with this product.

    (I'm not sure that finding and copying the mfc100.dll and copying to those two directories was the magic. I think the second uninstall and reinstall did it - but what do I know)

    Cheers!

    • Válasznak javasolta: michgaud 2012. július 20. 19:09
    2012. július 12. 5:48
  • Well - I've done all that plus some. The installation still isn't asking for the product key, but I do have a new error message: "The application was unable to start correctly (0xc000007b). Click OK to close the application". Ironically, it cost $35 to get them to answer the phone to tell them you have a problem. Downloading the trial version only gives the error message "some files corrupted - please reload". Bill Gates, please come back and fix this mess (again). My question is: are the people that don't know how to locate the .dll file (much less copy it to the proper directory) just throwing the disk in the trash??

    Copying the mfc100.dll to the directories mentioned in the previous post does resolve that issue.  Thanks Dunromin1. 

    • Szerkesztette: Montray 2012. július 13. 3:30
    2012. július 12. 23:05
  • Which operating system are you all using?

    So far I haven't had trouble with MapPoint 2013 (Win7, Vista, Win8) but I do have Visual Studio (various versions) installed on two of those.

    Wondering if it is OS-specific and/or S&T specific.


    Richard Marsden
    MapPoint Add-ins at Mapping-Tools.com

    2012. július 13. 12:08
  • The PC is about 6 months old and is pretty vanilla. The OS is Windows 7 Home Premium, service pack 1. I have AVG Internet Security loaded for the anti-virus and firewall, but turn it all off for loading programs. I use Google Chrome but currently have it unblocked. I even briefly changed my browser to Internet Explorer to make sure no cookies were blocked. There has to be one line of a program out there that is keeping that product key frame from displaying. I bought my disk directly from Microsoft and on reinstall it did load the hotfix patch. I loaded C++ as instructed by the Microsoft tech help to get the .dll file. All current Microsoft updates have been downloaded and installed. I'm out of guesses.
    2012. július 13. 14:09
  • U-R-E-K-A!!!!  - success!!! 1. Loaded and ran Avanquest System Suites diagnostic software. 2. Ejected the Streets and Trips disk immediately after install.

    I remembered that I successfully installed a program a long time ago and it wouldn't run unless the disk was ejected. That problem doesn't exist in most software today. The diagnostic software didn't locate anything significant. So, it looks like the disk ejection solved the problem. 

    • Válasznak javasolta: Montray 2012. július 14. 16:58
    2012. július 14. 16:58
  • Yeah that's weird - I'm pretty certain I had the MP disk in the drive when running MapPoint for the first time, on at least one of those installs. I'm running with a disk burnt from the MSDN iso, if that makes a difference.


    Richard Marsden
    MapPoint Add-ins at Mapping-Tools.com

    2012. július 16. 14:16
  • Well - I've done all that plus some. The installation still isn't asking for the product key, but I do have a new error message: "The application was unable to start correctly (0xc000007b). Click OK to close the application". Ironically, it cost $35 to get them to answer the phone to tell them you have a problem. Downloading the trial version only gives the error message "some files corrupted - please reload". Bill Gates, please come back and fix this mess (again). My question is: are the people that don't know how to locate the .dll file (much less copy it to the proper directory) just throwing the disk in the trash??

    Copying the mfc100.dll to the directories mentioned in the previous post does resolve that issue.  Thanks Dunromin1. 

    See this:

    http://www.trevisoassistenza.it/guide/17-impossibile-avviare-correttamente-l-applicazione-0xc000007b.html

    It's in italian.

    2013. január 17. 9:18
  • Actually it is not the disk. We have the same problem and it installed fine on our Dell machine, but the HP machine is missing the dll file. Microsoft AND HP are totally useless, as they deny knowing what this file is. We got swindled out of $200+ from HP customer support just to find out they have no clue.
    2013. március 4. 0:32
  • This seems to be the same issue with the MapPoint software -- 

    http://www.mapforums.com/mappoint-2013-bugs-errors-solutions-27627.html#post52302

    Let us know if that solution works for anyone else.

    Eric



    http://www.mapforums.com

    2013. március 5. 2:12
  • THIS WORKED FOR ME WITH MS STREETS & TRIPS 2013!!!!! THANKS A LOT FOR POSTING THIS WORK-AROUND!

    I was getting the dreaded "MFC100.DLL file is missing" warning and nothing worked to make S&T work right. I followed your advice last night, and VOILA! It works!

    2014. április 5. 15:44