none
CRM 2011: Social wave-1 error's

    Kérdés

  • Hi experts,

    I was import the solution sucessfully as administrator. but i am getting the error's 1) "Access denied" at "what new"

    wall .2) getting the error " the object or property was not supported" at on load the activity feed configuration form.

    please help me to move forward.

    Thanks



    VenkataP
    2011. október 28. 13:55

Az összes válasz

  • Please follow the instructions :

    Set up and configure Activity Feeds

     


    Shai Bar-Lev
    2011. október 29. 21:25
  • Thanks Shai. I follow the same link:https://rc.crm.dynamics.com/rc/2011/en-us/online/5.0/help/source_sf_setup_activity_feeds.htm

    still i am getting those error's specified on above thread.

    regards,


    VenkataP
    2011. október 31. 7:19
  • Lets do check list:

    1. Did you Apply Roll up 5 first ?

    2. You follow all the setup steps and you publish all customization after.

    3. Are you logged in as Administrator or a different user ? If different user please add this user to the security role "Activity feeds".

     

     


    Shai Bar-Lev
    2011. október 31. 8:10
  • HI shai,

    I was follow the same steps as u mentioned above .Still i am getting the same error as mentioned above. Here is message i am getting at event viewer:

    Exception information:

    Exception type: CrmException

    Exception message: Could not find a web resource with name Images/refresh.png.

    at Microsoft.Crm.Application.Components.Handlers.WebResource.RetrieveWebResource(String webResourceName, String preview)

    at Microsoft.Crm.Application.Components.Handlers.WebResource.ProcessRequestInternal(HttpContext context)

    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Request information:

    Request URL: http://xxxxx/xxxx/Handlers/WebResource.ashx?name=Images/refresh.png

    Request path: /xxx/Handlers/WebResource.ashx

    User host address: x.x.x.x

    User: XXX

    Is authenticated: True

    Authentication Type: Negotiate

    Thread account name: NT AUTHORITY\NETWORK SERVICE

     

    Thread information:

    Thread ID: 25

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Is impersonating: True

    Stack trace: at Microsoft.Crm.Application.Components.Handlers.WebResource.RetrieveWebResource(String webResourceName, String preview)

    at Microsoft.Crm.Application.Components.Handlers.WebResource.ProcessRequestInternal(HttpContext context)

    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

    Custom event details:


    VenkataP
    2011. október 31. 8:57
  • Do you see this refresh.png image in your imported solution (See screen shot from my Demo machine):
    Shai Bar-Lev
    2011. október 31. 9:14
  • Hi Shai,thanks for quick response. Yes , I am able to see the image in my feed solution .attached screen shot.

    regards


    VenkataP
    2011. október 31. 10:28
  • Is this OnLine or OnPremise environment?

    If OnPremise can you download CrmDiagTool 2011 , install it on the server turn on tracing and dev errors , reproduce the problem and load the log files to some share storage like skydrive.

     

     

     


    Shai Bar-Lev
    2011. október 31. 11:17
  • Hi, I am getting the same error as VenkataP

    Do you have any tips?

     

    Testing activity Feeds on virtual machine - On Premise deployment.

    Single solution deployed -  Only Activity Feeds.

    User administrator login, who is domain admin.

     

    Once I clicked to the link in the refresh.png detail, I was able to reach the file. However, I was requested to enter credentials.

    Once I open the Post configuration detail, there is an jscript onload error, that activityfeed.resources.js cannot be loaded. In web resource detail i am able to connect to this file.

    Thanks

     

    Milan

    2011. október 31. 12:33
  • I installed in on 2 online environment and 2 onpremise environment without any problems.

    Please send tracing and I'll look into it.


    Shai Bar-Lev
    • Szerkesztette: Shai BarLev 2011. október 31. 12:40 Spelling error
    2011. október 31. 12:38
  • I have found it out.

     

    I was logged to the http://localhost/xxxxxx.

    I had to use http://crmtestserver1/xxxxx.

     

    Now it is working ok.

     

    Hope this helps

     

    Milan

    • Válasznak javasolta: Bugs_Oli 2011. november 2. 9:56
    2011. október 31. 12:38
  • Hi Shai,

    Here is trace details.

    [2011-10-31 00:25:16.724] Process: w3wp |Organization:XXXXXXX|Thread:    7 |Category: Exception |User: 00000000-0000-0000-0000-000000000000 |Level: Error | SystemLabelDictionaryCacheLoader.LogDetails
     at SystemLabelDictionaryCacheLoader.LogDetails(Int32 languageCode, Int32 totalLabels, IOrganizationContext context)
     at LabelDictionaryCacheLoader.LoadCacheData(Int32 languageCode, IOrganizationContext context)
     at LabelCache.TryLookupEntry(Int32 languageCode, Guid objectId, String objectColumnName, IOrganizationContext context)
     at LabelCacheLabelCollection.HasLabels(IOrganizationContext context)
     at PreloadedOptionSetMetadataDataProvider.CreateEntityNameReferenceOptions(SortedList`2& optionsSorted, IOrganizationContext organizationContext)
     at PreloadedOptionSetMetadataDataProvider.LoadEntityNameReferenceOptionsIfNecessary(IOrganizationContext context, LoadMasks masks)
     at PreloadedOptionSetMetadataDataProvider.InitializeOptions(IPreloadedMetadataInitializationContext context, LoadMasks masks, IOrganizationContext organizationContext)
     at PreloadedMetadataCacheDataProvider.InitializeOptionSets(IPreloadedMetadataInitializationContext context, LoadMasks masks, IOrganizationContext organizationContext)
     at PreloadedMetadataCacheDataProvider.Initialize(IOrganizationContext organizationContext, MetadataContainer container, LoadMasks masks)
     at MultiOrgSharableMetadataCacheLoader.CreateMetadataCacheDataProvider(MetadataContainer container, IOrganizationContext context, LoadMasks masks, CounterList counter)
     at DynamicMetadataCacheLoader.BuildMetadataCacheFromMetadataContainer(MetadataContainer container, LoadMasks masks, IOrganizationContext context, CounterList counter)
     at DynamicMetadataCacheLoader.LoadCacheFromDatabaseInternal(LoadMasks masks, CrmDbConnection connection, CrmTransaction transaction, IOrganizationContext context, CounterList counter)
     at DynamicMetadataCacheLoader.LoadCacheFromDatabase(LoadMasks masks, IOrganizationContext context, CounterList counter)
     at DynamicMetadataCacheFactory.LoadMetadataCache(LoadMethod method, CacheType type, IOrganizationContext context)
     at MetadataCache.LoadCache(IOrganizationContext context, Boolean fileOnlyIfExists)
     at MetadataCache.GetInstance(IOrganizationContext context)
     at BusinessEntityMoniker..ctor(Guid id, String entityName, IOrganizationContext orgContext)
     at UserDataCacheLoader.LoadCacheData(Guid key, ExecutionContext context)
     at ObjectModelCacheLoader`2.LoadCacheData(TKey key, IOrganizationContext context)
     at CrmMultiOrgCache`2.CreateEntry(TKey key, IOrganizationContext context)
     at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)
     at SecurityLibrary.GetUserInfoCommon(IOrganizationContext context, Guid userGuid)
     at SecurityLibrary.GetCallerAndBusinessGuidsFromThread(WindowsIdentity identity, Guid organizationId)
     at CrmWindowsIdentity..ctor(WindowsIdentity innerIdentity, Boolean publishCrmUser, Guid organizationId)
     at WindowsAuthenticationProviderBase.Authenticate(HttpApplication application, WindowsIdentity userIdentity)
     at AuthenticationStep.Authenticate(HttpApplication application)
     at AuthenticationPipeline.Authenticate(HttpApplication application)
     at AuthenticationEngine.Execute(Object sender, EventArgs e)
     at SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
     at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
     at ApplicationStepManager.ResumeSteps(Exception error)
     at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
     at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
     at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
    >Not an error. System LabelDictionary was loaded for language 1033 from organization {Xxxxxxxx} with 19278 labels
    [2011-10-31 00:26:13.415] Process: w3wp |Organization:XXXXXX|Thread:    7 |Category: Exception |User: xxxxxx|Level: Error | SystemLabelDictionaryCacheLoader.LogDetails
     at SystemLabelDictionaryCacheLoader.LogDetails(Int32 languageCode, Int32 totalLabels, IOrganizationContext context)
     at LabelDictionaryCacheLoader.LoadCacheData(Int32 languageCode, IOrganizationContext context)
     at BasicCrmCache`2.LookupEntry(TKey key, IOrganizationContext context)
     at LabelCacheLabelCollection.GetLabel(Int32 languageCode, IOrganizationContext context)
     at OptionSetValueAttributeConverter.ConvertFromBusinessEntity(IAttributeInfo attributeInfo, Dictionary`2 nameToChildAttributes, ICrmConversionContext context, Entity target)
     at BusinessEntityToEntityConverter.Convert(ICrmConversionContext conversionContext, BusinessEntity businessEntity)
     at BusinessEntityCollectionToEntityCollectionConverter.Convert(ICrmConversionContext conversionContext, BusinessEntityCollection inputCollection)
     at Converter.ConvertTo(ITypeDescriptorContext context, CultureInfo culture, Object value, Type destinationType)
     at ConversionHelpers.Convert(ICrmConversionContext conversionContext, Object source, Type destinationType)
     at DictionaryMapper.Map(PropertyBag inputs, ICrmConversionContext context)
     at PropertyBagMapper.Map(PropertyBag source, ParameterCollection target, ICrmConversionContext context)
     at V5PluginProxyStep.ExecuteInternal(PipelineExecutionContext context)
     at VersionedPluginProxyStepBase.Execute(PipelineExecutionContext context)
     at Pipeline.Execute(PipelineExecutionContext context)
     at MessageProcessor.Execute(PipelineExecutionContext context)
     at InternalMessageDispatcher.Execute(PipelineExecutionContext context)
     at ExternalMessageDispatcher.ExecuteInternal(IInProcessOrganizationServiceFactory serviceFactory, IPlatformMessageDispatcherFactory dispatcherFactory, String messageName, String requestName, Int32 primaryObjectTypeCode, Int32 secondaryObjectTypeCode, ParameterCollection fields, CorrelationToken correlationToken, CallerOriginToken originToken, UserAuth userAuth, Guid callerId, Guid transactionContextId, Int32 invocationSource, Nullable`1 requestId, Version endpointVersion)
     at OrganizationSdkServiceInternal.ExecuteRequest(OrganizationRequest request, CorrelationToken correlationToken, CallerOriginToken callerOriginToken, WebServiceType serviceType)
     at OrganizationSdkServiceInternal.Execute(OrganizationRequest request, CorrelationToken correlationToken, CallerOriginToken callerOriginToken, WebServiceType serviceType)
     at InprocessServiceProxy.ExecuteCore(OrganizationRequest request)
     at PlatformCommand.XrmExecuteInternal()
     at RetrieveMultipleCommand.Execute()
     at <BatchLoadCacheData>d__8.MoveNext()
     at CrmSharedMultiOrgCache`2.LookupEntries(IEnumerable`1 keys, IOrganizationContext context)
     at RibbonRuleCache.LookupEntries(IEnumerable`1 rules, String entityLogicalName, Guid hierarchyLocation, Int32 ruleType, IOrganizationContext context)
     at RibbonDisplayRuleEvaluator.GetRuleDefinitions(HashSet`1 trimRuleIds, String entityLogicalName, Guid hierarchyLocation, IOrganizationContext context)
     at RibbonDisplayRuleEvaluator.GetHiddenIds(HashSet`1 displayRuleIds, Dictionary`2 mapCommandToRule, RibbonTabInformation tabInformation, DisplayRuleInformation displayRuleInformation, HashSet`1 webHiddenControls, HashSet`1 offlineHiddenControls, HashSet`1 onlineHiddenControls, Dictionary`2 dynamicCommandDefinitions, Dictionary`2 dynamicCommandToControlMap, IOrganizationContext context)
     at RibbonDescription.CalculateHiddenControls(DynamicMenuInformation dynamicMenuInformation, HashSet`1 currentTabCommands, RibbonTabInformation tabInformation, String entityLogicalName)
     at RibbonDescription.AddCommandsForTab(String tabIdForFetch, String entityLogicalName, RibbonTabInformation tabInformation)
     at RibbonDescription.AddCommandsForTab(RibbonTabInformation tabStruct)
     at RibbonDescription.AddTabs()
     at RibbonData.GetRibbonDescription(Header currentHeader, Boolean suppressTabs)
     at RibbonData.CreateClientControl(Header currentHeader, Boolean suppressTabs)
     at AppHeader.Render(HtmlTextWriter output)
     at Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
     at Page.Render(HtmlTextWriter writer)
     at Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     at Page.ProcessRequest()
     at Page.ProcessRequest(HttpContext context)
     at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
     at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
     at ApplicationStepManager.ResumeSteps(Exception error)
     at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
     at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
     at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
    >Not an error. System LabelDictionary was loaded for language 0 from organization {xxx-xxx-xx-xxx-xxxx} with 0 labels
    [2011-10-31 00:27:19.019] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:    7 |Category: Exception |User: 00000000-0000-0000-0000-000000000000 |Level: Error | CrmException..ctor
     at CrmException..ctor(String message, Exception innerException, Int32 errorCode, Boolean isFlowControlException)
     at CrmException..ctor(String message, Int32 errorCode)


    VenkataP
    2011. október 31. 15:12
  • I don't see any Errors !!
    Shai Bar-Lev
    2011. október 31. 18:27
  • Hi Milan,

     

    I have exactly the same problem as you and VenkataP, you must use the computer's Netbios name instead of localhost!


    Currently blogging @ www.furnemont.eu
    Currently twittering @bugsoli
    Currently restoring my Mustang @www.mustangpassion.com
    2011. november 2. 10:00
  • I am getting the exact same issue. When i try to access the "What's New" option i get "Error: error : Access is Denied". Then it sits there with the loading circle of DEATH!

    Upon importing the solution it advised it could not install certain labels due to alot of the lanuages not being available.

     

    We have tried installing the langauge pack update, but in trying to do so it says it is not required.

     

    =======

     

    Also when trying to setup the rules for the Activity feeds by going into the following:

    Settings > Activity Feeds Configuration > New

    "There was an error with this fields customized event,

    Field:window

    Event:onload

    Error: Unable to load requested

    file:http://<server name>/<organisational unit name>/web resources/msdyn_/ActivityFeeds.js"

    Ther server name is pointing to the physical name of the machine not the URL, hope that is correct if not i have no idea on how to correct that.

     

    I hope somone might be able to assist.

    Thanks

    Dan

    2011. december 13. 21:52
  • Hi,

    After reading this thread I decided to test this for myself. I am having the exact same errors.

    (Yes, I have Rollup 5 installed)

    The deployment of the solution went ok without any errors but a warning (the warning is about the localised labes as I don't have any languagepack installed)

    I get an access denied when trying to view the What's New as well.

    Moreover when trying to follow the instructions at https://rc.crm.dynamics.com/rc/2011/en-us/online/5.0/help/source_sf_setup_activity_feeds.htm I get the following error when trying to add an entity:

     

    If I proceed to create the record anyway, I can save it without any apparent issues.
    NOTE: When adding Recurring Appointment, the correct entity logical name is recurringappointmentmaster.
    Then I selected all the records and in the customize tab I published all customisations.
    STILL, I get the same error as other people. Access denied in the What's New page with the infinite loop. I also get the infinite loop (without the access denied message) when try to access the wall within an entity form (e.g.: opportunity or account).
    Looks like a bug to me.

    MCC, MCP, MCTS
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    2011. december 15. 16:08
  • Could a Microsoft Employee or affiliate shed some light on this please?
    2011. december 15. 16:16
  • I JUST posted this error in the Microsoft forum for partners =)

    That is closely monitored by the people responsible to escalate issues to the Microsoft product team for Dynamics CRM.

    Here it is: http://social.microsoft.com/Forums/en-US/partnerdynamicscrm/thread/c6bd6656-8b6c-4563-8b71-e2835159f398

    NOTE: You must be a Microsoft partner to access this forum, though.


     


    MCC, MCP, MCTS
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    2011. december 15. 16:19
  • Unfortunatley i dont have access to the Partners Forum's.

    If they get back to you please let me know.

    Thanks

    Dan

    2011. december 15. 16:21
  • Not the case for me. I always use the hostname, and I am having the same issue.
    MCC, MCP, MCTS
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    2011. december 15. 16:21
  • Hi PMDCI, have you had any response on the partners forum?
    2011. december 19. 15:14
  • I don't actually! This is a first... I jut posted a bump.

     

     


    MCC, MCP, MCTS
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    2011. december 19. 17:18
  • We are seeing the same problem.   When browsing through SSL, the solution works properly.  When using port 80, it gives those errors.   Is there any update from Microsoft regarding this?

    Edit: Let me clarify.  The problem actually exists when browsing over https as well.  It only works properly when the address matches exactly what is defined in the metadata.  In other words, if you have x.domain.local defined in the metadata, it fails when browsing x.  If just x defined, browsing x.domain.local fails.   Even though both resolve properly to the CRM itself.  

     


    2011. december 23. 4:22
  • For those of you with a test environment, try going to your deployment manager and changing your bindings to what you actually use to browse.  If you're using Claims-Based Auth you'd obv. have to stick with HTTPS, but if you set it to what your users normally use to access the web client, it will resolve properly.   Just tested on two separate systems and Activity Feeds are now working properly for every user.  Not sure if it is the best solution for everyone, but it does appear to resolve the incongruity between settings.

     

     

    2011. december 23. 4:30
  • Thanks for the reply.

    But in my case there are no issues with the bindings. I surf http://hostname, which is the same as in deployment manager.

    I got a reply at the partner forum and they said they couldn't replicate the issue so far, and asked if I was following the instructions by the letter (which I am).

    Let's see what happens next. :(

     


    MCC, MCP, MCTS
    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    2011. december 23. 10:08
  • I'm having this same issue with an on-premise deployment and have tried all of the suggested solutions with no success. This is a great feature and I'd love to implement it....
    2012. január 4. 18:03
  • I am also having the same exact issue on an on-premise deployment.  Has anyone had success fixing this?
    2012. január 20. 16:38
  • No, we have given up.

     

    It's nice to see that Microsoft are willing to help. Especially top gold partner companies.

    2012. január 20. 16:42
  • The message appears when you use the following web addres: http://localhost:5555/MyOrg or http://<IP>:5555/MyOrg It's a problem related with IE settings.

    One work around is use the following web addres: http://<server_name>:5555/MyOrg But the final solution is adjust the Security level to below Medium, the issue does not occur.

    To adjust security level, go to: Tools > Internet Options > Security tab > Select Local intranet or trusted sites and then adjust the vertical bar to Medium Low.

    I hope that helps


    [MVP]-Microsoft Dynamics CRM | My blog: http://jimmylarrauri.blogspot.com | My twitter: http://twitter.com/jimlarrauri
    2012. január 31. 23:39
    Moderátor
  • Jimmy,

    We have the exact settings you suggest, but the error continues.  We have Roll-Up Update 6 installed (the corrected version) and the event log is flooded.

    Any suggestions?

    Henri

     

     

    Microsoft® CRM - Debug Information
    Server Information:
    DescriptionValue:
    Server OS Version:6.1.7601.65536
    Server URT Version:4.0.30319.239
    Server Name:XYZ
    Application Install Path:C:\Program Files\Microsoft Dynamics CRM\CRMWeb\
    Configuration Database Information
    Data Source:CRM
    Initial Catalog:MSCRM_CONFIG
    Integrated Security:SSPI
    Database Information
    Data Source:CRM
    Initial Catalog:<MyOrg>
    Integrated Security:SSPI
    Web.Config Settings
    Show Developer Level Errors:On
    App Mode Enabled:True
    Help Catalog Name:Microsoft CRM Help
    Component Version Numbers
    Application Components:5.0.9690.1992
    User Interface Components:5.0.9690.1992
    Platform Components:5.0.9690.1992
    Resource (Strings) Components:5.0.9690.1992

     

    Client Information:
    DescriptionValue:
    Browser Version:IE 7.0
    User Agent Info:Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
    CPU Class:x86
    Cookies Enabled:true
    Platform Info:Win32
    Screen Resolution:1536x960
    Screen Bit Depth:16-bit

     

    User Information:
    DescriptionValue:
    NT Domain Name:<domain admin>
    Business Name:<MyOrg>
    Domain Name:<domain admin>

    User Name:<MyOrg User Name>
    Organization ID:{XXX}
    Business Unit ID:{YYY}
    User ID:{ZZZ}

    ----------------------------------

    Microsoft CRM Error Report:
    Error Description:
    Could not find a web resource with name Images/refresh.png.

    Error Details:
    Could not find a web resource with name Images/refresh.png.

    Full Stack:
    [CrmException: Could not find a web resource with name Images/refresh.png.]
       at Microsoft.Crm.Application.Components.Handlers.WebResource.RetrieveWebResource(String webResourceName, String preview)
       at Microsoft.Crm.Application.Components.Handlers.WebResource.ProcessRequestInternal(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

    Other Message:

    Error Number:
    0x80040217

    Source File:
    Not available

    Line Number:
    Not available

    Error Trace:


    Date: 02-01-2012

    Time: 10:36:49

    Server: crm


    Request URL:
    http://XYZ:5555/<MyOrg>/Handlers/WebResource.ashx?name=Images/refresh.png

    ----------------------------------

    Microsoft CRM Unhandled Error Details:

    2012. február 1. 15:50
  • Hi Henri,

    There is a limitation about the URL that you should use. The only supported URL is the one that is registered in deployment manager.

    Try with that and let us know your results.

     


    [MVP]-Microsoft Dynamics CRM | My blog: http://jimmylarrauri.blogspot.com | My twitter: http://twitter.com/jimlarrauri
    2012. február 3. 21:48
    Moderátor
  • isn't the issue that the resource isn't Images/refresh.png.  the resource is msdyn_/Images/refresh.png.  So, somewhere in the code it is assuming that this resource is built in instead of one that has been imported and has a prefix.  if you try to navigate to the url with msdyn_/ in front of Images/refresh.png, it renders the image fine.  Just don't know how to add the properly referenced image since any image you add will put your default prefix on it.  seems like it's a bug that needs to be fixed to make this error go away
    2012. február 8. 19:03
  • Jimmy,

    URL in deployment manager matches the requested URL.

    This must be a bug; why else is refresh.png the only URL that fails?

    Henri

    2012. február 10. 15:41
  • We have still given up with ours, it still gives access denied errors and green loading circle of doom.
    2012. február 16. 9:29
  • I have gotten the same error when I tried to access my CRM on a different URL than the URL my REST endpoints were configured.  You can see where your's are listening by Settings - Customization - Developer Tools.
    2012. február 18. 13:54
  • The other thing to check is that anonymous access is enabled on the CRM site in IIS.  I think I also saw a problem when my server admin disabled it for a security product install.

    2012. február 18. 13:58
  • Chris,

    Would you mind to elaborate?  Not sure what specifically we need to compare.

    Henri 

    2012. március 1. 23:13
  • Jimmy,

    No idea why Donna Edwards marked this as the answer. Do you?

    Henri

    2012. március 1. 23:15
  • Hi,

    I marked this as answered because I was told by Microsoft that if you use the Deployment Manager URL you should not receive the error.  Using any other URL will cause the behavior.  If you go to Deployment Manager and select Organization then select browse, you should be able to see the URL registered in Deployment Manager. 

    If you have tried that and it still does not work, then the person who originally posted this question can unmark the response.  You can also create a new post for this issue as it is possible that the issue was resolved for the original poster but the issue is not resolved for some.


    Regards, Donna

    2012. március 6. 16:03
    Tulajdonos
  • Interestingly enough, I ran into this exact error yesterday in a client environment and it appears that when activity feeds were installed, the checkbox to enable plug-ins during the import process was not selected.  The solution in this case was to completely uninstall activity feeds and reinstall.

    Regards, Donna

    2012. március 9. 14:04
    Tulajdonos
  • Not sure what started it but our deployment now has this same issue.  We are accessing using the FQDN that is shown in the Deployment manager.   This is very frustrating. 

    Donna, If I go to uninstall the solution, I get a message that it cannot be deleted because one or more components depend on it.  It lists under dependency Details list the ActivityFeeds.Plugins.Activity...   type plugin required by ...

    It looks like activity feed plugins are in place or they would not be required by each other when I try to delete the solution.

    Anyone else found a solution?   Again our environment was working fine until sometime this week.  Any chance of a .net framework 4 update causing this?

     


    Fred Zilz

    2012. március 31. 0:08
  • I'm pretty sure you're issue is because the activity feed solution was installed and the SDK checkbox was not selected.  You can try re-importing the solution and check the box to see if that works.  If not, then you will need to uninstall the solution. 

    These uninstall steps worked for me:

    • Go to Settings-> System-> Activity Feeds Configuration ->
    • Deactivate all Activity Feed Configuration Rules & Post Configurations
    • Delete all the Post Configurations entries except User
    • Delete User at the end
    • Publish all customizations
    • Delete the solution

    http://blogs.msdn.com/b/crm/archive/2012/01/26/activity-feeds-solution-amp-development-environment.aspx


    Regards, Donna

    2012. április 2. 22:11
    Tulajdonos
  • I will try to install paying close attention to the sdk box.  I will let you know if this resolves my issue.

    Any idea why this problem would just now show up, when we have been using this solution for months?

    Thank you.


    Fred Zilz

    2012. április 2. 23:13
  • I was able to re-install the solution and made sure the check the SDK box.  The solution complete with the only warnings that a set of sdks were replaced with the new ones from the solution.  

    However the issue persists.  I will try resetting IIS and if that does not work try uninstalling the activefeed solution and then reinstalling.

    I will let you know the outcome.


    Fred Zilz

    2012. április 2. 23:16
  • Were you able to try this and did it work?

    Regards, Donna

    2012. május 24. 15:32
    Tulajdonos
  • I tried, but continued to get this error.  So I removed all of my entities from the activity feeds configurations post configurations (deleted them).  I will re-create when this issue has been resolved.  I just don't have anymore time to work on this and my users have run out of patience with the issue.


    Fred Zilz

    2012. május 24. 16:01
  • We are having the same issue as mentioned when using a different url in the deployment manager.  We have 4 organizations, each with a different url  (Orgname.Org.com or like banana.fruit.com and orange.fruit.com).  Originally we had the server name as the default URL in deployment manager, and when each site would try to view Activity Feeds they would receive a security prompt asking if they would like to continue.  This also popped up when trying to view any record that could be followed.  From the looks of it IE is blocking this type of behavior as Activity Feeds is loading itself from the default URL to the URL that is being used.  Has anyone found a solution for this?   It seems to be designed for a single organization.  So now I've uninstalled for 3 of the 4 orgs, letting the one lucky org keep it for now.  

    Anyone have a similar situation?

    Anonymous access is on.  We are not using this with IFD, though hopefully in the next few months.

    2012. július 16. 19:16
  • I created a Test organization on production to see what I could figure out.  I found that I could easily replicate both issues (refresh.png and the cross site scripting) in a plain vanilla new organization with the latest Activity Feeds installed.

    My server URL is the server name

    I tested with both the http://Servername/test and the friendly URL http://org.orgname.com/test.  In both cases browsing to Activity feeds would throw an event log error

    "Exception information: 

        Exception type: CrmException 
        Exception message: Could not find a web resource with name Images/refresh.png."

    So this confirms it as a bug.  The refresh PNG is loaded but under msdyn_/Images/refresh.png.  When using Fiddler I see it very clearly looking for the image in a spot it doesn't exist.  However another call goes to the right spot and does load the correct PNG.  The bug in this instance is a call to an image that doesn't exist.  If this can be corrected by Microsoft this would no longer be an issue.  

    To resolve this in the short term, I, using very unsupported means, navigated to the database, and copied the entry within dbo.WebResourceBase for the release.png, changed the GUID for the solution, as well as the Name to be Images/refresh.png, and added a new GUID to the WebResourceIDUnique, which also needs to be added to the WebResourceBaseIDs table.  Now I don't receive any errors about this as the image has been added to Images folder.  I don't think this would cause much in the way of problems, but again, totally unsupported.

    The other error I mentioned above is due to my company having 4 organizations running off the same CRM install, so there is a base URL which is our server name, and each org has a unique sub domain Orgname.org.com and Orgname1.org.com.  When navigating to Activity Feeds a popup would appear asking if you trust the source, a typical cross site scripting warning.  So we'll need to allow cross site scripting for trusted domains for this message to disappear.  

    Both of these, in my opinion, are bugs and should be fixed.  I should be able to install and go, and that was my expectation prior to our upgrade last month, we did test, but unfortunately not in a replica environment.    I have a feeling this solution was quickly ported from CRM online without much testing for on prem, or if people did do testing they didn't do it with multiple orgs having unique sub domains.  

    Hope this helps.

    2012. augusztus 8. 19:34
  • This fixed my problem -thanks.

    I was using a development environment, and it seems to be configured with just the machine name.

    So when using the url http://mymachine.mycompany.com/myorganization I had the error with not finding the .js file

    if I browse to http://mymachine/myorganization the error goes away

    2013. március 7. 20:39