none
features not active when sent to another outlook 2007 user

    Domanda

  • I just downloaded the NoReplyAll Outlook - Add In and everything looks fine from my end when sending an email after the No Reply or No Forward or No Reply All options are selected but the receiver (at the desk next to me) also using Outlook 2007 sees no difference in the email - all the functions (reply, forward) work.  Suggestions?
    mercoledì 18 gennaio 2012 19:19

Risposte

  • Are your and the recipient's clients using accounts on the same Exchange server (or server farm - I'm a bit hazy about the details). The add-in sets a few flags in messages headers which, I understand, are passed on only via Exchange and only to clients connected directly. (The final component in this system is the recipient's client - the flag settings are honoured only on desktop Outlook, and don't need the add-in to be installed.)

    As examples: if I use my Microsoft corporate email account and send to another person within Microsoft, then the no reply settings propagate as expected; if I send to a user outside the corporate Exchange network, the flags settings are lost in the transition from Exchange to whatever system the other person uses; and, finally, if I send from a different email account (eg, Hotmail) then, no matter who I send to, the flag settings don't make it any further than my machine.

    Could any of that result in the behaviour you're seeing? Or have I broken something again? :-(

    It would be nice to have some mechanism that doesn't depend on this Outlook-connected-to-same-server system but the starting point for the project required that recipients didn't have to install the add-in and to do that, I have to rely only on what Outlook and Exchange offers. Maybe I can make the add-in so compelling that everyone installs it, and then I could devise some custom headers which propagate through any email server to be processed by the add-in at receive time - but that's something for another day...

    giovedì 19 gennaio 2012 06:59
    Proprietario

Tutte le risposte

  • Are your and the recipient's clients using accounts on the same Exchange server (or server farm - I'm a bit hazy about the details). The add-in sets a few flags in messages headers which, I understand, are passed on only via Exchange and only to clients connected directly. (The final component in this system is the recipient's client - the flag settings are honoured only on desktop Outlook, and don't need the add-in to be installed.)

    As examples: if I use my Microsoft corporate email account and send to another person within Microsoft, then the no reply settings propagate as expected; if I send to a user outside the corporate Exchange network, the flags settings are lost in the transition from Exchange to whatever system the other person uses; and, finally, if I send from a different email account (eg, Hotmail) then, no matter who I send to, the flag settings don't make it any further than my machine.

    Could any of that result in the behaviour you're seeing? Or have I broken something again? :-(

    It would be nice to have some mechanism that doesn't depend on this Outlook-connected-to-same-server system but the starting point for the project required that recipients didn't have to install the add-in and to do that, I have to rely only on what Outlook and Exchange offers. Maybe I can make the add-in so compelling that everyone installs it, and then I could devise some custom headers which propagate through any email server to be processed by the add-in at receive time - but that's something for another day...

    giovedì 19 gennaio 2012 06:59
    Proprietario
  • That's it.  We are not using accounts on the same exchange server.  A vendor stopped by the office and I was testing from my computer to his.  I am in need of something that protects proprietary company emails sent to customers from being forwarded.  It sounds like that may be a little way out.  You are off to a great start, keep up the good work and I will keep checking back with you guys.
    giovedì 19 gennaio 2012 13:31