none
Error when run the performance toolkit CRM 2011

    Domanda

  • Hi hi!

    I´m using the performance toolkit to do a concurrency test in the CRM 2011. The installation process was fine, but when I try to run the RunPopulation.cmd (without domain users) or the RunPopulation2.cmd (with domain users created in the domain) I got the following error:

    Goal_structure errors:

    Undefined Authentication Type
    Discovery server name is missing, defaulting discoveryserver to webserver
    Platform Server name is missing, defaulting platformserver to webserver
    System.InvalidOperationException: Metadata contains a reference that cannot be resolved: 'http://itc-bi/XRMServices/2011/Discovery.svc?wsdl'. ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized.
       at System.Net.HttpWebRequest.GetResponse()
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataLocationRetriever.DownloadMetadata(TimeoutHelper timeoutHelper)
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever.Retrieve(TimeoutHelper timeoutHelper)
       --- End of inner exception stack trace ---
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever.Retrieve(TimeoutHelper timeoutHelper)
       at System.ServiceModel.Description.MetadataExchangeClient.ResolveNext(ResolveCallState resolveCallState)
       at System.ServiceModel.Description.MetadataExchangeClient.GetMetadata(MetadataRetriever retriever)
       at Microsoft.Xrm.Sdk.Client.ServiceMetadataUtility.RetrieveServiceEndpoints(Type contractType, Uri serviceUri)
       at Microsoft.Xrm.Sdk.Client.ServiceConfiguration`1..ctor(Uri serviceUri)
       at Microsoft.Xrm.Sdk.Client.ServiceConfigurationFactory.CreateConfiguration[TService](Uri serviceUri)
       at dbPopulator.XrmDiscoveryServiceCreator.CreateDiscoveryService()
    OrganizationServiceUrl is Empty: Exiting

     

    Organization_structure error:

    Platform Server name is missing, defaulting platformserver to webserver
    System.InvalidOperationException: Metadata contains a reference that cannot be resolved: 'http://itc-bi/XRMServices/2011/Discovery.svc?wsdl'. ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized.
       at System.Net.HttpWebRequest.GetResponse()
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataLocationRetriever.DownloadMetadata(TimeoutHelper timeoutHelper)
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever.Retrieve(TimeoutHelper timeoutHelper)
       --- End of inner exception stack trace ---
       at System.ServiceModel.Description.MetadataExchangeClient.MetadataRetriever.Retrieve(TimeoutHelper timeoutHelper)
       at System.ServiceModel.Description.MetadataExchangeClient.ResolveNext(ResolveCallState resolveCallState)
       at System.ServiceModel.Description.MetadataExchangeClient.GetMetadata(MetadataRetriever retriever)
       at Microsoft.Xrm.Sdk.Client.ServiceMetadataUtility.RetrieveServiceEndpoints(Type contractType, Uri serviceUri)
       at Microsoft.Xrm.Sdk.Client.ServiceConfiguration`1..ctor(Uri serviceUri)
       at Microsoft.Xrm.Sdk.Client.ServiceConfigurationFactory.CreateConfiguration[TService](Uri serviceUri)
       at dbPopulator.XrmDiscoveryServiceCreator.CreateDiscoveryService()
    OrganizationServiceUrl is Empty: Exiting

     

    thanks for your help.

    Best regards,

    Hernando.

    giovedì 12 gennaio 2012 20:35

Tutte le risposte

  • Hi Hernando,

    Support for the Performance Toolkit is through the CRM Labs forum:

    http://social.microsoft.com/Forums/en-US/crmlabs/threads

     


    Best regards,

    Kim Johnson
    Partner Online Technical Community
    -----------------------------------------------------------------------------------------
    We hope you get value from our new forums platform! Tell us what you think:
    http://social.microsoft.com/Forums/en-US/partnerfdbk/threads
    ------------------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    venerdì 13 gennaio 2012 13:06
  • Hi Hernando,

    I appologize for the delayed reply.  Is the client where you are running the toolkit in the same domain as the CRM server?

     

    Thanks,

    Russ Dobbins

    lunedì 6 febbraio 2012 21:35
  • Hi Russ,

    The server where we are running the toolkit is a Virtual.

    This server contain the full instalation of the CRM 2011+SQL Server 2008 and this one is a DC, because this is a test server.

    Best Regards,

    Hernando.

    martedì 7 febbraio 2012 15:03
  • Hi Hernando,

    So are you saying everything including the toolkit is running on one Virtual server?

    Russ

    mercoledì 29 febbraio 2012 20:34
  • Hi Russ,

    I'm getting the same error and have the same setup as Hernando. Everything is installed on 1 Virtual Server. Any thoughts on this issue?

    Bas

    mercoledì 14 marzo 2012 09:54
  • Hi Bas,

    Sorry for the delay in answering.  The toolkit shoud not be ran from the same machine that CRM is on.  This does not allow for accurate performance testing.  What type of Authentication are you using and is this a CRM Onpremise deployment?

    Thanks,

    Russ

    martedì 28 agosto 2012 23:49