none
How to handle error message “The Password is incorrect” attempting console access

    Discussione generale

  • How to handle error message “The Password is incorrect” attempting console access
    Windows Home Server allows the Administrator to manage the system with the Windows Home Server console. The console will usually be started by right clicking the Connector icon on a client PC and entering the Console password, which is identical with the password of the account Administrator on the server. Another method would be the connection to the server via the Remote Access webpage.
    There are some situations, in which the console cannot longer be accessed, because the password is rejected as wrong, even if there is clearly no typo, no CAPS lock enabled by mistake, no unintentional change in keyboard layout and no broken keyboard.

    Reason:
    Some NVidia video drivers (in some cases also ATI) can break Remote Desktop access. This may happen after a driver upgrade or after upgrading other components sharing the same resources, i.e. .NET Framework.
    Since the Windows Home Server console is nothing else than a specific Remote Desktop connection, it will also fail to this behavior.

    Diagnostics:
    You can test this by attempting to connect using the Remote Desktop Client (in some cases a Remote Desktop connection without loading the console may still be possible). The Remote Desktop Client can be found in the Start menu under All Programs/Accessories (or the Communications subfolder here). The exact path depends from the client operating system and its patch level.
    After starting the Remote Desktop client, enter the name of your server in the Computer field.
    Enter Administrator as user name (other credentials are not supported) and as password provide the console password.
    After confirming the credentials, you should see the desktop of the Windows Home Server within the Remote Desktop session and receive a warning page informing you about the potential risks.
    In the Start Menu on Remote Desktop click the shortcut to start the Windows Home Server Console and check, if it works properly from here.
    If you cannot connect via Remote Desktop, you will need to perform a local login on your server, using attached keyboard and monitor. Since the situation caused by NVidia video drivers will only arise on a self built system with a video card, this specific problem should not happen on server appliances provided by the larger OEMs.

    On the affected system open the Event Viewer via Start/Control Panel/Administrative Tools/Event Viewer and check for entries like this:
    Event Type:          Information
    Event Source:       Application Popup
    Event Category:    None
    Description:Application popup: \SystemRoot\System32\RDPDD.dll failed to load

    This can easy be overlooked, since it is not declared as error or warning, but as plain information.

    Solutions:
    If you find this entry, following fixes may work:
    Method 1:
    Uninstall the NVidia video driver.
    Eventually check for a more up to date video driver and try, if this fixes the behavior.
    Method 2:
    Disable hardware acceleration on the server. To do this, right click the desktop, and select Properties to show the Display Properties.
    On the Settings tab click Advanced/Troubleshoot and turn off Hardware acceleration.
    Method 3:
    Create a text file with the extension .reg (i.e. remote.reg) with following content:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
    "SessionImageSize"=dword:00000020

    Save it in one of your shared folders on the home server.
    From within a desktop session on your server, double click it. Confirm that you want to merge the content of the file with the registry and after succeeding, reboot the server.
    Hint: If Notepad opens after doubleclicking the file, there may still be a hidden extension .txt behind the .reg extension. In this case in Windows Explorer under Tools/Folder Options on the View tab uncheck Hide extensions for known file types. Rename the file appropriate.

    Best greetings from Germany
    Olaf Engelke

    martedì 14 luglio 2009 09:35