none
Activities under My Work does not display anymone (retrieval error)

    Domanda

  • Hi,

    I did some conditional formatting (just some font changes) to the first pinned filter tab under My Work\Activities one night and saved t and everything was good.
    The morning after, when I tried to access my Activties, the CRM for Outlook says "Retrieval of a page from a CRM server failed due to an error". 
    See screen shot:

    This is the only page that is not functioning in my CRM.
    In the online CRM, the Activies displays correctly.

    So, I tried a couple of things.

    1. Just in case my default view in Activities got messed up, I set a new default view:

    Did not make an difference.

    2. I checked if any of the CRM add-ons in IE were disabled (although unlikely because other pages displays correctly) and all the add-ons were enabled.

    3. Formated the computer, installed everything again. Did not make a difference.


    So, I'm starting to wonder if there is a setting on my CRM-user that is wrong. I would also like to reset the conditional formatting but that seems impossible since I cannot access the ribbons when the page does not display.

    Does anyone have any suggestions here? Im getting quite desperate since Activities is the page I use the most :(


    domenica 18 marzo 2012 18:58

Tutte le risposte

  • You dont need the ribbon  to do conditional formatting .. Instead you can right click on the activities grid header, click on View Settings -> Conditional formatting.

    lunedì 19 marzo 2012 05:41
  • I'm not sure where you want me to right click. Could you illustrate this in a screenshot or explain it a little better?
    lunedì 19 marzo 2012 07:33
  • You can right click anywhere on the grid header ("Activity Type", "Subject") and you will see "View Settings" .. Screenshot below

    martedì 20 marzo 2012 04:58
  • Well, that's a problem. As you could see in my first post, I cannot retrieve the Activities-page at all.
    martedì 20 marzo 2012 08:28
  • Sorry Glen_83, I misunderstood. Unfortunately there is no way to reset conditional formatting via the UI when the page is not loading. However you can use SDK to retrieve the "userquery" and remove the value of "ConditionalFormatting" attribute.

    By the way, can you also check the CRM Traces and see if the logs say anything with regards to activities page not loading? Traces can be found at %localappdata%\Microsoft\MSCRM\Traces. You can turn on traces through CRM Diagnostics.

    martedì 20 marzo 2012 19:01
  • Also if this happens to be a UserView you can also attempt to delete it from Advanced Find

    martedì 20 marzo 2012 19:44
  • Thanks Rajani,

    I turned on traces and got some feedback in the txt-file.
    It seems to be an shell error:  Unrecognized Guid format.

    That doesn't tell me alot but maybe you guys know a thing or two about Guid :)



    • Modificato Glenn_83 mercoledì 21 marzo 2012 08:09
    mercoledì 21 marzo 2012 07:57
  • 'Unrecognized Guid format' could be anything. Since its happening in the shell and based on your description, seems to me like the view may be corrupted. Is this a view that you created? If yes, can you try deleting this view per Sumeru's suggestions.

    Traces folder will have files "***addin.txt" and "****OutlookClient.txt". Can you copy/paste the error traces from both the files for the timestamp when you navigated to Activities folder? Thanks.

    giovedì 22 marzo 2012 03:01
  • Hi Glenn_83,

    Not sure if you were able to resolve this issue. However I came across another thread where the user had the same problem and he resolved it by updating the entries in the Server DB. Here is the link to that thread http://social.microsoft.com/Forums/en-US/crm/thread/4649c2c7-31d9-4ef7-909e-4c312cbd8f73

    Thought I'll share it with you.

    giovedì 29 marzo 2012 17:24