none
Noreplyall attachment detector not working

    質問

  • Win 7 Professional 64 bit, Outlook 2010, exchange server.

     

    Attachment detector not working on test emails. In the top box: attached

     

    In test email, I write see attached without attaching anything and it sends like it did before.

     

    Any ideas?

    2012年1月26日 15:15

回答

  • I've just tried it here and it seems to be working... In my settings (version 2.4.1 of the add-in - the latest as of last week) I have "hide warning on receipt of reply-blocked message" checked, the next three "disable ..." boxes unchecked, just the word "attached" in the Attachments box (no spaces before/after - not that those should matter), nothing in the NonAttachments box. and the final checkbox, talking about regular expressions unchecked. Most of these are irrelevant to this problem, but I wanted to be complete here, just in case.

    I created a plain text message (addressed to myself, subject line "test") containing just the text "see attached" (all lowercase) - clicking send resulted in the expected missing attachments dialog box. I repeated this for both HTML and rich text emails - same result.

    I'm running Win7 64 bit, and 32 bit Outlook, both fully WindowsUpdated and SP'd as appropriate - identical, or close enough to what you have.

    So... I don't yet understand what's different between our systems to be able to help yet, sorry. Could you repeat the steps I've outlined - in case I've not specified something precisely enough in my repro steps, tell me how you did whatever the missing step was and I'll try again here too.

    2012年1月26日 15:58
  • I've posted an updated add-in just now which fixes this problem. I hope my testing has missed no other combinations of email format, embedded images and proper attachments.
    2012年5月3日 13:23

すべての返信

  • I've just tried it here and it seems to be working... In my settings (version 2.4.1 of the add-in - the latest as of last week) I have "hide warning on receipt of reply-blocked message" checked, the next three "disable ..." boxes unchecked, just the word "attached" in the Attachments box (no spaces before/after - not that those should matter), nothing in the NonAttachments box. and the final checkbox, talking about regular expressions unchecked. Most of these are irrelevant to this problem, but I wanted to be complete here, just in case.

    I created a plain text message (addressed to myself, subject line "test") containing just the text "see attached" (all lowercase) - clicking send resulted in the expected missing attachments dialog box. I repeated this for both HTML and rich text emails - same result.

    I'm running Win7 64 bit, and 32 bit Outlook, both fully WindowsUpdated and SP'd as appropriate - identical, or close enough to what you have.

    So... I don't yet understand what's different between our systems to be able to help yet, sorry. Could you repeat the steps I've outlined - in case I've not specified something precisely enough in my repro steps, tell me how you did whatever the missing step was and I'll try again here too.

    2012年1月26日 15:58
  • Got it to work. I checked all the boxes you had and it worked.  Thanks.
    2012年1月27日 13:10
  • I changed my settings to duplicate yours above and when I send a plain text message I get the pop-up warning.  When I send an html email, it goes to the outbox with no warning message.   Any suggestions?  I'm running Win7 32-bit with 32-bit Outlook 2010.

    UPDATE - The html version of my email includes a jpeg logo in the signature.  Noreplyall must see this as an attachment and so sends the email without a warning.  Is there any workaround for this?

    Thanks.

    • 編集済み rickL00 2012年3月2日 1:26
    2012年3月1日 22:58
  • However, if you take a look at the email rules definition tool, one of the options you can specify is to take some action if the email is "flagged for action" (where action is one of the flags I use, such as forwarding). I wonder if it's possible to use that to specify a rule which will fire on forward disabled messages which will prevent them from being forwarded automatically, perhaps by putting them in some subfolder of the inbox (if that would actually prevent forwarding). Of course, if autoforward is processed before the rules are run, that's no help at all
    jiaoart
    2012年3月2日 7:01
  • Hmmm, that's one of the cases I specifically look for - I'm obviously not looking hard enough (or I broke something in a recent release). Will investigate...
    2012年4月20日 9:36
  • That could be something to investigate. Some rules can be set to execute on the server, while the NoReplyAll add-in most certainly operates on the end user's machine so I'd guess that those rules would operate before I get to see the email. Autoforward must be running on the server too, but I don't know how the timing of that relates to server-based rules. Perhaps there is some combination of rules and client-side actions that could get us where we want to be...
    2012年4月20日 9:41
  • It appears that pretty much any embedded image, not just those in signatures, are incorrectly classed as attachments. The code does include a test for embedded image vs other attachments, and it used to work but now seems to be broken. I'll have to come up with a different way to detect images.
    2012年4月20日 11:44
  • I've posted an updated add-in just now which fixes this problem. I hope my testing has missed no other combinations of email format, embedded images and proper attachments.
    2012年5月3日 13:23