none
VS 2005 Debugger crashing with IE 8 Beta 2

    Vraag

  • Dear Friends,

    Today I installed IE 8 Beta 2 and started debugging my ASP.NET 2.0 site on VS 2005. When I start debugger it automatically stops after IE window appears on screen. My question is that do I need to do something with IE8 Beta2 settings to enable debugging in my ASP.NET applications or some thing is going wrong with IE8 Beta2 ?

    When I try to debug my applications with IE7 then VS 2005 debugger is working fine. My operating system is windows 2003 server

    To replicate this issue, I am adding steps:

    1. Open ASP.NET 2.0 site on visual studio 2005
    2. Close all IE windows
    3. Start debugging, it should work fine
    4. Now stop debugging and open IE
    5. Now again start debugging or press F5 in VS 2005
    6. Notice that VS 2005 debugger will not start

    Any suggestions or ideas will be most welcome.

    Thanks and Regards,


    Haider Raza Software Engineer, ZABSolutions. MCP(C#)
    • Bewerkt door Haider Raza Naqvi woensdag 22 oktober 2008 8:46 Replication steps added
    woensdag 22 oktober 2008 8:01

Antwoorden

  • Hi,

    IE 8 has a feature called Loosely-Coupled Internet Explorer (LCIE) which results in IE running across multiple processes.
    http://www.microsoft.com/windows/internet-explorer/beta/readiness/developers-existing.aspx#lcie

    Older versions of the Visual Studio Debugger get confused by this and cannot figure out how to attach to the correct process.  You can work around this by disabling the process growth feature of LCIE.  Here's how:

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    Since you are running on Windows Server 2003, this is all you should need to do.  If you run into the same problem on Vista or newer, you will also need to turn off protected mode.

    Thanks.
    Brad Sullivan - Program Manager - Visual Studio Debugger
    vrijdag 24 oktober 2008 0:35

Alle reacties

  • Hi,

    IE 8 has a feature called Loosely-Coupled Internet Explorer (LCIE) which results in IE running across multiple processes.
    http://www.microsoft.com/windows/internet-explorer/beta/readiness/developers-existing.aspx#lcie

    Older versions of the Visual Studio Debugger get confused by this and cannot figure out how to attach to the correct process.  You can work around this by disabling the process growth feature of LCIE.  Here's how:

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    Since you are running on Windows Server 2003, this is all you should need to do.  If you run into the same problem on Vista or newer, you will also need to turn off protected mode.

    Thanks.
    Brad Sullivan - Program Manager - Visual Studio Debugger
    vrijdag 24 oktober 2008 0:35
  • Thank you Brad.
    Haider Raza Software Engineer, ZABSolutions. MCP(C#)
    vrijdag 24 oktober 2008 4:21
  • Hi Brad,

    Thanks for this information, I ran into exactly the same problem after installing IE 8 this week. If I manually attached the process during debugging everything worked fine, but it wouldn't do it on its own, which was a real pain.

    This fix worked for me, and I am running Windows XP Pro.

    Mike
    maandag 6 april 2009 14:44
  • In Windows 7, there is already a REG_SZ type "TabProcGrowth" value there. By default its value is Medium.
    What's proper value for it ?
    Morgan
    woensdag 8 april 2009 4:46
  • Brad
    Thanks for the solution
    Still i am unable to solve the problem
    I added the key at your described location
    Then i attach the process aspnet_wp.exe by going to tools
    But unable to get the debuging
    vrijdag 10 april 2009 7:59
  • Hi Brad,

    I recently posted this: http://forums.asp.net/p/1412558/3101843.aspx#3101843

    Does what you posted apply to my situation too?  Also, if I upgrade to VS2008 will this problem disappear?

    Robert
    zondag 19 april 2009 17:08
  • Thanks Brad
    It Worked.
    dinsdag 7 juli 2009 16:12
  • Hi Brad
    I just today installed IE8, and am now unable to debug my simple web silverlight project.
    I tried the regedit hack above, which changed the behavior (now the running VS2008 debugger *also* appears in the window) but didnt fix it.
    I also unchecked and re-checked the web / properties / web / debug Silverlight checkbox with no change.
    any other ideas?
    thanx
    r
    woensdag 15 juli 2009 16:43
  • Thank You,Brad!!!
    donderdag 16 juli 2009 15:19
  • hi!

    thanks brad! i was just pulling my hair what's causing the problem for not going my application in Debug Mode (Visual Studio 2005) or not stopping at defined breakpoints. your trick has just worked perfect for my problem. never imagined to resolve so easliy. am using vs2005 on windows xp pro.

    the reason am writing here today just to make a better analysis of the problem. before reading your post, i tried on firefox instead of IE. but the compiler didn't stop at the breakpoints. i dont know what's causing the problem with firefox. however, after after the key in the registry, it stop at breakpoints also with firefox.

    may be my problem also related to the Visual Web Developer Express Edition which i downloaded from microsoft website a week ago. since then whenever i run my application, a new process "WebDev.WebServer.exe" starts up automatically which was never seen before. and constantly an error popups very often saying "An Error Verified in WebDev.WebServer.exe. The Application will be closed".

    it would be greatful, perhaps very kind if you can shed some light on this sequence of events for my better programming skills in the future.

    thanks once again.

    rams
    dinsdag 21 juli 2009 12:20
  • Thanks, Brad!!

    I was on the verge of "uninstall, reinstall, see if that clears it up" and found your post.

    Whew!

    Worked like a charm!

    Windows XP Pro
    Visual Studio 2005
    ASP.NET/C#
    http://www.myschoolvalet.com

    Remove filler from email address
    zondag 9 augustus 2009 20:55
  • Hi Brad,

    Thanks for the help,

    I tried it in Windows XP and it is working great ....... .

    Thanks for the solution.
    donderdag 10 september 2009 20:18
  • This fix worked for Visual Studio 2003 as well.
    vrijdag 9 oktober 2009 17:18
  • Yep..that was great...It Works..
    Thanks a TON !!!
    woensdag 13 januari 2010 10:55
  • Hi Brad,

    That was a easy fix and worked fine.

    Good work.

    donderdag 13 mei 2010 6:03
  • Hi All,

    I also have the same problem. I.e displaying following message in IE8 when running(F5) the VS website (vs2005):

    "Internet Explorer cannot display the webpage"

    Solution: I uninstalled the NOD Antivirus from my machine. then problem is resolved.

    Thanks and regards,

    prasanth.

    woensdag 26 januari 2011 10:28
  • Still its not working for me..Please help me out

    maandag 4 april 2011 10:49
  • I'm running VS2005 on Windows 7 and was having the same problem, and the fix given by Brad above wasn't working.  There was already a TabProcGrowth REG_SZ entry in the HKEY_LOCAL_MACHINE set to "medium" as Morgan has already pointed out. I then found this article: http://support.microsoft.com/kb/2000608 and as instructed added the DWORD entry to HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main and it fixed the problem. 

    For anybody still having problems after following the initial advice, try this and see if it works for you.

    vrijdag 16 september 2011 12:03
  • thanks for the solution..it worked for me as well.

    i was using win7,visual studio 2005 and i was not able to debugg the application.

    adding DWORD entry to HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main fixed my problem.

    donderdag 3 mei 2012 6:01