none
Windows Server 2008 DNS Issue

    คำถาม

  •  

    Currently I have a Windows Server 2008 Enterprise box running with 2 NICs.  I have routing and remote access turned on and am using NAT to connect my local network to the internet.  I have active directory, DNS, and DHCP running.  I have an issue however when i try to access any website through a web browser.  It takes about 20 seconds for the page to load and it is just a basic page, nothing special.  Now when i ping a site, say yahoo.com, I get the following:

     

    Pinging yahoo.com [216.109.112.135] with 32 bytes of data

    Reply from 192.168.0.1: Desitnation host unreachable

    Reply from 216.109.112.135: bytes=32 time=134ms TTL=54

    Reply from 216.109.112.135: bytes=32 time=154ms TTL=54

    Reply from 216.109.112.135: bytes=32 time=134ms TTL=54

     

    Ping statistics for 216.109.112.135:

    Packets: Sent = 4, Recieved = 4, Lost = 0 (0% loss),

    Approximate round trip time in milli-seconds:

    Minimum = 134ms, Maximum = 154 ms, Average = 140ms

     

    I had the same type of configuration on Windows Server 2003 Enterprise and I did not have this issue.  I got the new server and decided to try out Windows Server 2008 on it so it is a clean install not an upgrade.  Can anyone help?

    8 เมษายน 2551 5:54

คำตอบ

  • Hello,

     

    Thanks for your screenshot.

     

    I have noticed that the default gateway of your second NIC is still 0.0.0.0, this might cause the delay issue.

     

    After some research, I find that some third-party AV software might cause similar issues.

    For more information, please refer to the following thread: Default gateway On-link problem!?

     

    So please follow the below steps to fix this issue:

     

    1.Verify whether you have installed any third-party Anti-Virus software. If yes, please uninstall it temporarily and have another test. Please check whether 0.0.0.0 default gateway still exists.

     

    2. Please refer to my previous post to perform a clean boot and check whether the situation will improve.

     

    3. As it seems you didn’t disable IPv6 on one of your NIC. Please right click your network connections and click properties. Please ensure that “Internet Protocol version 6 (TCP/IP v6)” has been unchecked on both of your two NICs.

     

    Please let me know the result after you finish the tests. Thanks.

     

    Neo Zhu

    18 เมษายน 2551 10:42

ตอบทั้งหมด

  • Can you post an IPconfig /all from both NICs?

     

    Thanks,

    8 เมษายน 2551 19:24
  • below is the ipconfig /all

     

    i have changed the DNS servers on the intranet connection before...

     

     

    9 เมษายน 2551 4:15
  • Here is a picture of the ipconfig /all settings.

     

    I have tried altering the DNS servers for the intranet connection and still have the same issue.

     

     

    ipconfig /all
    9 เมษายน 2551 4:23
  • Hello,

     

    Thank you for the screenshot.

     

    I notice that you have set 0.0.0.0 as default gateway and 192.168.0.1 as DNS Server on your second NIC. This settings might cause your current problem.

     

    So please leave both the default gateway and DNS Server IP addresses blank and have another try.

     

    If the problem still occurs, please also try the following steps to fix the issue:

     

    1.    As firewall might also cause network performance issues sometimes, please temporarily disable Windows firewall and check whether this will make any difference.

     

    2.    Please try to disable IPv6 in Windows Server 2008 by doing the following:

     

    • In the Network Connections folder, obtain properties on all of your connections and adapters and clear the check box next to the Internet Protocol version 6 (TCP/IPv6) component in the list under This connection uses the following items.

     

    Thanks.

     

    Regards,

    Neo Zhu

     

    9 เมษายน 2551 11:29
  •  

    I tried those changes and am still getting the same results.  To be honest I am baffled as to why this is happening I never had any trouble with Server 2003.  Any more ideas?
    10 เมษายน 2551 5:50
  • Hello,

     

    Please check first whether you have installed correct and the latest driver of the network adapter on the Window Server 2008.

     

    After you changed the second NIC's gateway and DNS Server settings, did Ping work normally?

     

    If not, please disable the second NIC and check whether this will make any difference.

     

    If Ping works well but the delay issue still exists, please try to perform a clean boot and check whether the issue is caused by any third party services.

     

    To perform a clean boot, please do as follows:

    1. Click Start->Run ->type msconfig and press Enter

    2. Click Services tab and select Hide All Microsoft Services and Disable All third party Services.

    3. Click Startup tab and Disable All startup items

    4. Click OK and choose Restart

    5. After reboot, check whether the problem still occurs

     

    If a clean boot makes no difference, please boot the system into Safe mode with networking and have another test.

     

    Please let me know after you finish all the tests. Thanks

     

    Regards,

    Neo Zhu

     

    10 เมษายน 2551 12:08
  • Ok so I went ahead and disabled my LAN facing network card and the intranet and there is no delay on the ping.  I am not sure how to correct the problem however.  I am continuing to try to troubleshoot the problem with little luck besides now.  Thanks

    13 เมษายน 2551 6:53
  • Hello,

     

    When you disabled the second NIC, the issue no longer occurred. So it’s most likely that the issue is caused by the settings on the second NIC.

     

    Please enable the second NIC and change the settings on this NIC like this:

    Enter 192.168.0.1 as its IP address and 255.255.255.0 as the subnet mask. Please do not enter any IP addresses in default gateway, preferred DNS server  and alternate DNS server IP options.

     

    After that, please save the changes and check whether the delay still exists.

     

    If yes, please type the following two commands in Command Prompt and please post back the result.

     

    Ipconfig /all

     

    route print

     

    I look forward to hearing from you. Smile

     

    Regards,

    Neo Zhu

     

    14 เมษายน 2551 5:27
  • Ok so I tried to re-enable the second ethernet adapter and the delay still exists.  I am posting the requested screenshots.  Thanks a lot!

     

    ipconfig /all

    route print

     

    Bryce
    18 เมษายน 2551 3:03
  • Hello,

     

    Thanks for your screenshot.

     

    I have noticed that the default gateway of your second NIC is still 0.0.0.0, this might cause the delay issue.

     

    After some research, I find that some third-party AV software might cause similar issues.

    For more information, please refer to the following thread: Default gateway On-link problem!?

     

    So please follow the below steps to fix this issue:

     

    1.Verify whether you have installed any third-party Anti-Virus software. If yes, please uninstall it temporarily and have another test. Please check whether 0.0.0.0 default gateway still exists.

     

    2. Please refer to my previous post to perform a clean boot and check whether the situation will improve.

     

    3. As it seems you didn’t disable IPv6 on one of your NIC. Please right click your network connections and click properties. Please ensure that “Internet Protocol version 6 (TCP/IP v6)” has been unchecked on both of your two NICs.

     

    Please let me know the result after you finish the tests. Thanks.

     

    Neo Zhu

    18 เมษายน 2551 10:42