none
Issues while packaging with iexpress

    Soru

  • Hi All

    This may be a known issue, but since I am new to using iexpress tool, am facing issues. I have an exe file OCSAgentSetup.exe and i am trying to package this exe into a package along with other files required for a successful install of OCS. I will need this exe to be executed with a set of switches.. as shown below..

    OCSAgentSetup.exe /S /server:myserver.mydomain.com

    so I have mentioned this line in a text editor and saved it as a batch file.

    Now using iexpress, I am trying to package all the contents so that the batch file I saved in the above step will be executed upon a double click on the package. I want to distribute this package to my users for them to install the OCS, which runs on their laptops / desktops as a service and starts polling information to my server.

    However, the batch file it self seems to be able to install the OCS, but when packaged with iexpress, its not being done. I worked around renaming the .bat to a .cmd file referring to other posts. Also tried to include ./ infront of the execute statement in the batch file. But with out any luck. Hence I am approaching this forum for a recommendation. Below is the SED file I thought it might be of use. Please advice.

    Regards!

    Sarat

    [Version]
    Class=IEXPRESS
    SEDVersion=3
    [Options]
    PackagePurpose=InstallApp
    ShowInstallProgramWindow=0
    HideExtractAnimation=0
    UseLongFileName=0
    InsideCompressed=0
    CAB_FixedSize=0
    CAB_ResvCodeSigning=0
    RebootMode=I
    InstallPrompt=%InstallPrompt%
    DisplayLicense=%DisplayLicense%
    FinishMessage=%FinishMessage%
    TargetName=%TargetName%
    FriendlyName=%FriendlyName%
    AppLaunched=%AppLaunched%
    PostInstallCmd=%PostInstallCmd%
    AdminQuietInstCmd=%AdminQuietInstCmd%
    UserQuietInstCmd=%UserQuietInstCmd%
    SourceFiles=SourceFiles
    [Strings]
    InstallPrompt=
    DisplayLicense=
    FinishMessage=
    TargetName=D:\Sarat\OCS-TESTS\OCS-Install-IV.EXE
    FriendlyName=OCS Installation....
    AppLaunched=OCS-SilentInstall.bat
    PostInstallCmd=<None>
    AdminQuietInstCmd=
    UserQuietInstCmd=
    FILE0="ChangeLog"
    FILE1="ocsagent.exe"
    FILE2="OcsAgentSetup.exe"
    FILE3="OcsAgentSetup.log"
    FILE4="OcsLogon.exe"
    FILE5="OCS-SilentInstall.bat"
    FILE6="OCS-SilentInstall-tst.cmd.bat"
    [SourceFiles]
    SourceFiles0=D:\Sarat\Softwares\OCSNG_WINDOWS_AGENT_4061.1\
    [SourceFiles0]
    %FILE0%=
    %FILE1%=
    %FILE2%=
    %FILE3%=
    %FILE4%=
    %FILE5%=
    %FILE6%=

     

    18 Ağustos 2010 Çarşamba 15:07

Tüm Yanıtlar

  • Your SED file looks correct and should launch your .bat file. Place a "pause" at the end of your OCS-SilentInstall.bat and see if you can see any errors in the cmd window. Or you could change AppLaunched=OCSAgentSetup.exe /S /server:myserver.mydomain.com
    v/r LikeToCode....Mark the best replies as answers.
    05 Ocak 2011 Çarşamba 20:07