none
Trying to install the Connector: WHS 2011

    问题

  • I'm attemting to install the WHS connector on my station, but it continually fails with 'an unexpected error'

    There's no indication of where the problem may be.

    I've attempted the usual cleanups - temp folders, etc. bu all to no avail.

    Is there a log file anyplace which may provide a bit more detail?

    Anyone seen this before?

    Many thanks!

    2012年3月2日 15:37

全部回复

  • Try this to start with:

    http://social.technet.microsoft.com/wiki/contents/articles/3941.troubleshooting-client-deployment.aspx


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    2012年3月2日 15:44
  • Hi Phil,

    Thanks for the pointer.

    I'm unable to change etc\hosts as the location is protected and all of the permissions update options are grayed out.

    I took a look in the ClientCore.msi.log and found:

    MSI (s) (6C:18) [10:31:15:462]: Executing op: CustomActionSchedule(Action=SetupMcConnector,ActionType=9234,Source=C:\Program Files\Windows Server\Bin\esSetup.exe,Target=**********,)
    CustomAction SetupMcConnector returned actual error code -2147023828 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (6C:18) [10:31:30:969]: Note: 1: 1722 2: SetupMcConnector 3: C:\Program Files\Windows Server\Bin\esSetup.exe 4: **********
    MSI (s) (6C:18) [10:31:30:969]: Note: 1: 2205 2:  3: Error
    MSI (s) (6C:18) [10:31:30:969]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1722
    MSI (s) (6C:18) [10:31:30:985]: Note: 1: 2205 2:  3: Error
    MSI (s) (6C:18) [10:31:30:985]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
    MSI (s) (6C:18) [10:31:30:985]: Product: Windows Home Server 2011 Connector -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action SetupMcConnector, location: C:\Program Files\Windows Server\Bin\esSetup.exe, command: **********
    Action ended 10:31:31: InstallFinalize. Return value 3.
    MSI (s) (6C:18) [10:31:31:001]: User policy value 'DisableRollback' is 0
    MSI (s) (6C:18) [10:31:31:001]: Machine policy value 'DisableRollback' is 0

    The error doesn't really tell me anything significant.

    Cheers ... Peter

    2012年3月2日 16:29
  • Peter, if your hosts file is protected, then I suspect you aren't an administrator on the client you're trying to install the connector on. Being an administrator on the client is a requirement, I'm afraid.

    I'm not on the WHS team, I just post a lot. :)

    2012年3月2日 16:50
  • Hi Ken,

    I found the technique to get it changed - run Notepad as administrator.

    The problem persists.

    I have successfully got other stations in my network added, so it's definiely something local to the machine.

    Thanks.

    Cheers .. Peter

    2012年3月2日 17:09
  • Looking at the server, it seems that ther is a certificate problem.

    There is a list of certificate revocation entries which correspond with the attempts to install the connector.

    Any ideas on how to fix this situation?

    Many thanks

    2012年3月6日 22:16