none
Node template with Deployment tasks

    問題

  • Hi,

       I want to automate Windows HPC Setup for Compute nodes which involves tasks like joining to domain, Installing HPC Pack, restart the instance.

      I understand from Node Template , we can add these tasks to a node template and apply the template to a server instance and perform the actions automatically.

     But my question is how do I apply this nodetemplate to a plain instance which only has OS installed ( not a bare metal setup ) .

     Are these tasks apply only for deployment types for bare metal setup ? or Can these be applied to the other category as well ?

     Any samples towards this tasks usage in node templates will be helpful.

    Thanks in advance

    Aravindakumar.V

    2012年2月21日 上午 08:48

所有回覆

  • Hello.

    If i understand you correctly, you want to apply some node template to nodes that are already preconfigured. If so, you can apply them - simply don't set OS image in template settings and then apply. Please give some feedback if i don't understood you.

    2012年2月21日 下午 03:49
  • Hi,

      I understand the same, but I created a node template and included a deployment activity to Install HPC Pack in Compute Node.

      When I applied the node template , the provisioning log says 'Initiating deployment operations for template: ComputeNodeTemplate3' but no activity has been observed on both head node and the compute node and HPC Pack Installation is not happening as well. Am I missing anything here?

    Note: I have copied the HPC Pack Installer to the location as defined in the task in Compute Node as well as in Head Node.

      Do I have setup anything specific towards Windows Deployment Services on the head node as well as on compute nodes, if so please provide the details on the same.

    How can I track on the activities happening when I assign the node template to a specific node.

    Any logs that we can refer to?

    Thanks in advance

    Aravindakumar.V


    2012年2月22日 上午 06:26
  • When creating compute node templates, Provisioning, Configuration, and Deployment deals with tasks that have to do with bare metal.

    For anything that has an OS installed, you need to use the Maintenace section.  

    So for instance, if you wanted to install HPC Pack, you create a "Post Install Command" from "Mainetnance" and from there you carry out the HPC installation using the quiet mode.  In other words, you specify how to install the node.  

    Hope this helps,

    Christian from ScorpioTek

     
    2012年2月23日 上午 02:17
  • Hi Christian,

    Thanks for your response.

    I tried to include the HPC installation task in Silent mode as you mentioned in Maintanence activity. It didn't perform the task as well.

    Then I tried to put a simple notepad.exe command in the Maintanence activity, even that didn't execute. Provisioning logs says the following stack message

    Time Message
    2/23/2012 5:17:58 PM Could not contact node 'Compute1' to perform change. Connection Failed. A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.237.247.17:6730
    2/23/2012 5:17:37 PM Checking the configuration of node Domain\Compute1

    2/23/2012 5:17:37 PM Associating template ComputeNodeTemplate3 with node Domain\Compute1

    Also I am wondering why the Deployment tasks are restricted only for bare metal setup, since it is very much applicable for servers with OS installed as well and none of the documentation mentions the same..
    2012年2月23日 上午 11:52
  • Hi,

    My guess is that there could be issues with trust relationship between your nodes.  Can you please run the "Domain Connectivity Test" from Diagnostics and report back what you get?  

    Thanks!

    -Christian

    2012年2月23日 下午 10:01