Click Once Error "ShellExecuteEx failed with error code -2147221003"


  • I am getting the following error when the setup.exe of a Click Once deployment is running. This is from the log

    Launching Application.
    Running command '' with arguments ''
    ShellExecuteEx failed with error code -2147221003
    Error: The following error occurred attempting to install '':
    "Application not found "

    Any ideas on what may be causing the error. The installer works fine on some computers.







    10/محرم/1428 05:39 م

جميع الردود

  • I got the exact same error.  I'm still not sure why,  but here are a couple of things that I've tried and actually worked:

    1.  When you publish your apps, have it install from CD (in the publish wizard, when it ask the question on how the user will install the application, pick CD-ROM).  Then in the UpdateLocation, you point it to your website (http://...).  After that you publish another one, but this time point the publising location and installation url to your website.  By doing it this way, you install the apps using the CD, but any updates they will get it from the website.

    I know it may sound kind silly, but it actually worked.

    2.  When you go to the website where your apps is residing, do you have the link to launch the application?  Have tried clicking on that.  I had a pc where I had the same exact error as you do, it won't install the apps when I click on Install button..  But when I clicked on the Launch linked, it actually install the apps.  Somehow when you try to launch it, it actually forces it to install.

    If anyone can explain why the installation is giving this error, that would be great.  In the meantime, I found the two things mentioned above to be effective.


    12/صفر/1428 11:33 م