Buttons not visible in 64 bit Outlook RRS feed

  • Question

  • I'm not seeing the buttons after installing this. I'm running Windows 8 and Outlook 2013 64-bit. Installer succeeds according to Event Logs. Don't see the Add-in listed in Outlook. I was not running any previous version of the software. Any ideas?

    Thursday, February 14, 2013 6:31 PM

All replies

  • Same issue with me. I originally had the 2.0 version, so I uninstalled it prior to installing 3.0. However, I do not see the buttons reappear, and when I look under Options > Add-Ins, it doesn't list the NoReplyAll add-in. However, I do see it in Control Panel > Programs and Features.

    Any thoughts?

    Thursday, February 14, 2013 7:25 PM
  • Michael, are you using 64 bit Outlook too? I have to own up to not testing with 64 bit - I've just now got my hands on a suitable system to try.

    With the previous releases of the add-in, I placed some registry settings under HKCU\Software\Microsoft\Office\Outlook\Addins (which meant they were available only to the user who installed the add-in, which wasn't acceptable for some people); because of other changes I was making in the installation process, I took the opportunity to move that to HKLM to make the add-in available to all users, and I see that the installer is putting those keys in the "wrong place" for 64 bit Office (though the correct location for 32 bit Office). On my 64 bit Windows test box, the NoReplyAll key end up under HKLM\Software\Wow6432Node\Microsoft\Office\Outlook\Addins - note the additional Wow6432Node in the path. This is where 32 bit apps end up actually looking when they access the same path without that; 64 bit apps look in the expected place.

    If you're comfortable with delving into the registry, the "fix" is to copy the NoReplyAll key found under that path to the non-Wow path? (Probably the easiest way to do that is export the key to a text file, then delete the Wow6432Node\ and re-import.) Or, since the previous build worked with the key under HKCU, that might be another place to try adding the registry entries.

    In detail, the steps to copy the registry fragment is:

    • Start regedit.exe
    • Navigate to HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Office\Outlook\Addins
    • Right click on the NoReplyAll subkey and select "Export"
    • Edit the resulting file (eg, open in Notepad, or just right click and select "Edit") and remove the Wow6432Node\ fragment of the path; save the file
    • Import it back into the registry by double clicking it (or right click and select "Merge")
    • (Re)start Outlook and you should see the buttons

    Obligatory warning: take immense care when editing the registry - deleting or editing something important can do horrible things to your installation of Windows!

    The root cause of the problem is that my installer is a 32 bit one, and only "knows" about the 32 bit shadow of this part of the registry, which is the right thing to do for 32 bit Office. I'll need to scratch my head about (a) detecting the presence of 64 bit Outlook and (b) escaping from 32 bit constraints to scribble in the right place. (Or I could go back to the old scheme of writing into HKCU instead, with the disadvantage that the add-in is no longer available to all users.)

    Friday, February 15, 2013 7:13 AM
  • Gavin, this registry workaround worked for me. The buttons show up now. Thanks.
    Friday, February 15, 2013 4:04 PM
  • Success! Thanks Gavin!
    Tuesday, February 19, 2013 4:55 PM
  • Works great on 64-bit OL 2010. Thank you! I hope the 64-bit install is smoother in the future, but it's a small price to pay to STOP the silly people who only have one button on their ribbon; reply all.

    Friday, May 10, 2013 7:08 PM
  • Hello,

    I tried your solution on my Outlook 2010 64b version, I export the .reg file on my desktop, delete Wow6432Node\ and then double clic and then clic ok.
    BUT it does not change anything and when I re-export it, 
    Wow6432Node\ is back in the path.

    Could you help me please.

    • Edited by dudu42201 Saturday, May 18, 2013 8:05 PM
    Saturday, May 18, 2013 8:03 PM
  • The export will always be whatever you pointed RegEdit at, so every time you export the Wow6432Node subpath you'll see exactly the same thing. The point of this slightly mucky set of steps is to get whatever was under the NoReplyAll Wow6432Node path to the same place without the Wow6432Node. After importing (doubleclicking the edited file), run RegEdit again and go to HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlook\Addins - do you see NoReplyAll there now? If so, then Outlook should be able to find and load the add-in; if not, check that you'd edited the file correctly.

    Of course, something else might be going wrong, but I can't tell what...

    (Sorry that this really is much messier than we want - I'm working on a combined 32 and 64 bit installer, which will be available as soon as I've tested it thoroughly.)

    Monday, May 20, 2013 5:56 AM
  • Ok - the registry hack worked for me, and I now see the (Reply All, Reply, and Forward), buttons in my OL2010's ribbon,
    But I can't see anything relevant to the missing attachment detection that this add-in is also supposed to do ?
    I also sent myself an email saying "here's that attachment" (but with no attachment), and got no prompts


    Monday, May 20, 2013 6:14 PM
  • Well, I still have NoReplyAll in the Addins but this still does not work. Too bad, I just wanted to use the "forgotten attachment alert".
    Monday, May 20, 2013 7:32 PM
  • Hmmm, I'll have to investigate further - maybe I messed up my version check about when to handle attachments (Outlook 2013 includes a built in check, so I disable my check in that version, or at least I attempt to).

    TheAdmiralBenbow: you definitely see no options for attachment checking on the backstage where the options for setting default no-reply behaviour are, right?

    And, dudu44201, when you say "in the Addins" do you mean in the registry (in the "non-Wow" bit), or do you mean within Outlook (under options -> add-ins)? And if the latter, is it marked as disabled?

    Tuesday, May 21, 2013 6:04 AM
  • TheAdmiralBenbow: you definitely see no options for attachment checking on the backstage where the options for setting default no-reply behaviour are, right?

    Sorry - I never thought of looking there - (under "File -> NoReplyAll")
    I also see now why it wasn't detecting missing attachments - the list(s) are not pre-populated with any keywords (might be an idea to add a few obvious ones)

    I tried it with a list of "attached;included;attachment" - and it does work



    Tuesday, May 21, 2013 1:12 PM
  • Make sure you have DOT.NET framework 4.0 installed that fixed it for me (the plugin requires it)
    Friday, June 21, 2013 9:52 AM
  • The new release of NoReplyAll includes installer support for 64 bit Outlook, so there should be no more need for the registry hack.
    Saturday, August 3, 2013 6:26 AM
  • Thanks Gavin, The new release of NoReplyAll worked fine for outlook 64-bit
    Monday, December 7, 2015 5:40 PM