Windows 10 Store issue (with AppXManifest.xml and AppXBundleManifest.xml) RRS feed

  • Question

  • Hello everyone :). I am new to the forums as a member, but quite familiar with the forum itself as well as the troubleshooting tips it provides.  (My apologies if this is the wrong Forum Category. It was the closest one I could relate to. Please feel free to change it, because I honestly don't know how).

    As the title states, I'm having issues with the Windows Store. It was fine before, although I almost never used it, the Windows Calculator was something I used a lot. So, a couple of days ago, I noticed that I can't access a lot of the features that Windows Store provided, and it turned out that the Windows Store itself was deleted. I've read a lot on the forums about this issue, and despite trying every single method possible (I've spent over 20 hours non-stop trying to figure it out), but to no avail. Here are the methods that I have tried:

    1- Powershell commands from numerous sites. Yes I made sure everything was written correctly. There were so many commands. I wrote them one by one, still to no avail. 
    2- I tried creating another account and transfer user logs, parameters, configurations there. Still no avail. 
    3- I downloaded Windows 10 again using Media Creation Tool, and reinstalled whilst keeping my files and letting it update. Still no difference. 
    4- I tried that reinstall-preinstalledApps thing (which also uses Powershell), and still nothing. I always got errors that they are either invalid or not found (mostly not found, because they are literally wiped. Nothing in the WindowsApp directory). 
    5- I tried Tweaking.com Windows Repair, which actually made it worse, which forced me to use DISM to restore health. (It's fine now, but still no store). 

    What I have noticed is that this error occurred after the last Windows Features Update. Now, no matter what I do, Windows Store just won't budge. I've tried countless methods from numerous sites other than this one, and still no success, unfortunately. My computer otherwise is working fine, but it is still quite annoying, as it does have some adverse effects to a couple of applications that indirectly depend on Windows Store.

    My question is, of course, about how to fix this, and second, why is there no standalone installer for Windows Store? I've seen a forum that provided the Windows Store files, directly copy/pasted from one PC and transferred to another. The link however was quite old, meaning it is dead now. 

    That solution part is found in the comments section actually. So, currently, I'm trying to use the following command, and getting the corresponding error:

    PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}

    And the error that I get is:

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF9, Install failed.
    Please contact your software vendor. (Exception from HRESULT: 0x80073CF9)
    Rejecting a request to register from AppxBundleManifest.xml because the manifest is not in the package root.
    Note: For additional information, look for [ActivityId]
    b00314c8-95f5-0006-f34d-03b0f595d301 in the Event Log or use the command line
    Get-Appxlog -ActivityID b00314c8-95f5-0006-f34d-03b0f595d301
    At line:1 char:97
    + ... fest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manife ...
    +                     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo             :WriteError: (C:\Program File...ppxManifest.xml:String)[Add-AppxPackage], IOException
          + FullyQualifiedErrorId  : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

    Running the Get-Appxlog command on Powershell gives me:

    PS C:\WINDOWS\system32> Get-AppxLog -ActivityID b00314c8-95f5-0006-f34d-03b0f595d301

    Time                      ID           Message                                                                                                                                                         
    ----                      --           -------                                                                                                                                                         
    25-Jan-18 8:18:07 PM      603          Started deployment Register operation on a package with main parameter: AppxManifest.xml and Options: 0 and 0. See                                              
                                           http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues.                                                                        
    25-Jan-18 8:18:07 PM      709          Rejecting a request to register from AppxBundleManifest.xml because the manifest is not in the package root.                                                    
    25-Jan-18 8:18:07 PM      404          AppX Deployment operation failed for package  with error 0x80070057. The specific error text for this failure is: Rejecting a request to register from          
                                           AppxBundleManifest.xml because the manifest is not in the package root. 

    Note that I have tried repairing my Windows numerous times with the Media Creation Tool, and it didn't work. Same for the creation of another Microsoft Account. Nothing worked unfortunately, which is why I'm asking if there is a link I can get the Windows Store files from directly. Even WSRESET.exe isn't helping because of a PurgeCache error that is not found.

    Now, before you ask, I have run both Malware and Anti-Virus scans, and my computer is clean. DISM restorehealth was also performed numerous times, all successfully. The only strange thing is that sfc /scannow always returned with some corrupted files that it could not fix. Not even DISM was able to fix them, nor the Windows 10 reinstallation (Note that I have Windows 10 Pro latest build).

    If there is an ultimate solution to this problem, I'm all ears... even maybe a near-future update that fixes all issues with Windows Store? I'd really appreciate that

    Thank you for reading, and sorry for the long post :)

    • Edited by Exceedra Thursday, January 25, 2018 6:35 PM
    Thursday, January 25, 2018 6:30 PM

All replies

  • First, category "Windows Phone / Blink"??

    Second, "Add-AppxPackage -RegisterByFamilyName -MainPackage Microsoft.WindowsStore_8wekyb3d8bbwe".

    Saturday, March 3, 2018 10:30 AM
  • PS C:\WINDOWS\system32> Add-AppxPackage -RegisterByFamilyName -MainPackage Microsoft.WindowsStore_8wekyb3d8bbwe
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict
    Windows cannot install package Microsoft.WindowsStore_11906.1001.24.0_x64__8wekyb3d8bbwe because this package depends
    on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Runtime.2.1" published by
    "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor
    architecture and minimum version 2.1.26424.0, along with this package to install. The frameworks with name
    "Microsoft.NET.Native.Runtime.2.1" currently installed are: {}
    NOTE: For additional information, look for [ActivityId] b43538cc-4d63-0000-80af-35b4634dd501 in the Event Log or use
    the command line Get-AppPackageLog -ActivityID b43538cc-4d63-0000-80af-35b4634dd501
    At line:1 char:1
    + Add-AppxPackage -RegisterByFamilyName -MainPackage Microsoft.WindowsS ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : WriteError: (Microsoft.WindowsStore_8wekyb3d8bbwe:String) [Add-AppxPackage], IOException
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

    How to get Microsoft.NET.Native.Runtime.2.1 installed? I guess it's not a .NET Core, right?

    Wednesday, August 7, 2019 10:16 PM