none
Vælg tekstlag og tryk OK!.

    Spørgsmål

  • Hej.

    Jeg har opgraderet en C5 fra ver 3.0 til 2010. Og har oversat udskrifterne ifølge vejledningen der følger med i ver 2008 sp 1. I udskrifterne har jeg manuelt været inde og tilføje det standard tekstlag der som altid når man opgradere en udskrift mangler.

    Jeg har et lille problem med de overførte udskrifter, C5 kommer og spørg hvilket tekstlag udskriften skal køre på, HVER gang man vil lave udskriften, udskriften har også problemer med at huske hvilken en debitor der f.eks blev valgt sidst, alle felter er altså nulstillet når man går ind i udskriften igen.

    Hilsen den fustrede.

    16. november 2010 12:32

Svar

  • Hej René

    Ved godt det er Henrik du skriver til - men alligevel: Der er netop blevet frigivet en HF3 til 2010SP1 (og i øvrigt også en HF8 til 2008SP1). HF3 til 2010SP1 er inkl. nye kerner. Du kan finde dem på PartnerSource...

    PS: Spændt på om det løser dit problem eller det er mit forslag med at du skal de brugertilpassede elementer igennem der gør tricket for dig :-).

    MVH

    gsl (at) systemconnect.dk

     


    MVH gsl (at) systemconnect.dk
    14. december 2010 10:47

Alle besvarelser

  • Hej Frustrerede

    Du kan ikke "bare" drøne en C5 version 2.1 udskrift igennem oversættelses tool'et og så forvente at den kører på 2010. Og det gælder i øvrigt også ALLE andre tilpassede elementer.

    Du er nødt til at gennemgå alle elementer og "løfte" dine tilpasninger ind i 2010's standard-elementer - ellers går du i bedste fald glip af de ting der er ændret og i værste fald sker der dårlige, uoverskuelige ting...

    Det er derfor det er relativt dyrt at få opgraderet når man har mange tilpasninger...

    NB: I netop de nye 2010'ere er der lavet om på logikken i den måde mange af udskrifterne er lavet på - især kunde-dokumenterne som tilbud, følgeseddel, faktura osv. Bl.a. fungerer udskrift fra arkiv anderledes end tidligere...

    MVH

        gsl(at)systemconnect.dk


    MVH gsl (at) systemconnect.dk
    • Foreslået som svar af Gert Lynge 16. november 2010 12:46
    16. november 2010 12:46
  • Hvad har du af forslag så?

    Hvis jeg har en masse udskrifter som er lavet i en ver. 2.1, og skal bruge dem i 2010?

     - René

    16. november 2010 13:17
  • I det omfang hvor det er tilpasninger af standardudskrifter, så er det sådan set lige meget om du har få eller mange: Lav dem igen ved at tilpasse de nye standardudskrifter. Alternativt kan du naturligvis gennemskue hvordan logikken er nu og så tilpasse dine egne. Men der er bare større mulighed for fejl og det er sikkert mindst det samme arbejde...

    Du kan jo starte med dem der giver problemer og så (alt efter hvor modig du er) bare teste resten grundigt...

    Hvis det er egne specialudskrifter (dvs. ikke tilpasninger i standardudskrifterne) - så test dem grundigt og få dem justeret hvis de er holdt op med at fungere...

    Der er ikke nogen genveje hvis du vil slippe for problemer (i hvert fald ikke nogen jeg kender - så hvis der er, så føler jeg mig i hvert fald dum efter at have arbejdet med c5 og XAL-programmering i 13-14 år :-) ).

    MVH

        gsl (at) systemconnect.


    MVH gsl (at) systemconnect.dk
    • Foreslået som svar af Gert Lynge 16. november 2010 13:37
    16. november 2010 13:37
  • Okay, jamen det du siger er at jeg skal tage den nye standard udskrift og tilrette den.

    Så sagt så gjort. Og nu fejler den så også, udskriften der er snakke om er CustAccStatementEXT. Jeg har tilpasset lidt i brede på felter og flyttet lidt rundt på dem, jeg har ikke slettet nogen linjer, felter eller headders.

    Og alligevel fejler udskriften den siger: Array indeks er udenfor grænserne!

    Jeg er lige ved at blive sindsyg... Det er ikke den fejl jeg har fået før ved at ændre i en udskrift.

    - René

    16. november 2010 14:13
  • Ja, det er det jeg siger :-).

    Det lyder som om du har fået slettet noget af logikken omkring totalerne på netop den udskrift. Man skal passe lidt på med hvordan man retter.

    Mit bedste bud - hvis du selv skal klare det - er at prøve igen forfra. Og så tage en ændring ad gangen og teste hver gang.

    Der må være et eller andet sted "kæden hopper af" for C5 2010 er altså ikke mere hysterisk eller buggy end de gamle udgaver :-)

    Alternativt kan du jo tage fat på en/din C5-partner - men det koster jo lidt (du er naturligvis velkommen til at sende mig en e-mail)...

    MVH

        gsl (at) systemconnect.dk


    MVH gsl (at) systemconnect.dk
    • Foreslået som svar af Gert Lynge 16. november 2010 14:22
    16. november 2010 14:22
  • Kan det være fordi jeg har slettet et felt det hedder currency`

    Jeg er iøvrigt partner.

    - René

    16. november 2010 14:29
  • Det tror jeg ikke (det er vel bare valutakoden?).

    Nok nærmere definitionerne af nogle af totalerne eller en linje med noget subtotal...

    Mail mig en export af udskriften, så kan jeg da lige kaste et blik på det i aften og fortælle dig hvad der er galt...

    MVH

    gsl (at) systemconnect.dk


    MVH gsl (at) systemconnect.dk
    • Foreslået som svar af Gert Lynge 16. november 2010 14:36
    16. november 2010 14:36
  • Vi har her i huset flere gange oplevet noget lignende netop med kontoudtoget, CustAccStatementEXT. Bare vi åbner rapporten og gemmer med F3 - uden at rette noget som helst - fejler den ved Rep / Kør og ved udskrift fra menupunktet. Men vi kan sagtens afvikle rapporten når vi har den 'åebn' med Alt + R.

    Når det sker i en C5 2010 SP1 (eneste version vi har haft problemer i), med HF001 eller HF002, har vi løst det ved at tage den rapport, vi har oversat og fra standardrapporten taget alt fra alle kørslerne og lagt ind i den oversatte. Ellers tror jeg vi har forsøgt ALT. Det sker ikke i alle opgraderinger..

    Venlig hilsen

    Lillian Juhl Petersen, PentaCon A/S


    Lillian Juhl Petersen C5 Systemkonsulent PentaCon A/S
    18. november 2010 15:02
  • Hej Lillian,

    Det problem du oplever med CustAccStatementEXT vil jeg opfordre dig til at oprette en sag på i supporten - eventuelt undersøge om vi må "låne" en kopi af USR laget fra kunden. Vi har allerede en sag, hvor vi har et USR lag med samme fejl. Problemet er sandsynligvis at der under forhold vi ikke kender og forstår opstår en intern fejl i USR laget. Vi vil til næste C5 version gøre et forsøg på at få has på dette problem.

    mvh
    Henrik Hansen

     


    Venlig Hilsen Henrik Hansen Program Manager II Microsoft Dynamics C5 ------------------------------------------------------- This post is provided 'as is' and confers no express or implied warranties or rights.
    19. november 2010 07:46
    Ejer
  • Hej Henrik Hansen.

    Hvis vi laver en support sag, for jeg har problemet ved 2 kunder nu, er det så noget i kan fikse? Kan i løse problemet, og hvad skal vi give for deT?

    Hilsen René.

    1. december 2010 09:00
  • Hej René,

    Den næste Hotfix kerne vi frigiver vil indeholde en rettelse på dette problem.
    Den frigives om kort tid (Kan ikke være mere præcis).

    mvh

    Henrik Hansen


    Venlig Hilsen Henrik Hansen Program Manager II Microsoft Dynamics C5
    1. december 2010 12:53
    Ejer
  • Hej Henrik.

    Nogen udsigt til hvornår denne HotFix kommer?

    Hilsen René

    14. december 2010 10:39
  • Hej René

    Ved godt det er Henrik du skriver til - men alligevel: Der er netop blevet frigivet en HF3 til 2010SP1 (og i øvrigt også en HF8 til 2008SP1). HF3 til 2010SP1 er inkl. nye kerner. Du kan finde dem på PartnerSource...

    PS: Spændt på om det løser dit problem eller det er mit forslag med at du skal de brugertilpassede elementer igennem der gør tricket for dig :-).

    MVH

    gsl (at) systemconnect.dk

     


    MVH gsl (at) systemconnect.dk
    14. december 2010 10:47