none
Kan ikke udskrive til Excel??

    Spørgsmål

  • Hej.

    Jeg kan simpelthen ikke få min c5 til at udskrive til Excel. Jeg syntes jeg har fulgt vejledningerne, men når jeg udskriver til excel sker der ikke noget.

    Jeg kan dog gå i overførsler og åbner jeg et en anden excel fil, åbnes også den udskrift jeg har forsøgt med med via c5.

    Hvad katten går der galt?

    Vh. Mette

    3. februar 2015 16:18

Alle besvarelser

  • Hej.

    Jeg kan simpelthen ikke få min c5 til at udskrive til Excel. Jeg syntes jeg har fulgt vejledningerne, men når jeg udskriver til excel sker der ikke noget.

    Jeg kan dog gå i overførsler og åbner jeg et en anden excel fil, åbnes også den udskrift jeg har forsøgt med med via c5.

    Hvad katten går der galt?

    Vh. Mette

    Hej Mette,

    Prøv at vælge en udskrift som f.eks. kontoplanen. Udskriv denne til "Skærm" og valgt printer = MS Excel eller MS Excel PDF.

    Når du skriver til MS Excel og kommer igennem første afgrænsning "Udskrift til Excel" - tryk OK og der vises nu "Genererer Excel-dokument" herefter kan du vælge om du vil gemme dokumentet - evt. markér dette - tryk OK - herefter skulle du gerne få dannet et Excel dokument. Det er ikke sikkert at Excel åbner, men dokumentet findes på proceslinje.

    Når du skriver til MS Excel PDF - gentag ovenstående - og du får vist et PDF dokument på skærmen.

    Hvis du ikke kommer så langt, men får fejl under vejs, så skrive igen med hvilke fejl du får, så kan der fejlsøges herpå


    M.v.h. René rsl@

    4. februar 2015 10:41
  • Hej Rene / Mette,

    Vi har samme udfordring, og jeg kan ikke selv finde frem til en løsning. Så nu prøver jeg at spørge eksperterne.

    Vi kører C5 4.20 og Excel 2007 begge dele 32bit, på en 64bit Windows 8.1

    Jeg genererer en rapport og vælger udskriv til skærm og "MS Excel", hele rapporten genereres korrekt uden fejl. Men den åbner ikke Excel, der sker ingen ting.

    Det er først når jeg vælger at åbne en anden fil i Excel, så åbnes den genererede rapport også. Den fil jeg åbner åbnes oven på den genererede rapport som ligger sig ikke gemt i baggrunden.

    Så DDE forbindelsen mellem C5 og Excel virker fint, men selve det at åbne Excel lader til ikke at virke.

    Hvis der er nogen der har en ide til hvad der går galt så sig endelig til.

    Mvh Anders

    20. april 2015 13:11
  • Hej Anders,

    Vi har været ude for det samme, netop med en C5 4.2 og Windows 8.1.
    Vi opgraderede til 4.4, da der tydeligvis er rettet i Excel objekterne fra 4.2 til 4.4. Det fiksede problemet.
    Men om du kunne nøjes med 4.3 har jeg ikke undersøgt nærmere.

    Har kunden opdaterings abonnement, kunne du måske lave dit eget "private fix" til denne kunde, ved at flytte 4.4 elementer ned i 4.2 C5'en. Dog kender jeg ikke til de specifikke retningslinjer fra Microsoft på den idé. Så det vil jeg vende med Microsoft inden...

    24. april 2015 07:18
  • Hejsa

    For lige at uddybe det Mads skriver: XAC frameworket blev indført i C5 version 2012 (det er den der internt hedder version 4.4) - så Word/Excel integrationen formentligt helt ændret ift. tidligere.

    Man KAN faktisk tilkøbe XAC til ældre C5'ere - men hvor meget det ændrer på standard-funktionaliteten - eller det "kun" er noget man selv kan bruge når man programmerer skal jeg ikke kunne sige... Men det kan programmøren (Martin Broholm) sikkert svare på :-).

    Se evt. http://blog.systemconnect.dk/?p=591 for mere info. og kontaktoplysninger på Martin...


    MVH gsl@systemconnect.dk Se også: http://blog.systemconnect.dk/

    24. april 2015 07:30
  • Hej,

    Jeg har testet på en C5 2010 SP1 HF10 fra en 64-bit Windows 8.1 maskine med 32-bit Office 2013 installeret, og oplever samme problem.

    Med fare for at jeg har overset noget, så har jeg på mit setup fået det til at virke ved at lave følgende ændring i COMPRINTEXCEL.FNC:

        #Case('AppShow')
            IF (&HCOM == '') THEN
                RETURN &FALSE
            ENDIF

            //
            SET COMPush(&HCOM, &HCOM)
            SET COMPushVariant(&HCOM, 'VT_BOOL', '-1' ) // "TRUE" er ændret til "-1"
            SET &HR = COMPut(&HCOM, 'Visible', 0)
            #ShowError(&CMD+':'+'COMPut,Visible')

            //
            SET COMPush(&HCOM, &HCOM)
            SET COMPushVariant(&HCOM, 'VT_BOOL', '-1' )  // "TRUE" er ændret til "-1", er muligvis ikke nødvendig, men skader tilsyneladende ikke
            SET &HR = COMPut(&HCOM, 'UserControl', 0)
            #ShowError(&CMD+':'+'COMPut,UserControl')

            RETURN &TRUE

    At forsøge at downporte/importere seneste C5 2012 elementer kan sikkert lade sig gøre, men er ret omfattende, da der er lavet mange ændringer.

    Prøv at teste dette.


    Venlig Hilsen Henrik Hansen Senior Software Engineer Microsoft Dynamics C5

    24. april 2015 10:49
    Ejer