none
C5 2012 manglende hjælp F1

    Spørgsmål

  • Har installeret C52012 på en server, men hjælpefunktionen viriker ikke ( F1 ).

    Har forsøgt at flytte hjælpefilerne fra Country mappen , op i roden sammen med de øvrige C5 filer,  men det virker ikke.

    Har også forsøgt at lægge hjælpefiler lokalt på C-drevet i en mappe C:\C5help  og så henvise i opstartsparameter.  Men dette virker heller ikke.

    I tidligere versioner kunne man køre et script til reg-databasen som så tillod hjælpefilen at blive vist.

    Dette virker heller ikke.

    Er der nogen der har et tip til hvordan man simpelt og uden finurlige indstillinger kan få noget så naturligt i C5 som hjælpunktionen burde være,  til at virke ?

    Har set problemet på nu 5 forskellige kundeinstallationer af C52012.     

     

    4. februar 2013 21:17

Alle besvarelser

  • Rettigheder på mappen / filen? Det plejer at være der, det kniber.

    På mine 2012 virker F1 fint.

    Mvh Maria

    4. februar 2013 21:20
  • Tror desværre ikke at det har noget med rettigheder på mappen at gøre.   Jeg har fulde rettigehder til F:\c52012 ( nuværende placering ) og hjælpefilerne ligger også i denne mappe ( er administrator på serveren har fuld adgang til hele drevet).

    Hvilke rettigheder skulle det dreje sig om , som er specielle for hjælpefilerne ?

    Kan det tænkes at din C5 ligger på en lokal disk ( C: )    .    Der virker min F1 nemlig også .   Men denne C5 ligger som nævnt på en server .

    4. februar 2013 21:44
  • Hej Qrake

    Vi har flere installationer af C5 2012 (både med og uden SP1) hvor F1 hjælpen virker fint. Også hvor de er installeret på netværksdrev.

    Vi "Plejer" at udvide søgestien i C5.ini så Contry/DK mappen medtages.

    Herefter kører vi (hvis nødvendigt) den registry-fil du henviser til - men du skal være obs på at der (så vidt jeg husker) er forskel på 32 bit og 64 bit systemer - så hvordan ser den reg-fil rent faktisk ud som du bruger? Og er det en 32 eller 64 bit windows du har problemer med?

    Vores ser sådan her ud:

    REGEDIT4
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\HHRestrictions]
    "MaxAllowedZone"=dword:00000001
    "UrlAllowList"=""
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions]
    "MaxAllowedZone"=dword:00000001
    "UrlAllowList"=""
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\HHRestrictions]
    "MaxAllowedZone"=dword:00000001
    "EnableFrameNavigationInSafeMode"=dword:00000001
    "UrlAllowList"=""
     
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\ItssRestrictions]
    "MaxAllowedZone"=dword:00000001
    "UrlAllowList"=""

    Endelig kan det være nødvendigt at tilføje C5-drevet som et intranet site i Internet Settings - og endelig kan det være nødvendigt lige at højreklikke på hjælpefilerne _ENKELTVIS_ (vigtigt) og fjerne evt. blokering fordi de kommer fra en fremmed computer (hvis windows har markeret dem med det flag).

    NB: Du skal være opmærksom på at ovenstående reg-fil fjerner noget beskyttelse på din PCer og derfor kan udgøre et sikkerhedsproblem. Du kan læse tidligere indlæg i forum'et om det...

    Håber det hjælper dig videre...


    MVH gsl@systemconnect.dk Se også: http://blog.systemconnect.dk/


    5. februar 2013 07:08
  • Hej Qraka,

    Gert har svaret, men et tidligere svar indeholder link til kb artikel om problematikken:

    http://social.microsoft.com/Forums/da-DK/c5/thread/2cbc75aa-91ed-477f-b6c4-b87df5a8ea97


    Venlig Hilsen Henrik Hansen Program Manager II Microsoft Dynamics C5

    5. februar 2013 09:28
    Ejer
  • tak for hints.

    Har forsøgt de forskellige løsninger, men jeg valgte den med at hjælpefilerne ligger lokalt i C:\c5helpt og så ændre INI.   Og det virker.

    6. februar 2013 11:18