none
MessageLoop in erstelltem Thread

    Frage

  • Hallo!

    Leider finde ich hier zZ nur MIcrosoft Money und keine Unterforen, weswegen ich das einfach mal auf gut glückposte ohne zu wissen wo es landet.

    Hoffe es wird verschoben und nicht gelöscht.

    Ich schreibe zZ ne kleine Anwendung.

    Wenn ich einen Hook vom Typ WH_KEYBOARD_LL erstelle, funktioniert alles super, meine Main-Funktion  enthält den Messageloop "while(GetMessage(&message,NULL,0,0));"

    und alles ist in Ordnung.

    Wenn ich nunversuche diese Schleife in eine Funktion zu packen und diese Funktion in einen Thread packe, passiert gar nichts, ich kann nichts schreiben.

    Ich habe das Hauptprogramm mal  mittels Sleep und mal mittels WaitForMultipleObjects warten lassen, Resultat ist das gleiche.

    Gibt es also eine Möglichkeit, den MessageLoop in einen Thread auszulagern und was ist der Grund wiso der MessageLoop nicht richtig funktioniert(sprich HOOKPROC wird nicht aufgerufen).

    Mfg

     

    ?

     

    Samstag, 5. Februar 2011 19:54

Alle Antworten

  • Hallo!

    Leider finde ich hier zZ nur MIcrosoft Money und keine Unterforen, weswegen ich das einfach mal auf gut glückposte ohne zu wissen wo es landet.

    Hi,

    bei allem Verständnis für lässige Naivität, aber wo soll es denn sonst landen? Wo Money drauf steht, ist Money drin.

    Such mal auf http://social.msdn.microsoft.com/Forums/de-DE/categories oder
    http://social.answers.microsoft.com/Forums/de-DE/categories nach dem
    passenden Forum.

    Gruß von der Schlei

    Uli


    www.hbcifm99.de
    Samstag, 5. Februar 2011 20:37
  • Stimmt schon. Danke für die LInks, werde dort nochmal posten. Aber mal ehrlich, wie sollte ich die Links die du mir gegeben hast sonst finden. Ich log mich ein erstell ein Profil und habe keinerlei Menue mit dem ich auf die von dir genannten seiten komme, ist schon scheisse. Mfg
    Samstag, 5. Februar 2011 20:50
  • Stimmt schon. Danke für die LInks, werde dort nochmal posten. Aber mal ehrlich, wie sollte ich die Links die du mir gegeben hast sonst finden.


    Ich hab sie bei http://www.google.de gefunden. Dir bekannt? ;-))

    Spaß beiseite, prinzipiell hast Du schon Recht, dass die Struktur der Foren komplett in die Hose gegangen ist. Die alten Newsgroups waren deutlich übersichtlicher.

    Gruß von der Schlei

    Uli

     


    www.hbcifm99.de
    Samstag, 5. Februar 2011 21:06