locked
Email Router not Deleting Emails after Processing

    Frage

  • Hello,

    We are on CRM 2013 on-premise. We are using the CRM email router to automatically create email activities for every email that arrives in a shared group mailbox. 

    In the Mailbox setting, we set the option to 'Delete Emails after Processing' so that to avoid build-up of emails in Exchange.

    However the emails are never deleted from Exchange, even after I restarted the Email Router service a few times.

    Any idea why the emails are not being deleted?

    Thanks,

    -tri

    Donnerstag, 12. November 2015 20:20

Antworten

  • Hi,

    Yes we have to run a powershell script such as below to send to a forward mailbox with -DeleteMessage function:

    New-InboxRule -name 'ForwardAsAttach' -Mailbox mailbox@test.com -ForwardAsAttachmentTo ForwardMailbox -DeleteMessage $true

    -tri

    • Als Antwort markiert triangular Montag, 29. Januar 2018 19:29
    Montag, 29. Januar 2018 19:29

Alle Antworten

  • could be the shardmailboxtype, try it first with a users mailbox and see if this is happening there also

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Freitag, 13. November 2015 09:27
  • Thanks Daniel for the reply. Are you saying it's not working on a shared mailbox? 

    -tri

    Freitag, 13. November 2015 15:08
  • Actually I just tried on a user-owned mailbox and the emails are still not being deleted from Exchange even though the emails are created in CRM... I'm not seeing any error messages on the CRM Email router server that could be related to this.

    Any suggestions?

    Thanks much.

    -tri


    • Bearbeitet triangular Montag, 16. November 2015 20:09
    Montag, 16. November 2015 20:06
  • really hard to know without any logs

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Dienstag, 17. November 2015 08:50
  • Hello,

    Thanks all for the reply. We opened a case with MS support. Turned out this feature is not supported for the regular email router. It's only supported if using the server side synchronization, or if using the forward mailbox within the email router queue...

    Now we might still be able to use this feature but will have to modify the email router xml config file, and it's actually unsupported... I'm scratching my head to this answer... 

    Thanks, 

    -tri

    Donnerstag, 19. November 2015 03:52
  • Hello,

    Thanks all for the reply. We opened a case with MS support. Turned out this feature is not supported for the regular email router. It's only supported if using the server side synchronization, or if using the forward mailbox within the email router queue...

    Now we might still be able to use this feature but will have to modify the email router xml config file, and it's actually unsupported... I'm scratching my head to this answer... 

    Thanks, 

    -tri

    Hi, Can you find a solution for this problem?

    Montag, 29. Januar 2018 10:45
  • Hi,

    Yes we have to run a powershell script such as below to send to a forward mailbox with -DeleteMessage function:

    New-InboxRule -name 'ForwardAsAttach' -Mailbox mailbox@test.com -ForwardAsAttachmentTo ForwardMailbox -DeleteMessage $true

    -tri

    • Als Antwort markiert triangular Montag, 29. Januar 2018 19:29
    Montag, 29. Januar 2018 19:29