none
Update HBCI-Modul auf die Version 5.02.24 bricht ab

    Frage

  • Hallo,

    bei mir klappt das Update von der Version 5.01.28 auf die Version 5.02.24 nicht. Ich erhalte bereits beim Download folgenden Fehlerhinweis:

    Download von ...www.hbcifm99.de/iload.html?file=files/hbcifm99/... nicht möglich.

    Fehler beim Download von URL: ...www.hbcifm99.de/iload.html?file=files/hbcifm99/...

    Da beim Klick auf den Hilfe-Button ein Hinweis auf die Firewall kommt, habe ich testweise die Kaspersky-Firewall ausgeschaltet (womit sich die Windows-Firewall einschaltet). Keine Änderung. Da der Download der Kontoauszüge klappt, würde ich ein Firewall-Problem auch ausschließen. Was ist zu tun?

    OS: Windows 10 mit allen Updates

    Vorab vielen Dank,

    Uli Schäfer


    Lillebroer

    Freitag, 24. März 2017 17:43

Antworten

Alle Antworten

  • Moin Uli,

    installiere das Update manuell von meiner Website.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    • Als Antwort markiert Lillebroer Montag, 27. März 2017 18:20
    Freitag, 24. März 2017 18:36
  • Moin, moin,

    manuelle Installation des Updates hat geklappt. Abruf der Kontoauszüge auch.

    Allerdings erhalte ich einen sehr sehr langen Fehlerhinweis, wenn ich die Updateprüfung im Menü Hilfe manuell anstoße: "Verbindung zum Update Server ... nicht möglich.

    Vielleicht verschwindet dieser ja wieder, sobald ein neues Update erscheint.

    Vielen Dank und Grüße an die Schlei

    Auch Uli


    Lillebroer

    Montag, 27. März 2017 18:24
  • Allerdings erhalte ich einen sehr sehr langen Fehlerhinweis, wenn ich die Updateprüfung im Menü Hilfe manuell anstoße: "Verbindung zum Update Server ... nicht möglich.

    Vielleicht verschwindet dieser ja wieder, sobald ein neues Update erscheint.

    Das ist ein Problem mit dem Abruf über https:// und wird so nicht verschwinden. Lass bitte mal die Systemanalyse laufen und  kopiere die Ausgabe in Deine nächste Antwort. Schau auch bitte nach, was unter Extras/Update unter "Homepage" steht, erwartet wird "https://hbcifm99.de/". Ist dies der Fall teste den Zugriff auf die Homepage über den IE. Dann ändere diesen Wert in der Registry unter [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Uli Amann\HBCI-Modul für Money 99 V2000] auf "http://..." und teste es mit dem HBCI-Modul erneut aus und berichte bitte.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Montag, 27. März 2017 20:24
  • Hallo Ulli,

    habe das gleiche Problem allerdings bekomme ich auch das Update nicht mauell geladen. Download failed: An Error occured in the secure channel support. Check your connection and click "Retry" to try downloading the files again. Status: cannot connect

    Ursächlich kam als erstes der Fehler Verbindung zum Update-Server .... Die Registry (wie weiter unten beschrieben) passt und steht jetzt auf  http://  2 mal Kaltstart aber trotzdem kein Erfolg. Auszüge abrufen bis auf das Thema Update kein Problem.

    Über Chrome und Chromodo kann ich die Seite https://www.hbcifm99.de/home.html aufrufen, über IE und Firefox nicht...

    Update:Im Firefox geht es jetzt auch, nachdem Cache und Cookies gelöscht wurden. IE noch nicht, aber andere Seiten z.B. https://www.google.de/ funktionieren auch bei IE. Also Problem im IE trotz löschen von cache und Cookies?

    Firewall ist Windows Firewall, aber auch wenn ich den ausschalte funktioniert es nicht.

    Allerdings versucht er im Bereich der Updates auch immer noch über https:// zu zu greifen. Zeigt er zumindest an.

    BS.: Windows XP alle SP's

    Was kann ich jetzt noch tun?


    • Bearbeitet Ultra05 Donnerstag, 30. März 2017 12:17
    Donnerstag, 30. März 2017 10:00
  • Chrome und Firefox verwenden eigene SSL- und TLS-Komponenten. Der Installer und auch die Updatefunktion des HBCI-Moduls hingegen verwenden die Komponenten und Einstellungen des IE, da muss unter internet-Optionen/Erweitert/Sicherheit TLS und SSL aktiviert sein.

    Klappt es dennoch nicht, musst Du nach dem Fehler Deiner XP-Installation googeln, der ja offensichtlich bei Dir vorliegt. Ob sich das lohnt, solltest Du nach Lesen von https://www.hbcifm99.de/nachrichten/keine-verbindung-zur-bank-unter-windows-xp-und-vista.html entscheiden.

    Ist Dir das alles egal, kannst Du die DDBAC-Komponenten über den Firefox laden und installieren und dann die PR-Version von meiner Website installieren. Die Update-Kontrolle geht wiederum nur mit möglichem https://-Zugriff über den IE, die also abschalten, wenn Du es nicht hinkriegst.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Donnerstag, 30. März 2017 14:30
  • Hallo Ulli,

    danke für die schnelle Antwort. Den Setup_Loader kann ich laden (Firefox) kein Problem. Wenn ich Ihn aber ausführe kommt die Meldung:

    Download failed: A Connection wit the Server could not be established.

    Ach ja, meine "Sparkasse_XXXXX.VBS" ist auch nicht mehr da. Wie kriege ich die wieder erstellt? Nur mit dem Setup?

    Grüße an die Schlei (wo ich mal 2 Jahre stationiert war ;-)


    • Bearbeitet Ultra05 Freitag, 31. März 2017 13:01
    Freitag, 31. März 2017 12:59
  • Du solltest genauer lesen, ehe Du loslegst:

    1. SSL/TLS überprüfen! Was kam das raus?
    2. DDBAC manuell laden und installieren
    3. PR-Version installieren, (die hat keinen Setup-Loader)
    4. Wenn https:// nicht funktioniert Updatekontrolle deaktivieren!
    5. VBS wird erstellt über Einstellungen/Banken/"Abfrage über Money ermöglichen"
    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Freitag, 31. März 2017 17:37
  • Ich hatte geprüft, bloss nicht explizit noch mal geschrieben...

    1. ist geprüft und steht alles richtig, Häckchen sitzen

    2. auch bei existenter DDBAC?

    3. Dann bin ich wohl zu blöd die PR-Version zum download zu finden. Von deiner Homepage bekomme ich immer als erstes den hfm_setuploader.exe wenn ich den doppelt klicke kommt es zu obiger Fehlermeldung. Außerdem schreibst du selber: Die Installation ist daher in zwei Schritte unterteilt. Das erste Setup prüft die Systemvoraussetzungen und lädt dann die eigentliche passende Setupversion vom Server. (Genau dieser passende Setup läuft nicht)

    4. habe ich deaktiviert

    5. Hat geklappt, vielen Dank

    Samstag, 1. April 2017 08:52
  • Ich hatte geprüft, bloss nicht explizit noch mal geschrieben...

    1. ist geprüft und steht alles richtig, Häckchen sitzen
    2. auch bei existenter DDBAC?
    3. Dann bin ich wohl zu blöd die PR-Version zum download zu finden. Von deiner Homepage bekomme ich immer als erstes den hfm_setuploader.exe wenn ich den doppelt klicke kommt es zu obiger Fehlermeldung. Außerdem schreibst du selber: Die Installation ist daher in zwei Schritte unterteilt. Das erste Setup prüft die Systemvoraussetzungen und lädt dann die eigentliche passende Setupversion vom Server. (Genau dieser passende Setup läuft nicht)
    4. habe ich deaktiviert
    5. Hat geklappt, vielen Dank

    1. Immer bestätigen, woher soll ich das sonst wissen?
    2. Immer aktualisieren, sonst wird das vom Setup übernommen, und das geht ja bei Dir schief...
    3. Suchfunktion der Website "Pre-Release" ausprobiert?

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Samstag, 1. April 2017 15:44
  • Hallo Uli,

    hier ist das Ergebnis der Systemanalye. Die Bankleitzahlen meiner Konten habe ich unkenntlich gemacht:

    Money 99V2000 & HBCIFM99 Systemprüfung 1.23 Stand 03.04.2017 16:59:51
    OS Version: Windows 10 Home (ohne SP) 64bit
    Windir: C:\WINDOWS
    Appdata: C:\Users\Schae\AppData\Roaming
    Explorer Version: 10.0.14393.953
    Internet Explorer version: 11.0.14393.953
    Locale: 1031
    Regionsoptionen korrekt für Deutschland eingestellt
    CommonFilesDir: C:\Program Files (x86)\Common Files
    CommonFilesDir (x86): C:\Program Files (x86)\Common Files
    Money Version: 7.0.0.723
    Money LCID: 1031
    Money SKU: SuiteB
    mfc42.dll Version im Money-Verz.: C:\Program Files (x86)\Microsoft Money\mfc42.dll nicht gefunden (OK)
    mfc42.dll Version im Windows-Verz.: 6.6.8063.0
    vipzka.exe Version: 3.0.0.54 (Money 99V2000 SP1 Decoder)
    HBCIFM99 Version: 5.0.2.24
    DDBAC Version: 5.6.22.0
    DDBAC Dir: C:\Users\Schae\AppData\Roaming\DataDesign\DDBAC
    MDAC Version : 6.3.9600.16384 (unbekannte MDAC)
    Jet 3.5 Version: 3.51.3328.0
    Jet 4.0 Version: 4.0.9765.0 (unbekannter SP)
    ODBC Jet Version: 10.0.14393.0
    Älteste Datei im Money-Ordner: MPBDGT.DLL 14.03.1999 23:00:00 (OK)
    MS Setup Registry Key zeigt korrektes MS Money 99V2000 Plus (OK)
    QuoteServerURL: http://data.moneycentral.msn.com/Scripts/invisapi.dll/ (OK)
    Alte Registry Werte sind entfernt. (OK)
    SmrtInetURL: https://www.hbcifm99.de/smrtinet.ini (unbekannt)
    Kein LAN-Proxy konfiguriert
    Windows Firewall ist eingeschaltet
    Antivirus Kaspersky Internet Security ProductState 266240 aktiv, aktuell
    Antivirus Windows Defender ProductState 393472 nicht aktiv, aktuell
    Firewall Kaspersky Internet Security ProductState 266256 aktiv, updaten
    AntiSpyware Kaspersky Internet Security ProductState 266240 aktiv, aktuell
    AntiSpyware Windows Defender ProductState 393472 nicht aktiv, aktuell
    Kontakt 0: PSD Bank (PSD Bank) BLZ XXX HBCI 300 CommAddr https://hbci11.fiducia.de/cgi-bin/hbciservlet SecProgID TAN PINTAN ITanSupported ITANVerf. 942 S-Fkt 942
    Kontakt 1: Raiffeisenbank (Raiffeisenbank) BLZ XXX HBCI 300 CommAddr hbci01.fiducia.de SecProgID RDH.1 MediaFile

    Unter Extras/Update/Einstellungen steht folgende Homepage:

    https://www.hbcifm99.de/

    Der Zugriff mit IE, aber auch Edge und Firefox klappt.

    Nachdem ich in der Registry den Wert auf http geändert hatte, funktionierte die Update-Prüfung.

    Sorry, dass ich erst so spät antworte, ich habe aber keine Benachrichtigung über Deine Antwort erhalten, obwohl ich den Button angekreuzt hatte. Der Spam-Ordner enthielt auch nichts.

    Schöne Grüße aus Würzburg

    Uli Schäfer


    Lillebroer

    Montag, 3. April 2017 15:17
  • hier ist das Ergebnis der Systemanalye. Die Bankleitzahlen meiner Konten habe ich unkenntlich gemacht:
    ..
    Unter Extras/Update/Einstellungen steht folgende Homepage:
    https://www.hbcifm99.de/
    Der Zugriff mit IE, aber auch Edge und Firefox klappt.

    Nachdem ich in der Registry den Wert auf http geändert hatte, funktionierte die Update-Prüfung.

    Das ist nicht Ziel der Übung. Ich habe ja aus Sicherheitsgründen auf https:// umgestellt. Den fakultativen (unverschlüsselten) Zugriff über http:// will ich irgendwann (eigentlich schon vorgestern) deaktivieren. Ich kann in der Systemanalyse außer vielleicht einem übereifrigen Kaspersky auch keinen Grund erkennen, warum das bei Dir nicht klappen soll. Ich habe alle meine Update- und Download-Funktionen (Normal, Beta, PR) unter Windows 8.1 und 10 getestet und es lief überall problemlos.

    Lösche bitte den IE-Cache manuell, prüfe SSL- und TLS-Einstellungen, stelle die HP in der Registry wieder auf https:// und teste es erneut aus. Deaktiviere im Fehlerfall auch mal das Kaspersky-Geraffel.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Dienstag, 4. April 2017 10:43
  • Moin Uli,

    ich habe das gleiche Problem: Mit http in der registry funktioniert es, mit https nicht. Habe alle Deine Tipps ausprobiert, und das Sicherheits-Geraffel inkl. Windows Firewall ausgeschaltet. Leider ohne Erfolg.

    Mein Ergebnis der Systemanalyse:

    Money 99V2000 & HBCIFM99 Systemprüfung 1.23 Stand 08.04.2017 13:25:49
    OS Version: Windows 10 Pro (ohne SP) 64bit
    Windir: C:\WINDOWS
    Appdata: C:\Users\Werner\AppData\Roaming
    Explorer Version: 10.0.14393.953
    Internet Explorer version: 11.0.14393.953
    Locale: 1031
    Regionsoptionen korrekt für Deutschland eingestellt
    CommonFilesDir: C:\Program Files (x86)\Common Files
    CommonFilesDir (x86): C:\Program Files (x86)\Common Files
    Money Version: 7.0.0.723
    Money LCID: 1031
    Money SKU: SuiteB
    mfc42.dll Version im Money-Verz.: C:\Program Files (x86)\Microsoft Money\mfc42.dll nicht gefunden (OK)
    mfc42.dll Version im Windows-Verz.: 6.6.8063.0
    vipzka.exe Version: 3.0.0.54 (Money 99V2000 SP1 Decoder)
    HBCIFM99 Version: 5.0.2.24
    DDBAC Version: 5.6.22.0
    DDBAC Dir: C:\Users\Werner\AppData\Roaming\DataDesign\DDBAC
    MDAC Version : 6.3.9600.16384 (unbekannte MDAC)
    Jet 3.5 Version: 3.51.623.4
    Jet 4.0 Version: 4.0.9765.0 (unbekannter SP)
    ODBC Jet Version: 10.0.14393.0
    Älteste Datei im Money-Ordner: MPBDGT.DLL 15.03.1999 (OK)
    MS Setup Registry Key für keine bekannte MS Money Version gefunden
    QuoteServerURL: http://data.moneycentral.msn.com/Scripts/invisapi.dll/ (OK)
    Alte Registry Werte sind entfernt. (OK)
    SmrtInetURL: https://www.hbcifm99.de/smrtinet.ini (unbekannt)
    Kein LAN-Proxy konfiguriert
    Windows Firewall ist eingeschaltet
    Antivirus Avast Antivirus ProductState 266240 aktiv, aktuell
    Antivirus Windows Defender ProductState 393472 nicht aktiv, aktuell
    AntiSpyware Windows Defender ProductState 393472 nicht aktiv, aktuell
    AntiSpyware Avast Antivirus ProductState 266240 aktiv, aktuell
    Keine Firewall erkannt.
    Kontakt 0: ...
    Kontakt 1: ...

    Viele Grüße aus Uelzen an die Schlei

    Werner

    Samstag, 8. April 2017 11:40
  • Moin Uli,

    ich habe das gleiche Problem: Mit http in der registry funktioniert es, mit https nicht. Habe alle Deine Tipps ausprobiert, und das Sicherheits-Geraffel inkl. Windows Firewall ausgeschaltet. Leider ohne Erfolg.

    Das Skript ist ok und die Windows-FW hat hier auch noch nie Probleme gemacht. Entscheidend ist der IE. Hier musst Du https://www.hbcifm99.de aufrufen können, was bisher unter Windows 7 und höher lediglich durch den Cache oder geänderte SSL/TLS-Einstellungen verhindert wurde. Hast Du den Cache im IE auch wirklich gelöscht?

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Sonntag, 9. April 2017 07:11
  • Hallo,

    als Frischling werde ich mir jetzt vielleicht jetzt ein paar einfangen, aber wäre es für ein händisches Update nicht die Lösung keinen Setuploader mit den TSL Routinen des IE zu verwenden sondern ein eigenständiges Setupprogramm in dem alle Daten schon enthalten sind und das man mit z.B. mit Firefox (das eigenständige TSL Routinen hat) runterladen kann. Das hätte den Vorteil, daß auch Leutchen die noch XP verwenden auch in den Genuß der Updates kommen könnten (nur halt nicht automatisch). Muß aber zugeben, daß ich keine Ahnung vom Aufwand eines solchen Setupprogramms habe und auch nicht ob andere schwerwiegende Nachteile (hoher Datentransfer) damit einhergehen.

    LG

    Hubert

    Montag, 10. April 2017 11:31
  • Moin,

    na klar gehört zu "habe alle Deine Tipps ausprobiert" auch, dass ich den IE Cache gelöscht und mit Erfolg getestet habe, ob ich mit dem IE Deine Webseite per https aufrufen kann. Wir können aber gerne noch mal abgleiche, ob ich es richtig gemacht habe: Internetoptionen/Allgemein/Browserverlauf - Klick auf Löschen, alle Optionen auswählen, Klick auf Löschen. Erhalte Bestätigung "Der ausgewählte Browserverlauf wurde gelöscht". Kontrolle: Internetoptionen/Allgemein/Browserverlauf  - Klick auf Einstellungen, die Tabseite "Caches und Datenbanken" zeigt nix an. Auch die Schaltflächen der Tabeseite "temporäre Internetdateien" decken keine gecachten Seiten mehr auf.
    Passt das?

    Gruß aus Hameln

    Werner

    Montag, 10. April 2017 19:21
  • als Frischling werde ich mir jetzt vielleicht jetzt ein paar einfangen,
    ..
    aber wäre es für ein händisches Update nicht die Lösung ... ein eigenständiges Setupprogramm in dem alle Daten schon enthalten sind
    ..
    und auch nicht ob andere schwerwiegende Nachteile (hoher Datentransfer) damit einhergehen.

    Moin Hubert,

    Du fängst Dir natürlich sowas von keine ein...;-) Deine Frage ist schon berechtigt, aber leider nicht so einfach zu lösen. Abgesehen davon, dass ich die DDBAC nicht in das Setupprogramm einbinden darf, habe ich natürlich ein Limit auf meinem Internetpaket, daher muss der dynamische Download einfach funktionieren.

    Ich überlege schon an anderen Lösungen für die wenigen XP-Anwender. Da sich aber kaum jemand meldet fehlt mir noch der Überblick über die XP-Userzahl, um zu entscheiden, wie umfangreich ich das machen soll. Zumal mit XP und Vista sowieso in absehbarer Zeit beim flächendeckenden Umstieg der Banken auf TLS 1.2 das Ende naht.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Dienstag, 11. April 2017 07:44
  • Moin,

    na klar gehört zu "habe alle Deine Tipps ausprobiert" auch, dass ich den IE Cache gelöscht und mit Erfolg getestet habe, ob ich mit dem IE Deine Webseite per https aufrufen kann. Wir können aber gerne noch mal abgleiche, ob ich es richtig gemacht habe: Internetoptionen/Allgemein/Browserverlauf - Klick auf Löschen, alle Optionen auswählen, Klick auf Löschen. Erhalte Bestätigung "Der ausgewählte Browserverlauf wurde gelöscht". Kontrolle: Internetoptionen/Allgemein/Browserverlauf  - Klick auf Einstellungen, die Tabseite "Caches und Datenbanken" zeigt nix an. Auch die Schaltflächen der Tabeseite "temporäre Internetdateien" decken keine gecachten Seiten mehr auf.
    Passt das?

    Gruß aus Hameln

    Werner

    meine Erfahrung bei der Formulierung "..alle Tipps ausprobiert.." ist nunmal eine andere, daher frage ich immer die Details ab.
    Zu Deiner Fehlermeldung kann ich leider auch nur raten:

    1. Du hast nur Probleme bei der Updatekontrolle, also beim Laden der Versionsinformationen aus dem HBCI-Modul heraus?
    2. Das Setup auf die 5.0.2.24 ging noch aus der alten Version heraus, da zu dem Zeitpunkt der Eintrag http:// lautete?
    3. Die DDBAC 5.6.22.0 wurde über das Setup geladen?

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Dienstag, 11. April 2017 08:02
  • Hallo Uli,

    freut mich, daß ich so freundlich aufgenommen werde. Wir verbliebenen XP Nutzer, und ich denke es werden schon noch etliche sein, würden uns sehr über eine möglichst einfache für Dich zu realisierende Lösung freuen. Wir laden auch das DDBAC selber herunter. Ich bin etwas erstaunt zu hören, daß DDBAC die IE TSL Routinen nutzt aber das ist, wenn ich richtig informiert bin, ja auch ein Club von vielen freiwilligen Helfern und somit sind die Resourcen wohl überschaubar.

    Jede Lösung, sei Sie auch noch so arbeitsintensive bei der Anwendung, ist besser als keine Lösung und vielleicht ist es für die, die zwar Win7 oder höher haben, mit Problemen mit dem automatischen Update auch ein workaround.

    LG

    Hubert

    Dienstag, 11. April 2017 12:48
  • Hallo Uli,

    jede der drei Fragen kann ich mit "Ja" beantworten.

    Kann es daran liegen, dass ich die Updates nur von einem Benutzerkonto ohne Adminrechte starte? Seit Win7 ist das meine präferierte PC Nutzung.
    Führt aber bei Installation von DDBAC immer dazu, dass die Installationsroutine am Ende "meckert", dass keine Banking Kontakte vorhanden sind. Habe ich im Admin-Konto halt nicht eingerichtet...

    Gruß

    Werner

    Dienstag, 11. April 2017 19:08
  • Moin Werner,

    Kann es daran liegen, dass ich die Updates nur von einem Benutzerkonto ohne Adminrechte starte? Seit Win7 ist das meine präferierte PC Nutzung.

    Das kann ich hier nicht nachvollziehen, und auch in der Betatest-Gruppe arbeiten fast alle nur mit Standardrechten und keiner hat dazu Fehler berichtet...

    Führt aber bei Installation von DDBAC immer dazu, dass die Installationsroutine am Ende "meckert", dass keine Banking Kontakte vorhanden sind. Habe ich im Admin-Konto halt nicht eingerichtet...

    Das Setup führt über die Funktion 'ShellExecAsOriginalUser' eine Größenprüfung der ddusers.dat und den Aufruf des HBCI-Admins in der Umgebung und mit den Rechten des angemeldeten Users und nicht des Setup-Admin-Kontos durch. Hier unter Win 8.1 habe ich das eben mittels Download von der Website und manuellen Setup einwandfrei testen können. Wenn ich dann im Setup am Ende den HBCI-Admin manuell starte, wird mir der unter dem User angelegte Testkontakt korrekt angezeigt. Kannst Du das bitte auch mal ausprobieren?

    Läuft das HBCI-Modul oder Money bei Dir in irgendeinem Kompatibilitätsmodus?

    Kannst Du im IE https://www.bs-ag.com/index.php/produkte/ddbac öffnen?

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml



    • Bearbeitet Uli Amann Mittwoch, 12. April 2017 11:27
    Mittwoch, 12. April 2017 11:24
  • Kannst Du im IE https://www.bs-ag.com/index.php/produkte/ddbac öffnen?

    Ja

    Mittwoch, 12. April 2017 19:48
  • Läuft das HBCI-Modul oder Money bei Dir in irgendeinem Kompatibilitätsmodus?

    Nein.

    Mittwoch, 12. April 2017 19:51
  • Das Setup führt über die Funktion 'ShellExecAsOriginalUser' eine Größenprüfung der ddusers.dat und den Aufruf des HBCI-Admins in der Umgebung und mit den Rechten des angemeldeten Users und nicht des Setup-Admin-Kontos durch. Hier unter Win 8.1 habe ich das eben mittels Download von der Website und manuellen Setup einwandfrei testen können. Wenn ich dann im Setup am Ende den HBCI-Admin manuell starte, wird mir der unter dem User angelegte Testkontakt korrekt angezeigt. Kannst Du das bitte auch mal ausprobieren?

    Moin Uli,

    welches Setup und welche Website meinst Du?

    a) https://www.bs-ag.com/index.php/produkte/ddbac und ddbac?

    b) https://www.hbcifm99.de/Download-aktuell.html und hfm_setuploader.exe?

    Wie auch immer, in beiden Fällen ist eine Installation mit den Rechten des angemeldeten Benutzers nicht möglich, sondern es muss ein Admin-Konto angegeben werden. Im Falle b erfolgt dann der download an dessen Ende nach meiner Wahl dann hfm5.exe gestartet wird. Da wird dann für HBCI-Modul und DDBAC jeweils erneut ein Admin-Konto verlangt.

    Klingt irgendwie gar nicht nach dem, was Du so beschreibst.

    Aber kann das Problem bei der Updatekontrolle denn etwas damit zu tun haben?

    Gruß

    Werner

    Mittwoch, 12. April 2017 20:05
  • Das Setup führt über die Funktion 'ShellExecAsOriginalUser' eine Größenprüfung der ddusers.dat und den Aufruf des HBCI-Admins in der Umgebung und mit den Rechten des angemeldeten Users und nicht des Setup-Admin-Kontos durch. Hier unter Win 8.1 habe ich das eben mittels Download von der Website und manuellen Setup einwandfrei testen können. Wenn ich dann im Setup am Ende den HBCI-Admin manuell starte, wird mir der unter dem User angelegte Testkontakt korrekt angezeigt. Kannst Du das bitte auch mal ausprobieren?

    b) https://www.hbcifm99.de/Download-aktuell.html und hfm_setuploader.exe?

    Wie auch immer, in beiden Fällen ist eine Installation mit den Rechten des angemeldeten Benutzers nicht möglich, sondern es muss ein Admin-Konto angegeben werden. Im Falle b erfolgt dann der download an dessen Ende nach meiner Wahl dann hfm5.exe gestartet wird. Da wird dann für HBCI-Modul und DDBAC jeweils erneut ein Admin-Konto verlangt.

    Klingt irgendwie gar nicht nach dem, was Du so beschreibst.

    Aber kann das Problem bei der Updatekontrolle denn etwas damit zu tun haben?

    Ich rede vom Setup des HBCI-Moduls, also b), welches den HBCI-Admin aufruft. Die dabei durchgeführte Installation der DDBAC erfolgt selbst ohne Meldungen. Natürlich muss man bei einer Installation als Standardbenutzer sich über ein Admin-Konto einloggen. Wie aber oben beschrieben, soll während der Installation des HBCI-Moduls die DDAC-Konfiguration des Benutzers und nicht des Admins geprüft werden, was bei mir - wie ebenfalls oben beschrieben - funktioniert.

    Bei mir und den anderen Usern mit Standardinstallationen von Win 7 -10 gibt es keine Probleme. Meine Bitte um einen Installationsversuch über den direkten Download von meiner Website soll Erkenntnis darüber geben, ob bei Dir ein Unterschied zum Update aus dem HBCI-Modul heraus besteht.

    Kannst Du bitte noch folgende Tests machen, um eventuell eine fehlerhafte Konfiguration Deines aktuellen Bneutzerkontos zu erkennen:

    1. einen neuen Standardbenutzer anlegen, eine manuelle Installation des HBCI-Moduls durchführen und während der Installation einen Kontakt anlegen. Dann das HBCI-Modul aufrufen und die Updateprüfung hieraus durchführen.
    2. Anschließend als Admin anmelden und die Schritte erneut durchführen.

    Kommen hier die gleichen Fehler, oder klappt es darunter.

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml


    • Bearbeitet Uli Amann Mittwoch, 12. April 2017 21:24
    Mittwoch, 12. April 2017 21:21
  • Moin Uli,

    folgende Erkenntnisse:

    Test 1: Auch mit neuem Standardbenutzer funktioniert das Update nicht nach "manuelle Installation des HBCI-Moduls durchführen und während der Installation einen Kontakt anlegen. Dann das HBCI-Modul aufrufen und die Updateprüfung hieraus durchführen"

    Test 2: Als Admin klappt Updateprüfung nach erneuter Durchführung der o. a. Schritte.

    Damit scheint es doch einen Zusammenhang mit den Rechten zu geben. Das einzige, was mir sonst noch einfällt wäre, dass ich Money gemäß Installation als Windows XP Administrator installiert habe.

    Beste Grüße

    Werner

    Dienstag, 18. April 2017 19:19
  • Damit scheint es doch einen Zusammenhang mit den Rechten zu geben. Das einzige, was mir sonst noch einfällt wäre, dass ich Money gemäß Installation als Windows XP Administrator installiert habe.

    Du hast doch Windows 10 drauf. Was heißt jetzt "als XP-Administrator"? Hast Du das Money-Setup im XP-Kompatibilitätsmodus durchgeführt?

    Welche User haben Schreibrechte im Verzeichnis "%ALLUSERSPROFILE%\Uli Amann\HBCI-Modul für Money 99 V2000\"

    Gruß von der Schlei
    Uli
    --
    https://www.hbcifm99.de/

    https://www.hbcifm99.de/share/hbcifm99atom.xml

    Dienstag, 18. April 2017 19:43
  • Moin Uli,

    war leider durch einen Infekt verhindert, eine zeitnahe Antwort zu senden. Hat eigentlich schon jemand einen Virenscanner für Menschen erfunden? 

    Mit Installation als Windows XP Administrator wollte ich auf die Anleitung in den FAQ von G. Vogt verweisen, entlang derer ich die Installation eben als Administrator und nicht als Benutzer mit temporären Admin-Rechten durchgeführt habe.

    Ja, ich habe Win10. Allerdings habe ich Money auf zwei Win10 Rechnern installiert. Beide Money-Installationen verhalten sich bezüglich der Updateprüfung identisch. Die Win10-Version des Desktoprechners ist durch eine Upgrade einer Win7-Version entstanden. Auf dem Laptop habe ich vor kurzem ein Clean-Install von Win10 (und Money und hbcifm99) gemacht. 

    Alle Benutzer haben Vollzugriff auf "%ALLUSERSPROFILE%\Uli Amann\HBCI-Modul für Money 99 V2000\".

    Gruß aus dem sonnigen aber kalten Uelzen

    Werner

    Mittwoch, 26. April 2017 09:17
  • Nachtrag: Kein XP-Kompatibilitätsmodus, weder bei install noch bei run.
    Mittwoch, 26. April 2017 09:47
  • Hallo Uli,

    habe ich Dich jetzt angesteckt und Du hast den Infekt?

    Oder hast Du das Thema ad acta gelegt? Dafür hätte ich Verständnis, wenn Du die Situation nicht nachbilden kannst.

    Gibt doch bitte noch mal eine Rückmeldung.

    Beste Grüße

    Werner

    Donnerstag, 11. Mai 2017 20:28