none
Getting real time HPC Reports on Cluster Manager UI

    Question

  • Dear all,

    We have integrated Windows HPC 2012 in one of our projects in last year, and it’s been working pretty good. Our team has been using Windows HPC reporting capabilities to perform some monitoring and job execution trends. However, we are facing one issue. All of our report display information which is currentTime-90 minutes old. This implies that somewhere HPC is pushing the data to reporting DB with 90 minutes delay. Is there any configuration setting which can allow us to change this 90 minutes threshold so that we can see near real-time information on the reports. Please help us out here.

    Puneet Sharma

    Tuesday, 7 August 2018 3:57 PM

All replies

  • Hi Puneet,

      Which reports are you referring to?

      The Monitoring Charts should be real time. While the reports are generated for "Day", "Week" and "Month". Thus I don't understand how you got the 90 minutes delay perception. And the reports are 

      And for our reporting service, it has EtlJobDelaySeconds which is set to 1 hour as default. You could change by providing parameter for the reporting service:

    the parameter you can give is: -j <EtlJobDelaySeconds>


    Qiufang Shi

    Wednesday, 8 August 2018 5:17 AM
  • Hi Quifang,

    The records in [HPCReporting].[dbo].[JobHistory] tables are not populated in the real time. They have more than an hour lag. I believe EtlJobDelaySeconds should fix that problem. Please let us know. Also, let us know how to apply this parameter. Are there any configuration settings we need to update? 



    Puneet Sharma


    Tuesday, 14 August 2018 7:40 PM
  • Check below to add the parameter for your reporting service. Please try delay 5~10 minutes to see whether it works for you.


    Qiufang Shi

    Wednesday, 15 August 2018 8:49 AM
  • Hi Qiufang,

    I tried providing the parameter with the same method you have mentioned above. Nothing happens, I can still see a lag (around an hour) between my jobs submit time, and by the time they appear in JobHistory table. I wonder what might be wrong here.


    Puneet Sharma

    Wednesday, 15 August 2018 3:04 PM
  • Sorry for my careless, just checked the code, the parameter should be:

    -j:300

    instead of -j 300


    Qiufang Shi

    Thursday, 16 August 2018 3:07 AM
  • Hi Qiufang,

    I tried providing -j:300 to the service and checked. Still nothing happens and I don't see JobHistory table updated in 5 minutes. I wonder what's wrong.


    Puneet Sharma

    Thursday, 16 August 2018 1:12 PM
  • Hi Sharma,

      after this setting, you will see the delay of less than 20 minutes as:

    - Aggregation interval is timerIntervalSeconds=15*60 (default value)

    - EtlJobDelaySeconds now is being set to 300 seconds

    If you want to further reduce the this time, you could try:

    -j:60 -t:240

    This way, all jobs will be updated within 5 minutes.


    Qiufang Shi

    Tuesday, 21 August 2018 2:15 AM
  • Hi Qiufang,

    I tried following your suggestions but there is still an hour lag between my job completion time and job history table update. Basically I don't see any difference after providing these parameters. I wonder what I am doing wrong. Below is what i do

    1. Go the head node, open services, and right click on "HPC Reporting Service" and select Properties.

    2. First I "Stop" the service.

    3. Then I supply -j:60 -t:240 parameters to the service in "Start parameters:" text box.

    

    4. I Start the service.

    5. I schedule few quick jobs on HPC, and keep checking  JobHistory table.

    6. System populate the above job records after an hour or so in the Job History Table

    I wonder if my steps are correct or not.


    Puneet Sharma

    Tuesday, 21 August 2018 6:56 PM
  • Hi Sharma, I will take a check further

    Qiufang Shi

    Thursday, 23 August 2018 1:20 AM