none
Install of HPC Pack 2016 failing with Component Routing And Remote Access service cannot be installed with error code 1. Incorrect function.

    Question

  • Hello, 

    I am supporting an application which has a prerequisite of MS HPC Pack 2016. An earlier version of this application was running on HPC Pack 2012 Update 1.

    I have attempted to install on the head node server. That server is Windows Server 2012 R2 with .Net 4.7.1, 16 RAM, Xeon E5 2.20 Ghz, and IIS 8.5.9600. 

    I've tried running the install both from a network share and from a local drive. Both yield the same error when the installation gets to Routing And Remote Access. The installation fails on this steps with the error message, "Component Routing And Remote Access service cannot be installed with error code 1. Incorrect function.". I can find almost nothing available on what this error code is or how to address it. 

    Any tips on where I can look or what I can do to address the situation? 

    Thanks very much, David



    Wednesday, 7 November 2018 4:47 PM

All replies

  • Hi David,

      Could you try to install the Routing and Remote access service by yourself before you install HPC Pack? This is the component we try to enable during setup. If it is already enabled on the server, we will skip and proceed.

      And one of the know issue that during network configuration, you shall not enable "NAT" option. you can enable NAT by yourself in the system: https://docs.microsoft.com/en-us/powershell/high-performance-computing/release-notes-for-hpc-pack-2016-update-2?view=hpc16-ps


    Qiufang Shi

    Wednesday, 7 November 2018 5:33 PM