none
Compute node deployment in HPC Pack 2016 not working

    Question

  • I'm in the process of testing HPC Pack 2016 Update 1 in our lab environment - I've used previous iterations of HPC Pack, so I expected this to be fairly simple.  However, I've hit a few snags:

    - Using a new Node Template, accepting all defaults, I wasn't able to deploy a node - I keep getting a very unhelpful "Object reference not set to an instance of an object" error.  Through some trial and error, I found that the error is generated when the template tries to install HPC Pack on the node.  It's properly set to "ComputeNode", and the source directory is also correct.  If I go into the node after install and manually try to install HPC Pack interactively, it works fine.  Any ideas?

    - I noticed that HPC Pack 2016 doesn't have its own toolset.  I use Lizard extensively for HPL validation after installing the cluster, but the current version of Lizard only supports HPC Pack 2012R2.  Any ideas?

    I've tried to go down the path with Microsoft support, but it's been three months (yes, three months).  Good thing this is just a lab test, but I've got clients who really want to use Server 2016.  

    Appreciate any help you can provide would be helpful!

    Friday, 27 April 2018 3:02 PM

Answers

  • Hi,

      As you can see, we added Linux nodes in HPC Pack, but the diagnostics test won't work for the linux nodes at all. Thus we currently already have a project enabling diagnostics for linux nodes, the lizard work going forward will be included in that as well. We will try to bring that with HPC Pack post update 2.


    Qiufang Shi

    Thursday, 21 June 2018 2:40 AM

All replies

  • Hi, 

    Are you using the bare metal deployment feature(i.e. assign a node to node template with image)?

    If so, goto "Deployment To-do List" -> "Import a certificate for deployment" to import a certificate first. Because since HPC Pack 2016 on, certificate is needed for all HPC nodes to secure the communication.

    Saturday, 28 April 2018 1:40 AM
  • Thanks - I created a self-signed cert during the initial install, after importing the cert it worked normally. 

    Any input on the toolset for HPC Pack 2016?  I use Lizard to validate the cluster extensively, and we really can't release it to the client without some kind of validation.  I applied the latest Update 1 patches from May 28th, but the update didn't add any workable diagnostic tests or validation tools.

    Tuesday, 19 June 2018 5:17 PM
  • Hi,

      As you can see, we added Linux nodes in HPC Pack, but the diagnostics test won't work for the linux nodes at all. Thus we currently already have a project enabling diagnostics for linux nodes, the lizard work going forward will be included in that as well. We will try to bring that with HPC Pack post update 2.


    Qiufang Shi

    Thursday, 21 June 2018 2:40 AM
  • Any idea when update 2 will be released?
    Wednesday, 25 July 2018 10:49 PM
  • Hi,

      HPC Pack 2016 update 2 is postponed to this September. We are now in phase of reliability  testing, stressing


    Qiufang Shi

    Friday, 27 July 2018 3:13 AM