none
Local login problem for users on WinServer 2012 with HPC pack

    Question

  • On a windows server 2012 where HPC pack is installed (total 4 windows server nodes that one of them is head), I have created an active directory user on the head node. However, he can not login in locally and gets the following error

    the sign-in method you're trying to use isn't allowed

    The solution is to open "local security policy"->"local policies"->"user rights assignment"

    I want to know is that really important? How the users connect to the cluster?




    • Edited by mahmoodn Wednesday, 25 April 2018 4:56 PM
    Monday, 23 April 2018 6:12 PM

All replies

  • Hi,

      There should be two "user" involved. Job Owner and Job Runas User. Usually they are the same account for your user.

      In order for your user to connect to the cluster and submit the job, he needs to be added to the Cluster User (In the Cluster Manager GUI -->Users). the job owner will be the account who connect to the cluster and do the submit.

      During job submission, your user also need to provide a credential to run the job. This runas credential will be used when the task is executed on the compute nodes. And this account requires "local logon" permission. This is the one you specified.

      Thus usually your user will use a same account for job owner and job runas, the account requirement will be:

    - added to the cluster user group, and should be in the local users group

    - the account has local log on permission


    Qiufang Shi

    Tuesday, 24 April 2018 11:09 PM
  • Hi,

    Thanks for the answer. Although I have done many clustering things on linux, I am pretty new to windows HPC pack. So, maybe the questions are so simple. I opened "Cluster GUI"->"Configuration"->"Users"->"Add user" and entered the username.

    What is "Add job operator" then? Should I add there too?

    As you can see in the first picture, I can not add the local login for the user. The buttons are disabled.

    Wednesday, 25 April 2018 5:07 PM
  • Please check this: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/hpc-server-2012-R2-and-2012/ff919445(v=ws.11)

    If you can't change it, I think it is your domain policy. You need contact your domain admin. From your snapshot, "Users" group is not in the allowed list thus job user may not be able to run on this node. Administrators group is in the list, thus your cluster admin shall be able to run the job.


    Qiufang Shi

    Wednesday, 25 April 2018 7:17 PM
  • Excuse me. I am getting confused about that. From control panel, I allowed the user to access the local machine as you can see in the picture below


    However, as you can see below, when I want to allow local login via local security policy, the button is disabled. What does that mean? Which one truly allows the user to login locally?

    Thursday, 26 April 2018 9:52 AM
  • Hi,

      this usually means you have a Domain policy that prevent the users group local logon permission. you can take a check on this: https://social.technet.microsoft.com/Forums/windowsserver/en-US/703499eb-90e9-4bbc-a6df-d0e93d30811e/log-on-locally-gpo?forum=winserverGP 


    Qiufang Shi

    Monday, 30 April 2018 4:33 PM